Page MenuHomePhabricator

Display categories while printing articles again
Closed, DeclinedPublic

Description

Problem

Previously we printed categories as pipe separated blocks. However, now they are hidden. @Fomafix (and possibly others) think they shouldn't be hidden. Should these be shown?

@Nirzar says "Not sure how useful these are for regular readers. The downside is it takes space and in some cases waste an entire page if you are printing it on paper"

Solution

  • Evaluate the usefulness of categories while printing articles on Wikipedia

IF they are useful

  • Style categories to indicate the difference between structured data and content

Design

CSS

.catlinks {
    overflow: hidden;
    margin-top: 20px;
}

// FIXME: Overflow hidden is just a hack for Clearfix since I'm floating all LIs

.catlinks ul {
    list-style-type: none;
    margin: 0;
}
.catlinks ul li {
    float: left;
    display: inline-block;
    border: 1px solid #999;
    color: #000;
    border-radius: 40px;
    margin: 3px;
}

.catlinks ul li a {
    border: none;
    padding: 0px 8px;
    font-size: 8pt;
    font-weight: bold;
}


#mw-normal-catlinks > a {
    font-family: "Charis SIL", serif;
    border: none;
    font-weight: bold;
    font-size: 21px;
    
}
NOTE: Make sure Hidden categories are hidden on print
#mw-hidden-catlinks{
    display: none;
}

Related Objects

Event Timeline

Nirzar created this task.Jul 21 2017, 1:01 AM
Nirzar removed the point value for this task.
Nirzar updated the task description. (Show Details)

in zhwiki, categories is hide while printing articles

@Shizhao Thank you for pointing that out.

Apart from common solutions for all wikis, individual wikis can override these things per project basis! regardless, i would like to know the reason behind hiding categories. based on my knowledge, categories are supposed to be used for organization and exploration, both of which cannot be done when you print something.

Nirzar updated the task description. (Show Details)Jul 21 2017, 2:17 AM
matmarex removed a subscriber: matmarex.Jul 22 2017, 7:43 PM
Jdlrobson renamed this task from Display categories while printing articles to Display categories while printing articles again.Jul 27 2017, 3:53 PM
Jdlrobson added a project: Regression.
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Fomafix.
Nirzar closed this task as Declined.Aug 11 2017, 5:51 PM
Nirzar added subscribers: Jan_Dittrich, TheDJ.

From Wikimania 2017 conversation with

@Jan_Dittrich, @TheDJ , @ovasileva

We are going to decline this task until someone proves the value of showing this in Print use case. We recommend particular users who want this as a specific use case and should add the css written in description to their user styles.