Page MenuHomePhabricator

New filters for edit review can't be opt-out on some wikis
Closed, ResolvedPublic

Description

Remove this https://m.mediawiki.org/wiki/Special:MyLanguage/Edit_Review_Improvements/New_filters_for_edit_review changes from urwiki we (and some other wikis) are facing many problems like preferences activation (preferences changes are not saving), and even we can't use HotCat.
Also hindiwiki (hi.wikipedia) and many other wiki facing same problem. twinkle, hotcat etc. dnt work on hiwiki.


Seen on wikis for hi, ur, bn, mr languages.
Apparently due to T177478: Unable to change user settings.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 6 2017, 9:58 AM
BukhariSaeed updated the task description. (Show Details)Oct 6 2017, 10:02 AM
Aklapper added a subscriber: Trizek-WMF.

Hi @BukhariSaeed, thanks for taking the time to report this!
I am sorry for the problems you are facing. Can you please be more specific about these problems, so a developer can investigate?
Please see how to https://www.mediawiki.org/wiki/How_to_report_a_bug for steps. Thanks!

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptOct 6 2017, 10:32 AM

I am also facing the same problem. Today when I open hiwikiversity. I got the message in Recent Changes from edit Review improvement. Then I have seen that all the gadgets are automatically disabled. When I want to enable the gadget. The Enable not happening.

And Edit Review improvement message coming every time. When I visit Recent Changes

This comment was removed by BukhariSaeed.

@BukhariSaeed Sorry, I don't know. I think this is enabled default on all wiki.

I think all wikis are facing same problem (per jayprakash).

BukhariSaeed updated the task description. (Show Details)Oct 6 2017, 11:29 AM
BukhariSaeed added a comment.EditedOct 6 2017, 11:34 AM

@Jayprakash12345 Yes! same issues on urwiki, gadgets are automatically disabled and enabling of gadget is'nt working.

i have facing same problem on hiwiki

Jayprakash12345 triaged this task as Unbreak Now! priority.Oct 6 2017, 12:00 PM

How we can enable our local wiki gadgets.

Jayprakash12345 lowered the priority of this task from Unbreak Now! to High.Oct 6 2017, 12:01 PM

Sorry

BukhariSaeed renamed this task from Remove New filters for edit review from urwiki to Remove New filters for edit review from wikis.Oct 6 2017, 12:01 PM

I have changed the task name because i think all wikis have same problem. Shalom aleichem!

YmKavishwar updated the task description. (Show Details)Oct 6 2017, 12:29 PM

i have added information related about hiwiki in description.

Trizek-WMF lowered the priority of this task from High to Medium.Oct 6 2017, 12:44 PM

I have changed the task name because i think all wikis have same problem. Shalom aleichem!

That's not the case. Some wiki are apparently experiencing it, not all.

Please see T177478: Unable to change user settings, which apparently the source of the problem.

Trizek-WMF renamed this task from Remove New filters for edit review from wikis to New filters for edit review can't be opt-out on some wikis.Oct 6 2017, 12:46 PM
Trizek-WMF updated the task description. (Show Details)
BukhariSaeed updated the task description. (Show Details)Oct 6 2017, 1:18 PM

We are facing many problems on urwiki and no gadget is working. Please do the correction.

We are facing many problems on urwiki and no gadget is working. Please do the correction.

I've just left a message on your wiki about it.

So far, investigations are proving that filters are not the cause but the problem is bigger (and tracked on T177478).

YmKavishwar added a comment.EditedOct 6 2017, 3:24 PM

If possible make it high priority, becouse user facing big problem. Do not able to maintain wiki bcouse twincle etc. Do not work. Hindi wiki facing big problem related with vandalism. User not able to fight to vadal without using twincle.
Hotcat etc. Some basic gedget. Its not working so user facing big problem to edit wikipedia.
Also recent changes related pop up box coming every visit of recent changes page.
User tired to face it.
Its need very high priority to solve the problem.

@YmKavishwar, the highest priority is set for the parent task (T177478) which has to be solved before fixing that one. If the parent task is solved, you will be able to save your preferences and get the tools back. We know how difficult it can be for you and we do all we can to solve it quickly.

Trizek-WMF updated the task description. (Show Details)Oct 6 2017, 4:06 PM

@YmKavishwar, the highest priority is set for the parent task (T177478) which has to be solved before fixing that one. If the parent task is solved, you will be able to save your preferences and get the tools back. We know how difficult it can be for you and we do all we can to solve it quickly.

ok. thanks.

BukhariSaeed closed this task as Resolved.Oct 7 2017, 5:14 AM