Page MenuHomePhabricator

Composer\Downloader\TransportException in CI builds for multiple repositories
Closed, ResolvedPublic

Description

Example MediaWiki core build:

12:16:30   [Composer\Downloader\TransportException]                                                                                                                                     
12:16:30   The "https://packagist.org/p/provider-latest%246760aba1bc237ab9d18b5c819fea3ab689abaef67db86ae67f78830cfebce931.json" file could not be downloaded (HTTP/1.1 404 Not Found)

Example Wikibase build:

12:17:30   [Composer\Downloader\TransportException]                                                                                                                              
12:17:30   The "http://packagist.org/p/provider-2016%24e6f26a3fa2ea1261459b39ffa1f461ca4fb2ae031d46b8ecb204fc2bdb38bd1c.json" file could not be downloaded (HTTP/1.1 302 Found)

Other examples:

Note that the HTTP code varies, though I would be surprised if it’s actually tied to the different repositories. A few builds also still seem to be passing, so this seems to be somewhat flaky (though my impression is that the majority of builds fail).

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 21 2019, 12:28 PM
Lucas_Werkmeister_WMDE triaged this task as Unbreak Now! priority.Jun 21 2019, 12:28 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 21 2019, 12:28 PM
hashar added a subscriber: hashar.Jun 21 2019, 12:49 PM

I am pretty sure that is an issue with packagist.org and its CDN. Some file must be stalled :-\

I haven’t managed to reproduce this locally yet – I tried running COMPOSER_VENDOR_DIR=$(mktemp -d /tmp/vendor-XXXXXX) COMPOSER_CACHE_DIR=/dev/null composer install --prefer-dist a few times but it always succeeded.

In some builds (example), the initial composer install succeeds but then this fails:

14:07:08 INFO:quibble.cmd:vendor.git used. Requiring composer dev dependencies
14:07:08 DEBUG:quibble.cmd:composer require mediawiki/mediawiki-phan-config=0.6.0 psy/psysh=0.9.9 giorgiosironi/eris=^0.10.0 jakub-onderka/php-console-highlighter=0.3.2 monolog/monolog=~1.24.0 symfony/yaml=3.4.28 phpunit/phpunit=4.8.36 || ^6.5 wikimedia/testing-access-wrapper=~1.0 wikimedia/avro=1.8.0 jakub-onderka/php-parallel-lint=0.9.2 cache/integration-tests=0.16.0 hamcrest/hamcrest-php=^2.0 nikic/php-parser=3.1.5 nmred/kafka-php=0.1.5 johnkary/phpunit-speedtrap=^1.0 | ^2.0 wmde/hamcrest-html-matchers=^0.1.0 composer/spdx-licenses=1.5.1 seld/jsonlint=1.7.1 justinrainbow/json-schema=~5.2 mediawiki/mediawiki-codesniffer=26.0.0
14:07:10 
14:07:10                                                                                                                                                                         
14:07:10   [Composer\Downloader\TransportException]                                                                                                                              
14:07:10   The "http://packagist.org/p/provider-2016%24e6f26a3fa2ea1261459b39ffa1f461ca4fb2ae031d46b8ecb204fc2bdb38bd1c.json" file could not be downloaded (HTTP/1.1 302 Found)

I’m not sure if there’s something significant about that composer require or if this is just random.

Tgr added a subscriber: Tgr.Jun 21 2019, 2:53 PM

See T182266: Error "TransportException 404 Not Found" in Jenkins jobs using composer for similar issues in the past. Sometimes it was due to upstream problems, sometimes not.

See T182266: Error "TransportException 404 Not Found" in Jenkins jobs using composer for similar issues in the past. Sometimes it was due to upstream problems, sometimes not.

Thanks! And someone else already pinged the GitHub issue mentioned there, so it looks like this isn’t limited to Wikimedia people and therefore likely an upstream problem this time.

It seems that the symptoms have eased.

Seems so, tried several rechecks at several patches, no build failed (yet? :-D).

Jdforrester-WMF closed this task as Resolved.Jun 24 2019, 5:42 PM

Yeah, this appears to have fixed itself upstream.

For setting up a packagist.org mirror there is T203529

mmodell changed the subtype of this task from "Task" to "Production Error".Wed, Aug 28, 11:05 PM