Page MenuHomePhabricator

Regression: Visited links on mobile appearing as black
Closed, ResolvedPublic0 Estimated Story PointsBUG REPORT

Description

Steps to replicate the issue (include links if applicable):

What happens?:
Link is now black

What should have happened instead?:

Software version (skip for WMF-hosted wikis like Wikipedia):

Other information (browser name/version, screenshots, etc.):

https://phabricator.wikimedia.org/T356928#9530669

QA Results - Prod

ACStatusDetails
1T356928#9530669

Event Timeline

Change 998594 had a related patch set uploaded (by Jdlrobson; author: Jdlrobson):

[mediawiki/skins/MinervaNeue@master] color-link-visited was not defined

https://gerrit.wikimedia.org/r/998594

Change 998594 merged by jenkins-bot:

[mediawiki/skins/MinervaNeue@master] color-link-visited was not defined

https://gerrit.wikimedia.org/r/998594

Edtadros added a subscriber: Edtadros.

@Jdlrobson, I'm unable to replicate this.

We demoed the issue in task sync. Let me know if you need more help.

Can someone please fix this? As an editor who edits on the mobile site, this is a serious problem. It makes it very hard to figure out what is and is not linked. Several times today I have opened the edit menu to add a link, only to discover that said link was already there.

Change 998974 had a related patch set uploaded (by Jdlrobson; author: Jdlrobson):

[mediawiki/skins/MinervaNeue@wmf/1.42.0-wmf.17] color-link-visited was not defined

https://gerrit.wikimedia.org/r/998974

Not marking this as a UBN, but we should backport this as soon as we can.

Change 998974 merged by jenkins-bot:

[mediawiki/skins/MinervaNeue@wmf/1.42.0-wmf.17] color-link-visited was not defined

https://gerrit.wikimedia.org/r/998974

Mentioned in SAL (#wikimedia-operations) [2024-02-09T16:57:50Z] <logmsgbot> lucaswerkmeister-wmde@deploy2002 Started scap: Backport for [[gerrit:998974|color-link-visited was not defined (T356928)]]

Mentioned in SAL (#wikimedia-operations) [2024-02-09T16:59:20Z] <logmsgbot> lucaswerkmeister-wmde@deploy2002 jdlrobson and lucaswerkmeister-wmde: Backport for [[gerrit:998974|color-link-visited was not defined (T356928)]] synced to the testservers (https://wikitech.wikimedia.org/wiki/Mwdebug)

Mentioned in SAL (#wikimedia-operations) [2024-02-09T17:11:04Z] <logmsgbot> lucaswerkmeister-wmde@deploy2002 Finished scap: Backport for [[gerrit:998974|color-link-visited was not defined (T356928)]] (duration: 13m 13s)

Edtadros removed Edtadros as the assignee of this task.EditedFri, Feb 9, 11:02 PM
Edtadros added a project: Verified.

Test Result - Prod

Status: ✅ PASS
Environment: mediawiki
OS: macOS Sonoma
Browser: Chrome
Device: MBA
Emulated Device:NA

Test Artifact(s):

QA Steps

Visit https://m.mediawiki.org/wiki/MediaWiki or
Open , multilingual in a new tab
Refresh page
✅ AC1: Link should not be black and should show as visited.

screenshot 228.mov.gif (466×782 px, 567 KB)

Jdlrobson claimed this task.