Page MenuHomePhabricator

Deleting a translation unit page doesn't remove the corresponding content from the translation page
Closed, ResolvedPublic

Description

If you delete a single translation unit page, the translation page won't be updated to reflect this until another translation unit page is edited.
The easiest way is actually to do it yourself by replacing the translation with the source text and deleting the unit page only after it.

Niklas said it's a bug (now removing from docs).

Details

Reference
bz39415

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz39415.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.Aug 16 2012, 7:00 AM

Story: As a wiki administrator, when I delete the page for a unit of a translatable page, I have to be able to rely on the translatable page to be updated, so that it properly reflects the translation status and vandal fighting, etc, can be done relatively easily.

Requirement: When deleting a page that is a unit in a translatable page, that translatable page has to be updated after deletion.

  • Bug 53343 has been marked as a duplicate of this bug. ***

Change 151861 had a related patch set uploaded by Kunalgrover05:
Update translation pages on deleting translation unit

https://gerrit.wikimedia.org/r/151861

Change 151861 merged by jenkins-bot:
Update translation pages on deleting translation unit

https://gerrit.wikimedia.org/r/151861

Change 154953 had a related patch set uploaded by Kunalgrover05:
Update translation pages on deleting translation unit

https://gerrit.wikimedia.org/r/154953

Patch in last comment is still awaiting review.

revi added a subscriber: revi.Dec 30 2014, 4:12 PM

Change 154953 had a related patch set uploaded (by Nemo bis):
Update translation pages on deleting translation unit

https://gerrit.wikimedia.org/r/154953

Patch-For-Review

Still happening

Yes, the patch is stuck on a request for tests.

Stryn added a subscriber: Stryn.Apr 15 2015, 5:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2016, 8:02 AM

Hey, can someone give me a pointer on how to proceed with respect to the tests on the patch?

Nikerabbit updated the task description. (Show Details)Apr 13 2016, 1:38 PM
Qgil removed a subscriber: Qgil.Apr 13 2016, 2:41 PM
Nemo_bis closed this task as Resolved.May 6 2016, 12:22 PM
Nemo_bis added a project: User-notice.

Change 154953 merged by jenkins-bot:
Update translation pages upon deleting translation unit

https://gerrit.wikimedia.org/r/154953

Nemo_bis assigned this task to Kunal.
Nemo_bis reassigned this task from Kunal to Kunalgrover05.
Nemo_bis added a subscriber: Kunal.
Trizek-WMF raised the priority of this task from Normal to Needs Triage.
Nemo_bis triaged this task as Normal priority.May 7 2016, 8:43 AM