[Story] show diffs for ordering changes
Closed, InvalidPublic

Description

When changing the order of statements it should be shown inside of the diff.

Details

Reference
bz57918
bzimport raised the priority of this task from to High.
bzimport set Reference to bz57918.
bzimport added a subscriber: Unknown Object (MLST).

durgasubramanian94 wrote:

I would like to work on this bug, could someone please assign it to me?

@Dorgu: Unfortunately this still requires some extensive discussion about how to actually do it because it is quite tricky. If this is your first Wikidata bug I think it would be much better for you if you chose another one. https://bugzilla.wikimedia.org/buglist.cgi?keywords=need-volunteer%2C%20&keywords_type=allwords&emailcc1=1&resolution=---&emailtype1=exact&emailassigned_to1=1&query_format=advanced&email1=wikidata-bugs%40lists.wikimedia.org&list_id=162515 has a lot of better ones.

That being said you're of course welcome to just start hacking on this but please be aware that this is a very hard one.

(In reply to Lydia Pintscher from comment #2)

@Dorgu: Unfortunately this still requires some extensive discussion about
how to actually do it because it is quite tricky.

Lydia: As this ticket is "highest priority", has this discussion taken place in the meantime? If not, what is the rough timeframe and who can be expected to lead this discussion?

No, we have postponed this to be part of the UI redesign.

(In reply to Lydia Pintscher from comment #4)

No, we have postponed this to be part of the UI redesign.

If it's postponed, could you set a lower priority here?

aude added a comment.Apr 5 2014, 7:09 AM

I just came across this issue when editing Wikidata and it's *ugly* and confusing!

at least we could say the "order of statements changed", without waiting for UI redesign.

For whenever we implement more for the diff...

I also expect to see in the "before" side of diff view:

  • statement above the one I moved (prior to reordering), maybe in collapsed / summary format "main snak property / value"
  • statement that i moved
  • statement following the one I moved (prior to reordering)

In "after" side of diff:

  • statement above the one I moved (after reordering), maybe in collapsed / summary format "main snak property / value"
  • statement that i moved
  • statement following the one I moved (after reordering)

Normally I think people would reorder just one statement, but if they reorder more than one then show multiple sets of what I describe above.

  • Bug 63730 has been marked as a duplicate of this bug. ***
  • Bug 64585 has been marked as a duplicate of this bug. ***

Can the diff at least say "There are sorting changes which are not displayed" as an interim solution?

Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher renamed this task from show diffs for sorting changes to show diffs for ordering changes.Dec 27 2014, 3:45 PM
Lydia_Pintscher set Security to None.
Lydia_Pintscher updated the task description. (Show Details)
Jonas renamed this task from show diffs for ordering changes to [Story] show diffs for ordering changes.Aug 13 2015, 4:50 PM
Jonas updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 13 2015, 4:50 PM
Jonas updated the task description. (Show Details)Aug 13 2015, 4:50 PM
Jonas added a project: TestMe.
Jonas added a subscriber: Jonas.

Check the current state of this for:

  • statements
  • refernces
  • qualifiers
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptDec 14 2016, 10:03 AM
Lydia_Pintscher closed this task as Invalid.Dec 14 2016, 10:25 AM

We are sticking to a global sort order so I think this is no longer relevant.