Page MenuHomePhabricator

Null edits should not be saved in posts, topic titles, descriptions, summaries
Closed, ResolvedPublic

Description

Example: http://en.wikipedia.beta.wmflabs.org/w/index.php?title=Topic:Sk5vp4t1ixkkt4bc&action=history

In that edit: User:Test3544535452 edits the topic title, and hit save, without making any actual changes.

This "no-change action" currently would not get saved in the database, with regular wikipages (see [[WP:Null edit]]). It shouldn't in Flow, either.

This also happens in posts:
https://www.mediawiki.org/w/index.php?title=Topic:Sm56a9q3oa7enyxr&action=compare-post-revisions&topic_newRevision=sm7mynnx1c7j2mo2

And in summaries:
http://test.wikimedia.beta.wmflabs.org/w/index.php?title=Talk:ET4&action=history

A null edit should be ignored and not saved as an edit.

Note that this is also used as a workaround for T59991: Changes in templates are not immediately reflected in Flow posts which transclude those templates (and similar issues), so possibly should be fixed in conjunction.

See also: T98127: null edits on Flow posts are registered in history

Details

Reference
bz58975
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:27 AM
bzimport set Reference to bz58975.
bzimport added a subscriber: Unknown Object (MLST).
Quiddity created this task.Dec 26 2013, 7:53 PM

bingle-admin wrote:

The WMF core features team tracks this bug on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/658, but people from the community are welcome to contribute here and in Gerrit.

Ciencia_Al_Poder renamed this task from Flow: If no content is changed, the revision should not be saved to Flow: Topic title edit: If no content is changed, the revision should not be saved.Jul 10 2015, 12:30 PM
Ciencia_Al_Poder updated the task description. (Show Details)
Ciencia_Al_Poder set Security to None.
Ciencia_Al_Poder removed a subscriber: wikibugs-l-list.
DannyH renamed this task from Flow: Topic title edit: If no content is changed, the revision should not be saved to Null edits should not be saved in posts, topic titles, summaries.Aug 2 2015, 12:05 AM
DannyH updated the task description. (Show Details)
DannyH removed subscribers: EBernhardson, Spage.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 2 2015, 12:05 AM

Still happening

:

Mattflaschen-WMF renamed this task from Null edits should not be saved in posts, topic titles, summaries to Null edits should not be saved in posts, topic titles, descriptions, summaries.Aug 27 2015, 8:41 PM
Catrope reopened this task as Open.Sep 23 2015, 11:33 PM
Catrope added a subscriber: Catrope.

Duped this in the wrong direction.

Change 241142 had a related patch set uploaded (by Sbisson):
Ignore null edits for topic title, post, description, and summary

https://gerrit.wikimedia.org/r/241142

Change 241142 merged by jenkins-bot:
Ignore null edits for topic title, post, description, and summary

https://gerrit.wikimedia.org/r/241142

https://gerrit.wikimedia.org/r/#/c/241142/ Ignore null edits for topic title, post, description, and summary

Checked all those items in betalabs - 'View history' seems to be free now from those null edits.

DannyH closed this task as Resolved.Sep 30 2015, 5:17 PM
DannyH added a subscriber: DannyH.

The history reports the second edit as +22.

But the diff reports no difference.

@mattflaschen is 99.9% sure this is caused by T115236: Flow posts being serialized from HTML -> WT without providing Parsoid data-parsoid attributes?

Will do comparison in wikitext to avoid these problems.

The revisions have slightly different html representations. One has title="mw:talk:Flow" while the other has title="mediawikiwiki:talk:Flow".

<p id="mwAQ">Hello Shizhao,</p>
<p id="mwAg"><a rel="mw:ExtLink" href="//www.mediawiki.org/wiki/Flow/Request Flow on a page" title="mw:Flow/Request Flow on a page" id="mwAw">Following your request</a>, your talk page has been converted to Flow. The previous page is archived, with a link on the sidebar. </p>
<p id="mwBA">If you have any feedback to provide, please leave a message <a rel="mw:ExtLink" href="//www.mediawiki.org/wiki/talk:Flow" title="mw:talk:Flow" id="mwBQ">on MediaWiki</a> in any language or contact me.</p>
<p id="mwBg">Have fun!</p>
<p id="mwAQ">Hello Shizhao,</p>
<p id="mwAg"><a rel="mw:ExtLink" href="//www.mediawiki.org/wiki/Flow/Request Flow on a page" title="mediawikiwiki:Flow/Request Flow on a page" id="mwAw">Following your request</a>, your talk page has been converted to Flow. The previous page is archived, with a link on the sidebar. </p>
<p id="mwBA">If you have any feedback to provide, please leave a message <a rel="mw:ExtLink" href="//www.mediawiki.org/wiki/talk:Flow" title="mediawikiwiki:talk:Flow" id="mwBQ">on MediaWiki</a> in any language or contact me.</p>
<p id="mwBg">Have fun!</p>

Change 246249 had a related patch set uploaded (by Sbisson):
Check for null edits using wikitext format

https://gerrit.wikimedia.org/r/246249

Change 246249 merged by jenkins-bot:
Check for null edits using wikitext format

https://gerrit.wikimedia.org/r/246249

Checked in betalabs.

The fix successfully catches

  • white spaces:

  • moving chunk of text

Still failing in summaries after rEFLW48aea31224dcfae3232ec1d97f3f734316c03f70 got merged (not sure if it was fixing that):

Topic:Sq8d47itaqbchwqh

Catrope closed this task as Resolved.Nov 22 2015, 11:03 PM

Still failing in summaries after rEFLW48aea31224dcfae3232ec1d97f3f734316c03f70 got merged (not sure if it was fixing that):
Topic:Sq8d47itaqbchwqh

Interesting! Looks like it's possible to create an empty topic summary. Because that's not technically the same as a null edit, I've filed that as T119349: Creating empty summaries should not be allowed.