Make sure all Wikimedia online spaces have binding and enforceable anti-harassment policies
Open, NormalPublic

Description

https://wikimediafoundation.org/wiki/Friendly_space_policy is a useful tool to prevent and act upon unfriendly behavior in Wikimedia events. What about expanding the scope to Wikimedia online spaces? At the end of the year, most wikimedians spend a lot more time in online collaboration spaces than in face to face meetings, risk of harassment and other flavors of unfriendliness are just as high.

I guess there have been discussions about this topic in the past. The purpose of this task is to document the current status and to decide whether it is a good idea or not to expand the scope of the current Friendly Space Policy.

See also:

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes
Qgil added a comment.Jan 28 2015, 9:27 PM

It would be useful to have an overarching policy for all our online collaboration spaces, just like we have it for all our offline activities. It would focus on user interaction, collaboration spaces: discussion pages, mailing lists, Phabricator...

mailing lists are not on-wiki, and mediawiki.org or meta or whatever wiki in whatever language might or might have not such on-wiki policies.

That said, I fully agree that statements are only statements until there is a will to point to them and enforce them. Having one common policy for all is more useful than having to find and learn the peculiar norms agreed in each space.

I can say that in the context of the technical community we have help defining and maintaining the Friendly Space Policy and the Bugzilla (now Phabricator) etiquette, and our team has been actively using these policies in many situations. I think they have helped having a friendlier context in our channels and activities, but then when we jump outside from this area to other wikis or mailing lists I personally feel less entitled, with a less stable foundation under my feet, to tell someone when an attitude is unhelpful or plain unacceptable.

Tgr added a subscriber: Tgr.Jan 28 2015, 10:26 PM
Qgil triaged this task as "Normal" priority.Feb 2 2015, 1:13 PM
Qgil assigned this task to Rfarrand.Feb 4 2015, 7:54 AM

Assigning this task to @Rfarrand since she is one of the owners of the Friendly Space Policy. She is the one to decide the future of this task, of course after checking with LCA and other stakeholders.

Krenair added a subscriber: Krenair.Mar 2 2015, 9:01 PM

I'm in favor of some sort of policy, but I question whether the policy is the issue or whether it's more about willingness to enforce extant ones. I doubt there's much here that isn't covered already in other policies on-wiki, is there?

All our online spaces should have a binding civility policy (though I realize getting there takes work), with enforcement mechanisms (which may vary by space). However, not all do. E.g.:

And people have used the lack of binding policies to attempt to cover their uncivil behavior in our online spaces.

I agree enforcement of existing policies in this area needs to be better. But that is not the only issue.

Qgil edited the task description. (Show Details)Mar 5 2015, 2:06 PM
Qgil edited the task description. (Show Details)Mar 20 2015, 11:47 AM
Qgil edited the task description. (Show Details)Mar 25 2015, 9:08 AM
Pine added a subscriber: Pine.Apr 4 2015, 6:46 AM
Pine added a subscriber: Ocaasi.EditedApr 4 2015, 6:49 AM

There seems to be some interest in this subject on the Gender Gap mailing list.

@Ocaasi recommended reading "This Is Why We Can't Have Nice Things: Mapping the Relationship between Online Trolling and Mainstream Culture" (Information Society Series)

If there is to be an online version of the policy it will need community ratification of some kind on the community-run wikis like English Wikipedia, where any WMF-led imposition of policy is likely to be viewed at best with skepticism if not outright hostility, especially after the MediaViewer situation. It makes sense to me that we would have a friendly space policy, but WMF's role in creating it would be as facilitator rather than legislator. The policy would also need to be reconciled with relevant local interpretations of civility, which may vary among cultures.

That said, I agree with Jimbo that people who are toxic to projects in the sense of creating such a hostile environment that other productive members of the community get exasperated or quit, should be politely and firmly shown the door. Jimbo shared some good ideas for how to do this in his speech at Wikimania.

Qgil added a comment.Apr 6 2015, 2:44 PM

With +800 wikis and counting, I think we need a default pushed by someone, and then freedom to each project to customize.

A parallel track, or a tactical step in that direction, could be to expand the Phabricator etiquette to the rest of online technical channels: mediawiki.org, wikitech.wikimedia.org, Gerrit, mailing lists, and IRC. All these channels have the same scope, form a continuum, share a big percentage of actors and topics, and default to English.

This etiquette (born as Bugzilla etiquette) vas co-created by several contributors of different affiliations, and it has proven to be useful in Bugzilla and Phabricator. Would there be a reason not to expand it further to the rest of tech channels? Should we create a task specific for this?

Nemo_bis closed this task as "Declined".EditedApr 6 2015, 3:08 PM
Nemo_bis added a subscriber: Nemo_bis.

This is not an appropriate place where to discuss policy proposals for Wikimedia projects. please bring your proposal on an appropriate venue, like [[m:Wikimedia Forum]] or [[m:Talk:Terms of use]].

In the meanwhile, I note that https://meta.wikimedia.org/wiki/Terms_of_use#4._Refraining_from_Certain_Activities WORKSFORME.

Pine reopened this task as "Open".Apr 6 2015, 9:54 PM
Pine added a comment.EditedApr 6 2015, 9:59 PM

@Nemo_bis People can discuss policy modifications wherever they like. However, I would agree that any actual RfCs that may emerge from this discussion should be held on-wiki.

@Qgil Freenode IRC is independent of the Wikimedia Foundation and many channels are governed solely by community members and, indirectly, Freenode staff. Any attempt to impose WMF policies on IRC would be met with even more resistance than WMF attempts to impose policies on community wikis without consent. On the other hand, if there is community acceptance of new policies, then the community may choose to apply those policies to IRC channels.

I think a possible way forward with this discussion is to draft a friendly space policy and then open an RfC. This process may be slow and difficult but the results are more likely to be accepted by the community.

@Qgil Freenode IRC is independent of the Wikimedia Foundation and many channels are governed solely by community members and, indirectly, Freenode staff. Any attempt to impose WMF policies on IRC would be met with even more resistance than WMF attempts to impose policies on community wikis without consent. On the other hand, if there is community acceptance of new policies, then the community may choose to apply those policies to IRC channels.

Where resistance is just WMF getting completely ignored, yeah. It doesn't have any ultimate say over the IRC channels, that lies with Freenode and the individuals who run each channel. You'll need to convince the operators of each channel you'd like this to apply to.

Nemo_bis removed a subscriber: Nemo_bis.Apr 7 2015, 7:49 AM
Qgil added a subscriber: Nemo_bis.Apr 7 2015, 12:54 PM

It is true that "harassment", which is the main focus of the Friendly Space Policy, is included there. Something that the Terms of Use don't say is what happens when a user breaks them.

Still, reading again both documents, I think we need to work further on the gap between "harassment" and "friendly". There is a wide margin of toxic communication that probably cannot be considered harassment but is still clearly unfriendly, and this margin is affecting existing and new contributors.

The Phabricator Etiquette is more useful for dealing with this level of unfriendliness, both at identifying undesired behavior and at proposing specific responses to resolve conflicts. Maybe it's the spirit of the Phabricator Etiquette what needs expanding to other online channels instead of the Friendly Space Policy, or maybe consolidate both in a single friendly policy for simplicity?

"WMF attempts to impose policies on community wikis without consent" is not something we should aim for, certainly. Considering that the situation is Wikimedia Phabricator is satisfactory, what do you think about continuing with the expansion ot the Etiquette to Gerrit? Then mediawiki.org and wikitech.wikimedia.org (including Labs). Then the technical mailing lists (to be decided how, even if one by one). IRC channels are different, fine. We'll see what to do (if anything needs to be done) when we get there.

Pine added a comment.Apr 8 2015, 12:55 AM

An incremental approach that is specific to the tech community might make sense. Gerrit sounds like a good next step.

The further away the "friendly space" concept moves from WMF-led projects like Phabricator and toward community-led projects like content wikis (including Meta), the more important it is to get community support and consent.

I would be asking @GYoung to comment if she was still with us. Terence never responded to my questions on Wikimedia-l, and I'm not sure what to make of that; he might be internally focused so projects like a community-facing friendly space policy might be outside of his scope. That means that @Philippe-WMF may be the best WMF-side facilitator for engaging the community, and perhaps there could be some kind of incremental RfC process on Meta.

Nemo_bis removed a subscriber: Nemo_bis.Apr 8 2015, 6:24 AM
Elena added a subscriber: Elena.Apr 8 2015, 5:50 PM

I believe that engaging the community in creating friendly-space policies across the projects is outside the scope of both hr and operations, which are both internal facing.

Additionally, HR has not adopted phabricator as a team due to the confidential-nature of some of our projects, so most of hr probably isn't following your proposal.

This etiquette (born as Bugzilla etiquette) vas co-created by several contributors of different affiliations, and it has proven to be useful in Bugzilla and Phabricator. Would there be a reason not to expand it further to the rest of tech channels? Should we create a task specific for this?

Yes, I think that may be a good idea.

Where resistance is just WMF getting completely ignored, yeah. It doesn't have any ultimate say over the IRC channels, that lies with Freenode and the individuals who run each channel. You'll need to convince the operators of each channel you'd like this to apply to.

Some of the channels (e.g. #wikimedia-collaboration or #wikimedia-tech), are more extensions of the Wikimedia technical community then extensions of the on-wiki community (naturally, they overlap), so it probably makes more sense for these channels to be governed by the former's friendly space policies.

This task was part of ECT-March-2015, and it is still open and assigned. Assuming that it belongs to ECT-April-2015 as well. Otherwise please edit accordingly.

In T87773#1085406, @Mattflaschen wrote:

All our online spaces should have a binding civility policy (though I realize getting there takes work), with enforcement mechanisms (which may vary by space).

My experience on the English Wikipedia is that cultural differences in what's considered civil make any attempt at writing or enforcing policies incredibly difficult. I imagine the issue is only amplified in groups of developers/programmers/tech-minded people, if other parts of the Internet are any indication. What you find offensive many others might find mild. It seems like that's part of the nature of the Internet.

It's not really the place of individual Wikimedia Foundation employees to try to tell members of the volunteer Wikimedia community how to behave. The Wikimedia community consists of your colleagues.

However, not all do. E.g.:

  • I believe MediaWiki.org has no binding civility policy.

Feel free to propose one, if you'd like, it's a wiki after all. You can be bold. :-) But as @Nemo_bis indicates, you can't make binding wiki policy outside of the wiki. As it is, I think nobody has seen the need for such a document on mediawiki.org; unless there's evidence of a problem, I'm not sure proposing a solution is a good idea. However, that's your battle, not mine, to fight on the wiki, if you so choose.

That page is specifically intended to be a series of guidelines. Both the subject-space page and the talk page use the term "guidelines" repeatedly as evidence of this. The guidelines are not binding, they're guidelines.

And people have used the lack of binding policies to attempt to cover their uncivil behavior in our online spaces.

Hmm, there's a concern that people might use bogus incivility claims to try to stifle discussion and disagreement. I'm not sure what you mean by people using the lack of a policy in an attempt to cover behavior. What does that mean, exactly? How can someone use the lack of something to cover something? It sounds impressive.

My experience on the English Wikipedia is that cultural differences in what's considered civil make any attempt at writing or enforcing policies incredibly difficult. I imagine the issue is only amplified in groups of developers/programmers/tech-minded people, if other parts of the Internet are any indication. What you find offensive many others might find mild. It seems like that's part of the nature of the Internet.

It's not really the place of individual Wikimedia Foundation employees to try to tell members of the volunteer Wikimedia community how to behave. The Wikimedia community consists of your colleagues.

+1

now I suddenly find myself wishing phabricator had a "Like" button on comments.

Nemo_bis removed a subscriber: Nemo_bis.Apr 18 2015, 4:42 AM
Qgil added a comment.Apr 20 2015, 10:22 AM

My experience on the English Wikipedia is that cultural differences in what's considered civil make any attempt at writing or enforcing policies incredibly difficult. I imagine the issue is only amplified in groups of developers/programmers/tech-minded people, if other parts of the Internet are any indication. What you find offensive many others might find mild. It seems like that's part of the nature of the Internet.

I think the basic concept of friendliness is quite universal, and even if describing it with words is difficult, I think most humans recognize when a situation is moving from friendly to hostile.

The argument of leaving things as they are is easier to sustain when being in a position of strength, with a background, attitude, skills, and demographics favoring you in the context of an hypothetical discussion. This is probably why many veteran contributors (who have survived many situations and have got a thick skin) tend to favor the status quo. However, the perspective of others may differ, especially among the ones that for whatever reasons will be in a weaker position in a hypothetical hostile situation.

When things go ugly, many stare silently, many walk away. As long as this is a problem in the engineering community, I think it's worth to work on it and encourage others to join as well (T95999).

It's not really the place of individual Wikimedia Foundation employees to try to tell members of the volunteer Wikimedia community how to behave. The Wikimedia community consists of your colleagues.

This is not about WMF employees telling volunteers how to behave. Hostile attitudes may come from anybody and be directed to anybody. In events, the same policy applies to all, and the same principle could applied to our online channels as well.

That page is specifically intended to be a series of guidelines. Both the subject-space page and the talk page use the term "guidelines" repeatedly as evidence of this. The guidelines are not binding, they're guidelines.

Personally, I'm fine continuing with principles and guidelines. When they are backed by the community, they are stronger than nominal binding policies. What matters is to bring those principles and guidelines as soon as hostility arises, which until now has worked quite well here in Wikimedia Phabricator.

In T87773#1085406, @Mattflaschen wrote:

All our online spaces should have a binding civility policy (though I realize getting there takes work), with enforcement mechanisms (which may vary by space).

My experience on the English Wikipedia is that cultural differences in what's considered civil make any attempt at writing or enforcing policies incredibly difficult.

Writing an encyclopedia is also incredibly difficult. Incredibly difficult things can be done with the right motivation.

I imagine the issue is only amplified in groups of developers/programmers/tech-minded people, if other parts of the Internet are any indication. What you find offensive many others might find mild. It seems like that's part of the nature of the Internet.

Essentially anyone is able to speak in a way that someone (when the listener is acting in good-faith) from another culture finds civil. At first there may be cultural misunderstandings, but that doesn't mean they can't be worked past.

It's not really the place of individual Wikimedia Foundation employees to try to tell members of the volunteer Wikimedia community how to behave. The Wikimedia community consists of your colleagues.

This is just the beginning of a discussion, not the end. And as you can see, not everyone participating here is a WMF employee.

However, not all do. E.g.:

  • I believe MediaWiki.org has no binding civility policy.

Feel free to propose one, if you'd like, it's a wiki after all. You can be bold. :-) But as @Nemo_bis indicates, you can't make binding wiki policy outside of the wiki.

Per above, Phabricator has been clear from day-one that it's not only for technical tasks. Any task can be discussed here. Implementation is often elsewhere (just like features are not actually implemented on Phabricator).

As it is, I think nobody has seen the need for such a document on mediawiki.org; unless there's evidence of a problem, I'm not sure proposing a solution is a good idea.

You now know that I see such a need.

That page is specifically intended to be a series of guidelines. Both the subject-space page and the talk page use the term "guidelines" repeatedly as evidence of this. The guidelines are not binding, they're guidelines.

Hence 'should', not 'is binding'.

Nemo_bis removed a subscriber: Nemo_bis.Apr 23 2015, 8:40 AM
AlexWang added a comment.EditedAug 4 2015, 10:55 PM

The new Friendly space expectations are now live on the Meta-wiki Grants namespace. These expectations are not a policy, but guidelines for how we expect people to engage in discussions about grant requests and reports, as well as program evaluation. The first version was successfully piloted during the Inspire Campaign and now we're expanding it. https://meta.wikimedia.org/wiki/Grants:Friendly_space_expectations

Also, we created guidelines and template for action: https://meta.wikimedia.org/wiki/Grants:Friendly_space_expectations/Guidelines_and_templates

Qgil added a comment.Aug 5 2015, 5:07 PM

It is interesting to see how this effort by Grants and T90908: Goal: Binding code of conduct for all Wikimedia technical spaces with consequences for breaches have progressed in the past weeks. Thank you!

Qgil added a comment.Aug 14 2015, 8:31 AM

This task is Normal priority and assigned, but I think it would be better to lower the priority and put it aside in order to focus all the attention to in T90908: Goal: Binding code of conduct for all Wikimedia technical spaces with consequences for breaches. In fact, we could even mark this task Open Stalled, blocked by T90908?

Aklapper changed the task status from "Open" to "Stalled".
Aklapper lowered the priority of this task from "Normal" to "Low".

Makes a lot of sense to me to reflect where the current focus is hence I was bold and went ahead.

jayvdb added a subscriber: jayvdb.Aug 14 2015, 1:31 PM
mmodell removed a subscriber: mmodell.Aug 14 2015, 7:43 PM
Qgil moved this task from Backlog to Team radar on the Community-Liaisons board.Jan 13 2016, 1:25 AM
Mattflaschen-WMF changed the title from "Expand Friendly Space Policy to all Wikimedia online spaces" to "Make sure all Wikimedia online spaces have binding and enforceable anti-harassment policies".
Mattflaschen-WMF removed Rfarrand as the assignee of this task.
Mattflaschen-WMF reopened this task as "Open".
Mattflaschen-WMF raised the priority of this task from "Low" to "Normal".