Inconsistent parameter names for action=mobileview when you compare with action=parse
Open, NormalPublic


The core ApiParse supports disablepp, disableeditsection and disabletoc, but MobileFrontend adds noimages.
We should deprecate the noimages parameter – since we're extending a core API – in favour of the new and improved disableimages parameter.

Ricordisamoa updated the task description. (Show Details)
Ricordisamoa raised the priority of this task from to Needs Triage.
Ricordisamoa added a project: MediaWiki-API.
Ricordisamoa added a subscriber: Ricordisamoa.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 13 2015, 9:03 PM
Anomie added a subscriber: Anomie.May 14 2015, 3:12 AM

ApiParse does not have a "noimages" parameter.

MobileFrontend does add such a parameter, though.

Anomie set Security to None.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptMay 14 2015, 3:12 AM

@Anomie sorry for having overlooked that!

Ricordisamoa updated the task description. (Show Details)May 14 2015, 9:53 AM
phuedx added a subscriber: phuedx.May 15 2015, 4:08 PM

Deprecate the noimages parameter – since we're extending a core API – in favour of the new and improved disableimages parameter.

phuedx added subscribers: BGerstle-WMF, bearND.

Mobile-Apps folks (@BGerstle-WMF, @bearND) : do you use the noimages parameter in any of your requests?

@phuedx Yes, the Android app uses that parameter if the user has selected to not show images.

OK. Then part of this task should be ensuring that Mobile-Apps is notified that the noimages parameter has been deprecated.

Jdlrobson updated the task description. (Show Details)Aug 4 2015, 6:37 PM
Jdlrobson moved this task from Backlog to Bugs on the MobileFrontend board.
Jhernandez triaged this task as Normal priority.Aug 17 2015, 11:19 AM

I found this ticket while doing a bit of grooming on the neglected Mobile-Apps board a week or so ago, and I have to admit I'm a bit confused. The noimagesparameter isn't marked as deprecated in MobileFrontend, and there is no disableimages parameter (though there is apparently a cookie of that name). We've been happily using noimages for the year+ since this ticket was filed.

Is it still valid? Should we stop using noimages?

OK, I think I finally understand what's going on. This was originally a task about naming consistency, but then took a 90-degree turn and became about not using the noimages param. disableImages is a cookie and always has been, and we should use it instead of noimages (presumably to avoid splitting the cache).

For anyone with expertise and opinions on such matters, a friendly debate inspired by this task over how to handle image disabling in the Android app is happening over at

@Mholloway: This task isn't that noimages is deprecated, it's that someone thinks that it should be deprecated and disableimages created to be used instead for consistency with the core ApiParse parameters.

If a "disableImages" cookie changes how the page is parsed, it needs to split the cache (and then I'd say a cookie isn't the right way to do it). Otherwise visitor A comes along with the cookie set, the lacking-images response is cached, then visitor B comes along without the cookie but gets the cached output that lacks images anyway. Or vice versa.

@Anomie Oh, I was under the impression from T120151 that we (now) knew how to vary the cache based on disableImages.

(I'm sure my understanding of cache variation is incomplete at best, but I think this means multiple copies of a given page that vary on specific criteria are cached to be served from the same URL.)

Yes, it appears from T120151 that the cache is varied on that cookie; I was mainly responding to your "presumably to avoid splitting the cache" comment there, which is the exact opposite of what T120151 was about.

OK, I think I understand.

In any case, there doesn't appear to be anything else for us to do here other than note that deprecating noimages is under discussion; noted. (For the record, the iOS app doesn't use it.)

Jdlrobson renamed this task from Inconsistent parameter names for action=parse to Inconsistent parameter names for action=mobileview when you compare with action=parse.Aug 1 2017, 4:40 PM