Page MenuHomePhabricator

CX2: ContentTranslation adapts some references only partially
Closed, ResolvedPublic

Description

When translating the article Sleep (non-human) from English to Hungarian, some references are partially adapted, missing some parameters. For example:

Source with English Cite journal template:

<ref>{{cite journal | last1 = Zhdanova | first1 = I.V. | last2 = Wang | first2 = S.Y. | last3 = Leclair | first3 = O.U. | last4 = Danilova | first4 = N.P. | display-authors = etal   | year = 2001 | title = Melatonin promotes sleep-like state in zebrafish, ''Brain Research'' 903: 263–268. Yokogawa T, Marin W, Faraco J, Pézeron G, Appelbaum L, ''et al.'' (2007) Characterization of Sleep in Zebrafish and Insomnia in Hypocretin Receptor Mutants | url = | journal = PLoS Biology | volume = 5 | issue = 10| page = e277 | doi = 10.1371/journal.pbio.0050277 }} [http://biology.plosjournals.org/perlserv/?request=read-response&doi=10.1371/journal.pbio.0050277 and criticism and rebuttal, at ''PLoS Biology'']</ref>

Translation with Hungarian Cite journal template:

<ref>{{Cite journal|year=2001|title=Melatonin promotes sleep-like state in zebrafish, ''Brain Research'' 903: 263–268. Yokogawa T, Marin W, Faraco J, Pézeron G, Appelbaum L, ''et al.'' (2007) Characterization of Sleep in Zebrafish and Insomnia in Hypocretin Receptor Mutants|journal=PLoS Biology|volume=5|issue=10|pages=e277|doi=10.1371/journal.pbio.0050277|url=}} [http://biology.plosjournals.org/perlserv/?request=read-response&doi=10.1371/journal.pbio.0050277 and criticism and rebuttal, at ''PLoS Biology'']</ref>

The adaptation is not perfect. For example, the important last1 parameter (The surname of the author) is not adapted . I don't know if it's an issue with incomplete TemplateData adaptation or a bug in CX2, but it's definitely not what was happening in CX1 where much of the reference text was lost.

Details

Related Gerrit Patches:
mediawiki/services/cxserver : masterTemplate mapping: Use the citoid map in templatedata

Event Timeline

Amire80 created this task.May 21 2015, 6:15 PM
Amire80 raised the priority of this task from to Medium.
Amire80 updated the task description. (Show Details)
Amire80 added a project: ContentTranslation.
Amire80 added subscribers: Amire80, santhosh, Elitre.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 21 2015, 6:15 PM
Amire80 moved this task from Needs Triage to CX6 on the ContentTranslation board.Jun 25 2015, 11:13 PM
Amire80 set Security to None.
Amire80 moved this task from CX6 to CX7 on the ContentTranslation board.Sep 16 2015, 2:24 PM
Amire80 added a comment.EditedOct 8 2015, 5:42 PM

Another example: translating from https://en.wikipedia.org/wiki/Chevron_butterflyfish to https://de.wikipedia.org/wiki/Benutzer:Amire80/cb .

Notice how the references are transferred, but become shorter.

Amire80 moved this task from CX8 to CX9 candidates on the ContentTranslation board.Feb 8 2016, 5:51 PM

Not sure if this is the same problem - if not, please feel free to split it off: When translating from English to Dutch, many references become messy, because the fields in the reference templates don't transfer properly. However, there's no warning given about this.

Part of the problem seems to be that information gets lost as well. See https://nl.wikipedia.org/w/index.php?title=Reince_Priebus&oldid=47977771 as example.

Not the exact same problem, but in any case this will change completely very soon, as we'll deploy a huge patch that completely changes the way templates are handled. We've been promising this for a few months already, but it's really close now :)

OK, happy to be a guinea pig at that point ;)

@Amire80 out of curiosity, when will 'very soon' be? :) I'd love to get started with translating some articles again, but all the extra work in fixing references is a bit of a turn-off :)

This should already be better now, see https://cxupdate.wordpress.com/2016/11/30/new-template-editor/ . This bug here is probably not relevant any more, but I'll try to test it again.

There are still some problems with references, however, see T152444. Briefly, while the template handling is improved, it still cannot be fully controlled by the editor. That will probably be coming after full migration to Visual Editor (T105447).

Effeietsanders added a comment.EditedJan 6 2017, 10:55 AM

Confirmed, the bug is still there: references in translations are still very messy. Some problems I encountered:

  • moving references to another location in the translation is not possible
  • If the paragraph ends with a reference, it is not possible to type after it.
  • if the reference uses cite-web, it gives nasty errors in the translated document which then have to be addressed manually

(happy to post in another ticket if that is more appropriate)

There is a whole bunch of issues with references, and they are being worked on.

This one does seems to still exist, unfortunately, although it's hard to pinpoint, because every article is different. But this revision, for example, has Rochman, Sue (November 20, 2007). where English has Rochman, Sue (November 20, 2007). [http://www.advocate.com/article.aspx?id=22181 What's up, doc? Would removing transgender from the list of mental disorders do more harm than good?] ''[[The Advocate]]'', which is very close to the original report.

A very similar example, possibly the same problem: https://fr.wikipedia.org/w/index.php?title=Croissance_non-%C3%A9conomique&oldid=136488114

Note that the source English article has footnotes with full titles of books and not only the author name "Daly".

Framawiki renamed this task from ContentTranslation adapts references only partially in "Sonno negli animali" to ContentTranslation adapts references only partially.Apr 22 2017, 2:58 PM
Framawiki added a subscriber: Framawiki.

@Amire80, if this can be reproduced in CX2, can you add "CX2: " to the title, move to the "CX2" column, and set this as a sub-task of T200786?
Thanks.

Well, here is how it works in CX2, when translating from English to Hungarian:

Source:

<ref>{{cite journal | last1 = Zhdanova | first1 = I.V. | last2 = Wang | first2 = S.Y. | last3 = Leclair | first3 = O.U. | last4 = Danilova | first4 = N.P. | display-authors = etal   | year = 2001 | title = Melatonin promotes sleep-like state in zebrafish, ''Brain Research'' 903: 263–268. Yokogawa T, Marin W, Faraco J, Pézeron G, Appelbaum L, ''et al.'' (2007) Characterization of Sleep in Zebrafish and Insomnia in Hypocretin Receptor Mutants | url = | journal = PLoS Biology | volume = 5 | issue = 10| page = e277 | doi = 10.1371/journal.pbio.0050277 }} [http://biology.plosjournals.org/perlserv/?request=read-response&doi=10.1371/journal.pbio.0050277 and criticism and rebuttal, at ''PLoS Biology'']</ref>

Translation:

<ref>{{Cite journal|year=2001|title=Melatonin promotes sleep-like state in zebrafish, ''Brain Research'' 903: 263–268. Yokogawa T, Marin W, Faraco J, Pézeron G, Appelbaum L, ''et al.'' (2007) Characterization of Sleep in Zebrafish and Insomnia in Hypocretin Receptor Mutants|journal=PLoS Biology|volume=5|issue=10|pages=e277|doi=10.1371/journal.pbio.0050277|url=}} [http://biology.plosjournals.org/perlserv/?request=read-response&doi=10.1371/journal.pbio.0050277 and criticism and rebuttal, at ''PLoS Biology'']</ref>

The adaptation is not perfect. For example, the important last1 parameter is not adapted, but it's better than . I don't know if it's an issue with incomplete TemplateData adaptation or a bug in CX2, but it's definitely not what was happening in CX1.

So the old issue probably doesn't happen, but it would be nice if somebody who understands CX2 template adaptation could take a closer look.

Pginer-WMF renamed this task from ContentTranslation adapts references only partially to CX2: ContentTranslation adapts some references only partially.Sep 5 2018, 10:59 AM
Pginer-WMF updated the task description. (Show Details)

I updated the description to make it a relevant ticket for CX2. We may want to check again on this once some planned improvements are completed on the reference mapping front such as T203550 which may be related.

Pginer-WMF updated the task description. (Show Details)Sep 5 2018, 11:05 AM
santhosh claimed this task.Sep 27 2018, 5:14 AM
santhosh moved this task from Backlog to In Progress on the Language-2018-July-September board.

Change 462449 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Template mapping: Use the citoid map in templatedata

https://gerrit.wikimedia.org/r/462449

After the above patch, you can see that all params are mapped to target language(hu)

Change 462449 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Template mapping: Use the citoid map in templatedata

https://gerrit.wikimedia.org/r/462449

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-10-15T05:16:28Z] <kartik@deploy1001> Started deploy [cxserver/deploy@fd74c3b]: Update cxserver to b51f363 (T203077, T99934, T203550)

Mentioned in SAL (#wikimedia-operations) [2018-10-15T05:20:53Z] <kartik@deploy1001> Finished deploy [cxserver/deploy@fd74c3b]: Update cxserver to b51f363 (T203077, T99934, T203550) (duration: 04m 25s)

Etonkovidova closed this task as Resolved.Oct 31 2018, 10:45 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked in wmf.1 - the template is adopted in huwiki (Yandex MT option) ехацтлы as it's represented in enwiki:

I checked other cases

Note: If the following text with reference from enwiki is just copied to huwiki, the citejournal will be displayed as in the ticket:

For example, [[zebrafish]],<ref>{{cite journal | last1 = Zhdanova | first1 = I.V. | last2 = Wang | first2 = S.Y. | last3 = Leclair | first3 = O.U. | last4 = Danilova | first4 = N.P. | display-authors = etal   | year = 2001 | title = Melatonin promotes sleep-like state in zebrafish, ''Brain Research'' 903: 263–268. Yokogawa T, Marin W, Faraco J, Pézeron G, Appelbaum L, ''et al.'' (2007) Characterization of Sleep in Zebrafish and Insomnia in Hypocretin Receptor Mutants | url = | journal = PLoS Biology | volume = 5 | issue = 10| page = e277 | doi = 10.1371/journal.pbio.0050277 }} [http://biology.plosjournals.org/perlserv/?request=read-response&doi=10.1371/journal.pbio.0050277 and criticism and rebuttal, at ''PLoS Biology'']</ref>

Pasted in huwiki:

Pasted in enwiki:

Elitre removed a subscriber: Elitre.Nov 8 2018, 5:02 PM