Page MenuHomePhabricator

[Tracking] Track descriptions usages separately (Create a new description usage aspect "D")
Closed, ResolvedPublic

Description

Descriptions can currently only be accessed directly via the Entity data structure, as obtained via [[ https://www.mediawiki.org/wiki/Extension:Wikibase_Client/Lua#mw.wikibase.getEntity | mw.wikibase.getEntity ]]. This means they are tracked using the X or O aspect for now; given we will track which part of the Entity data structure is actually used (T90436), we we should track description usage separately, using a new D aspect.

Steps to get this rolled out:

  • Create the usage aspect
  • Add 'D' to $wgWBClientSettings['disabledUsageAspects'] (T177153)
  • Make mw.wikibase.description and mw.wikibase.getDescriptionWithLang add a description usage along with the other usage (T177154)
  • Deploy description usage tracking for Lua (513f79bf94a560d3baa736e12d06eba55165ff1a)
  • Remove 'D' from $wgWBClientSettings['disabledUsageAspects'] test-wise on a few wikis (all small wikis, elwiki, …) (T177155)
  • Evaluate data from T177155
  • Remove 'D' from $wgWBClientSettings['disabledUsageAspects'] on a few more wikis (T178515)
  • Remove 'D' from $wgWBClientSettings['disabledUsageAspects'] on ruwiki
  • Remove 'D' from $wgWBClientSettings['disabledUsageAspects'] on all wikis (except commons)
  • Remove 'D' from $wgWBClientSettings['disabledUsageAspects'] on commons (this might be the wiki where this has the biggest effect)
  • Use compact representation of diffs in EntityChange. (T113468)
  • Make AffectedPagesFinder take description usage into account (T176417)
  • No longer save other usage along

Related Objects

Event Timeline

hoo created this task.Jul 19 2015, 5:10 PM
hoo raised the priority of this task from to Medium.
hoo updated the task description. (Show Details)
hoo added subscribers: Bianjiang, Candalua, aude and 20 others.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 19 2015, 5:10 PM
JanZerebecki renamed this task from Track descriptions usages separately to [Task] Track descriptions usages separately.Sep 10 2015, 7:52 PM
JanZerebecki set Security to None.
JanZerebecki moved this task from incoming to ready to go on the Wikidata board.
jmadler added a subscriber: jmadler.Jan 6 2016, 5:13 AM
daniel updated the task description. (Show Details)Aug 2 2017, 1:04 PM
Restricted Application added a subscriber: PokestarFan. · View Herald TranscriptAug 2 2017, 1:04 PM
hoo renamed this task from [Task] Track descriptions usages separately to [Task] Track descriptions usages separately (Create a new description usage aspect "D").Aug 13 2017, 3:26 PM
hoo updated the task description. (Show Details)
hoo added a subscriber: eranroz.
Candalua removed a subscriber: Candalua.Aug 13 2017, 5:12 PM
hoo claimed this task.Sep 27 2017, 9:59 PM
hoo moved this task from Proposed to Doing on the Wikidata-Former-Sprint-Board board.

Change 381140 had a related patch set uploaded (by Hoo man; owner: Hoo man):
[mediawiki/extensions/Wikibase@master] Add EntityUsage::DESCRIPTION_USAGE for descriptions

https://gerrit.wikimedia.org/r/381140

thiemowmde moved this task from Review to Doing on the Wikidata-Former-Sprint-Board board.
thiemowmde added a subscriber: thiemowmde.

Change 381140 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Add EntityUsage::DESCRIPTION_USAGE for descriptions

https://gerrit.wikimedia.org/r/381140

hoo updated the task description. (Show Details)Oct 13 2017, 9:13 AM
hoo updated the task description. (Show Details)Oct 18 2017, 5:29 PM
hoo updated the task description. (Show Details)Oct 20 2017, 10:01 AM
hoo updated the task description. (Show Details)Oct 23 2017, 12:22 PM
hoo added a comment.Oct 23 2017, 10:48 PM

We finally have our first descriptions usages at nowiki (caused by https://no.wikipedia.org/wiki/Modul:Wikibase_signature, invoked by https://no.wikipedia.org/w/index.php?title=Mal:Wikidata_egenskapslenke&action=edit)! The description is used there to add additional context to a link's title attribute.

thiemowmde renamed this task from [Task] Track descriptions usages separately (Create a new description usage aspect "D") to [Tracking] Track descriptions usages separately (Create a new description usage aspect "D").Oct 26 2017, 2:40 PM
Ladsgroup updated the task description. (Show Details)Dec 1 2017, 2:57 PM

@hoo Ok if Amir goes ahead and makes the remaining changes in the description?

Change 395584 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[operations/mediawiki-config@master] Enable description usage tracking for all wikis except commons

https://gerrit.wikimedia.org/r/395584

Change 395584 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable description usage tracking for all wikis except commons

https://gerrit.wikimedia.org/r/395584

Mentioned in SAL (#wikimedia-operations) [2017-12-06T00:36:24Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:395584|Enable description usage tracking for all wikis except commons]] T106287 (duration: 00m 48s)

Ladsgroup updated the task description. (Show Details)Dec 6 2017, 12:44 AM

Change 396090 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[operations/mediawiki-config@master] Start description usage tracking for commonswiki

https://gerrit.wikimedia.org/r/396090

Change 396090 merged by jenkins-bot:
[operations/mediawiki-config@master] Start description usage tracking for commonswiki

https://gerrit.wikimedia.org/r/396090

Mentioned in SAL (#wikimedia-operations) [2017-12-07T19:35:00Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:396090|Start description usage tracking for commonswiki]] T106287 (duration: 00m 48s)

Ladsgroup closed this task as Resolved.Dec 8 2017, 12:16 PM
Ladsgroup updated the task description. (Show Details)
Ladsgroup removed a project: Patch-For-Review.