Remove Flow from Wikipedia talk:WikiProject Breakfast on enwp
Closed, ResolvedPublic

Description

The RFC at Wikipedia talk:Wikiproject Breakfast on the English Wikipedia has concluded, with consensus that the test installation of Flow at that location should be removed, restoring it to being a normal talk page. Can that please be done.

Scott created this task.Jan 6 2016, 3:12 PM
Scott updated the task description. (Show Details)
Scott raised the priority of this task from to Normal.
Scott added a project: StructuredDiscussions.
Scott added a subscriber: Scott.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 6 2016, 3:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptJan 6 2016, 5:09 PM
Alsee added a subscriber: Alsee.Jan 7 2016, 12:08 AM

As the final step of the Trial, I am interested to see the outcome of the software for converting all of the the Flow discussions back to Talk format. Thanx.

Scott added a comment.EditedJan 7 2016, 1:46 AM

As the final step of the Trial, I am interested to see the outcome of the software for converting all of the the Flow discussions back to Talk format. Thanx.

Great point. Can anyone link to any public pages about the tool/process for that?

As the final step of the Trial, I am interested to see the outcome of the software for converting all of the the Flow discussions back to Talk format.

@Alsee: Could you please bring up general Flow questions / discussion on https://www.mediawiki.org/wiki/Talk:Flow as this Phabricator task is specifically about removing Flow from enwp's Wikipedia talk:WikiProject Breakfast. Thanks for your understanding!

Scott added a comment.Jan 7 2016, 5:37 PM

As the final step of the Trial, I am interested to see the outcome of the software for converting all of the the Flow discussions back to Talk format.

@Alsee: Could you please bring up general Flow questions / discussion on https://www.mediawiki.org/wiki/Talk:Flow as this Phabricator task is specifically about removing Flow from enwp's Wikipedia talk:WikiProject Breakfast. Thanks for your understanding!

It's a completely valid point here. If this removal is going to take place, it's going to affect real editors' content, and assurances need to be made as to how that's going to happen. There were two possible outcomes for the trial: either Flow would be accepted and retained, or declined and removed. Both contingencies should have been planned for.

A converttotext.php script exists, but needs some updates. I'll update this thread next week, with more details on that, when normal work resumes (post devsummit/allhands).

A converttotext.php script exists, but needs some updates. I'll update this thread next week, with more details on that, when normal work resumes (post devsummit/allhands).

We need to discuss as a team before we make any decisions regarding use of convertToText.php.

Begoon added a subscriber: Begoon.Jan 10 2016, 10:40 AM

The close was challenged, reviewed, and confirmed as correct: https://en.wikipedia.org/w/index.php?title=Wikipedia%3AAdministrators%27_noticeboard&type=revision&diff=699373873&oldid=699336258

Consensus to end Flow Trial at EN:WikiProject_Breakfast.

The script to export the structured Flow board to create an unstructured wikitext page is being updated and checked. The WikiProject Breakfast talk page will be switched over once that is ready. The existing Flow page will be moved to a subpage and protected, for detailed attribution purposes. Apologies that it will take longer than the 24hours stated 2 years ago.

Alsee added a comment.Jan 17 2016, 7:44 AM

@Quiddity, could you clarify the "detailed attribution" issue?

Ideally the conversion would use a series of synthetic edits to properly recreate the full history (as discussed in T96301). That idea appears to have been dropped because of the work involved and the (hopefully) limited use this converter is going to get. I'm willing to accept the current converter as adequate for the current limited use.

Are you saying that the WMF is unable to fully rollback this Flow trial? Are you saying there would be some legal issue if the archived Flow page were to be nominated for speedy deletion?

@Alsee The change back to wikitext contentmodel is as originally described. (Standard disclaimer for this is not legal advice) As with all pages, the history retained within the deleted page is sufficient for complete attribution. The recommendation to leave the Flow page visible, is just a recommendation. It would make comparison easier, and attribution more detailed. We were planning on creating the conversion page, moving the Flow page, and then let the Enwiki admins carry out the protection or deletion of the Flow page.

Alsee added a comment.Feb 18 2016, 8:46 AM

@Quiddity
Bug report: The Edit Description link disappeared from at https://en.wikipedia.org/wiki/Wikipedia_talk:WikiProject_Breakfast/Flow_archive

I was trying to place a deletion tag on it, per the discussion above. I'll post on Admin Noticeboard.

@Quiddity
Bug report: The Edit Description link disappeared from at https://en.wikipedia.org/wiki/Wikipedia_talk:WikiProject_Breakfast/Flow_archive

I was trying to place a deletion tag on it, per the discussion above. I'll post on Admin Noticeboard.

Could that be because that page is protected?

Catrope closed this task as Resolved.Feb 18 2016, 5:39 PM
Catrope claimed this task.

Closing this task since Flow has in fact been removed from the Breakfast page.

@Quiddity
Bug report: The Edit Description link disappeared from at https://en.wikipedia.org/wiki/Wikipedia_talk:WikiProject_Breakfast/Flow_archive

I was trying to place a deletion tag on it, per the discussion above. I'll post on Admin Noticeboard.

Could that be because that page is protected?

Yes.

Alsee added a comment.EditedFeb 20 2016, 7:59 PM

My description of the bug was inaccurate because the bugs here themselves created confusion, and because Quiddity said in his earlier comment that the WMF was not going to be applying protection to the page.

Bug: The page history does not contain any entry for Page Protection. (I specifically checked for this before posting here, and this is why I concluded it wasn't a Protected-Page issue.) There's no indication anywhere that the page is protected.
Bug: There are still a links to post new threads, post a new replies, and to edit existing comments. Those links still open the editor, with no indication that the page is protected.
Bug: Clicking save in any of the above cases throws up a completely mangled error message.
Bug: When an Admin post on the page, they are given no warning that they are editing a Fully Protected page.
Possible Bug(?) I not an Admin so I can't check: Does the Edit Description link show up for Admins? It's definitely a bug if Admins can't Edit Description.

My description of the bug was inaccurate because the bugs here themselves created confusion, and because Quiddity said in his earlier comment that the WMF was not going to be applying protection to the page.

My apologies for that.

Bug: The page history does not contain any entry for Page Protection. (I specifically checked for this before posting here, and this is why I concluded it wasn't a Protected-Page issue.) There's no indication anywhere that the page is protected.

Looks like a regression. Filed as T127770: Log entries missing from Flow history pages

Bug: There are still a links to post new threads, post a new replies, and to edit existing comments. Those links still open the editor, with no indication that the page is protected.

Filed as T127774: On protected Flow pages, remove/replace action links, and/or inform users without sufficient rights to use them

Bug: Clicking save in any of the above cases throws up a completely mangled error message.

Covered by the above (which might need to be split into 1 or more sub-tasks).

Bug: When an Admin post on the page, they are given no warning that they are editing a Fully Protected page.

This is T108762: Notify users who are editing protected flow content.

Possible Bug(?) I not an Admin so I can't check: Does the Edit Description link show up for Admins? It's definitely a bug if Admins can't Edit Description.

It does show up.
Thank you for the details.