Page MenuHomePhabricator

Fix category headers for pages that begin with numbers
Closed, ResolvedPublic5 Story Points

Description

There is a bug where pages that start with numbers end up getting put under headers on the category pages that consist of weird Unicode characters, rather than the appropriate number. I don't have an example of this offhand, but it is mentioned at T8948#1919137. I think this only happens under ICU collation, but need to verify.

Related Objects

StatusAssignedTask
OpenNone
OpenNone
Resolvedtomasz
Resolvedhashar
Resolvedhashar
ResolvedJoe
ResolvedLegoktm
Declineddemon
ResolvedJoe
ResolvedReedy
ResolvedNone
OpenNone
ResolvedJoe
ResolvedNone
Resolvedkaldari
Resolvedkaldari
ResolvedNone
Resolvedkaldari
ResolvedJohan
ResolvedJoe
ResolvedJoe
ResolvedJoe
ResolvedJoe
Resolvedtstarling
ResolvedJoe
Resolvedkaldari
Resolvedjcrespo
ResolvedVolans
Resolvedaaron
InvalidNone
ResolvedNiharika
ResolvedJohan
DuplicateNone
OpenNone
Resolvedkaldari

Event Timeline

kaldari created this task.Mar 1 2016, 5:35 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptMar 1 2016, 5:35 PM
kaldari added a subscriber: Bawolff.Mar 1 2016, 5:36 PM

@Bawolff: Could you provide some more details about this bug?

kaldari updated the task description. (Show Details)Mar 1 2016, 5:51 PM
DannyH triaged this task as Normal priority.Mar 1 2016, 6:17 PM
DannyH set the point value for this task to 5.
DannyH moved this task from To be estimated/discussed to Estimated on the Community-Tech board.
DannyH added a subscriber: DannyH.Mar 3 2016, 6:42 PM

It would be for icu collation modified to use numeric sorting. It might depend on version of libicu. Im more assuming it happens. Havent really tested

It would be caused by a mismatch in the logic of firstLetterHeader over how numbers sort at a primary strength.

Since we don't have a reliable way to reproduce this at the moment, I'm going to switch the blocking order.

DannyH moved this task from Estimated to Bug backlog on the Community-Tech board.Mar 15 2016, 5:22 PM
kaldari closed this task as Resolved.Nov 19 2016, 2:00 AM
kaldari claimed this task.

Seems to be resolved.

kaldari moved this task from Bug backlog to Archive on the Community-Tech board.Nov 19 2016, 2:00 AM