Page MenuHomePhabricator

Get rid of Zend 5.5 tests for wmf branches
Closed, ResolvedPublic

Description

Once there are no more Zend PHP machines running in Wikimedia production there is no need to trigger the Zend-based tests for wmf branches.

With the recent introduction of MySQL the PHPUnit ones went from 6 to more than 10 minutes which is slowing down merges for no reason (T93556).

Details

Related Gerrit Patches:
integration/config : masterSkip php 5.5 for mediawiki wmf branches
integration/config : masterDrop transient Zuul rules
integration/config : masterwmf branches: drop mediawiki-core-phpcs-trusty

Related Objects

StatusAssignedTask
ResolvedReedy
ResolvedNone
ResolvedJoe
ResolvedJoe
ResolvedJoe
Resolvedtstarling
ResolvedJoe
Resolvedkaldari
Resolvedjcrespo
ResolvedVolans
Resolvedaaron
InvalidNone
DeclinedArielGlenn
ResolvedArielGlenn
Resolvedori
DeclinedNone
ResolvedMoritzMuehlenhoff
ResolvedJoe
ResolvedJoe
ResolvedJoe
ResolvedAndrew
ResolvedJoe
Duplicatefgiunchedi
Resolvedbrion
Resolvedbrion
Resolved bd808
ResolvedJoe
Resolvedfgiunchedi
ResolvedEBernhardson
ResolvedKrenair
ResolvedNone
Resolvedhashar
Resolvedtstarling
Resolvedtstarling
ResolvedLegoktm
ResolvedLegoktm
ResolvedLegoktm
ResolvedNone
ResolvedAnomie

Event Timeline

hashar created this task.Mar 27 2015, 10:56 AM
hashar raised the priority of this task from to Needs Triage.
hashar updated the task description. (Show Details)
hashar added a subscriber: hashar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 27 2015, 10:56 AM
Krinkle updated the task description. (Show Details)Mar 27 2015, 12:34 PM
Krinkle set Security to None.
Krinkle triaged this task as Normal priority.Mar 29 2015, 7:57 AM

Um, Wikimedia most certainly still uses Zend PHP, see T84842 for example.

hashar changed the task status from Open to Stalled.Oct 6 2015, 11:47 AM
Anomie added a subscriber: Anomie.Nov 24 2015, 3:22 PM

In T118932: RfC: Raise MediaWiki's PHP version requirement to 5.5 and update coding standards it looks like we're considering bumping the MediaWiki PHP version requirement to PHP 5.5, while HHVM currently seems to be aiming at 5.6. In the past it has been useful that unit tests are also run with something like our minimum target version of PHP to help avoid breaking compatibility.

Yep, this task is just about tests on the wmf deployment branches.

greg updated the task description. (Show Details)Nov 24 2015, 4:52 PM
greg awarded a token.

Oh, I misread it.

Anomie removed a subscriber: Anomie.Nov 24 2015, 5:22 PM

Yup this specific task is about removing the Zend based Jenkins jobs whenever the Wikimedia infrastructure has been fully migrated to HHVM. At this point we will no more care about Zend and that will speed up gate-and-submit for wmf branches.

I should show up at the RFC meeting tonight for T118932 .

hashar added a subscriber: ori.

@ori confirmed on T86081 that Zend 5.3 is gone:

In T86081#2012595, @ori wrote:

This task is a blocker for getting rid of Zend 5.3 Jenkins jobs for WMF branches and master branches deployed on Wikimedia infra ( T94149 ).
There is still three blockers, but they don't seem to have Zend 5.3 running still:
T98813: Move wikitech (silver) to HHVM
T94277: Convert snapshot hosts to use HHVM and trusty
T86096: Switch HAT appservers to trusty's ICU (or newer)
Can subscribers to this task please confirm the three task above are no more for migrating out of Zend 5.3? If nothing left running Zend 5.3 we will get rid of the related Jenkins jobs.

Yes, confirmed. Wikitech and the snapshot hosts are running 5.5.9, and T86096 is blocked by the migration, not blocking it.

So we can filter out Zend based jobs for wmf branches.

Krinkle added a subscriber: Krinkle.

Test must remain until HHVM roll out is complete, not the other way around.

Krinkle removed a subscriber: Krinkle.Feb 23 2016, 4:55 PM
hashar changed the task status from Stalled to Open.Mar 17 2017, 11:29 PM
hashar added subscribers: thcipriani, Paladox, demon, greg.

So triggering the PHP5 jobs might cover the corner case of code being run as maintenance script and we have a lot of it: job runners, getting all wikis configuration etc.

Emphasis is on might. Job runners don't run via runJobs anymore, it's a loop to the RPC endpoint now. I think the benefit is very minor. Let's just drop them

So we are going to remove Zend for wmf branches in the interest of lowering load on CI and speed up feedback/merge for wmf branch.

Talked about it again during the release engineering meeting. We believe that although maintenance script are still using Zend php5.5, running tests on every single patch is unlikely to catch any issue and thus have little purpose beside slowing down merges.

Change 344642 had a related patch set uploaded (by Hashar):
[integration/config@master] wmf branches: drop mediawiki-extensions-php55-trusty

https://gerrit.wikimedia.org/r/344642

Change 344643 had a related patch set uploaded (by Hashar):
[integration/config@master] wmf branches: drop mediawiki-core-phpcs-trusty

https://gerrit.wikimedia.org/r/344643

Change 344645 had a related patch set uploaded (by Hashar):
[integration/config@master] Drop transient Zuul rules

https://gerrit.wikimedia.org/r/344645

Change 344643 abandoned by Hashar:
wmf branches: drop mediawiki-core-phpcs-trusty

Reason:
Can be done with a generic rule .*php55.* .

https://gerrit.wikimedia.org/r/344643

Wikitech on silver still runs Zend php 5.5 :(

Change 344645 merged by jenkins-bot:
[integration/config@master] Drop transient Zuul rules

https://gerrit.wikimedia.org/r/344645

greg added a comment.Mar 27 2017, 5:33 PM

Wikitech on silver still runs Zend php 5.5 :(

I forget, why is that?

greg added a comment.Mar 27 2017, 7:00 PM

Wikitech on silver still runs Zend php 5.5 :(

I forget, why is that?

OSM :(

Change 344642 abandoned by Hashar:
Skip php 5.5 for mediawiki wmf branches

Reason:
We can't get rid of php 5.5 jobs yet :(

https://gerrit.wikimedia.org/r/344642

hashar changed the task status from Open to Stalled.Jun 6 2017, 2:26 PM

Stalled, pending completion of Zend -> HHVM migration.

EddieGP added a subscriber: EddieGP.Oct 1 2017, 8:27 PM

Should this be declined due to T176370?

Yeh, one should be filled for getting rid of the hhvm tests.

demon closed this task as Declined.Oct 2 2017, 10:45 PM
hashar reopened this task as Open.Oct 4 2017, 1:05 PM

That is to remove the Zend 5.5 based jobs. That is pending on https://gerrit.wikimedia.org/r/358896 Stop forcing php5 in mwscript

hashar renamed this task from Get rid of zend tests for wmf branches to Get rid of Zend 5.5 tests for wmf branches.Oct 4 2017, 1:05 PM

It's blocked on more than that - we still use PHP 5.5 for dumps and wikitech (silver).

Change 344642 restored by Hashar:
Skip php 5.5 for mediawiki wmf branches

https://gerrit.wikimedia.org/r/344642

Krinkle changed the task status from Open to Stalled.Apr 10 2018, 1:50 PM

This should be the last thing to happen in the chain of this tasks' parent (T190547), and should not happen until after Wikimedia no longer runs PHP5 with MediaWiki anywhere in production.

Jdforrester-WMF changed the task status from Stalled to Open.May 30 2018, 3:39 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

No longer stalled.

Jdforrester-WMF closed this task as Resolved.May 30 2018, 4:28 PM
Jdforrester-WMF assigned this task to Reedy.

Change 344642 abandoned by Hashar:
Skip php 5.5 for mediawiki wmf branches

Reason:
Obsolete.

https://gerrit.wikimedia.org/r/344642