Page MenuHomePhabricator

decom ytterbium (datacenter)
Closed, ResolvedPublic

Description

ytterbium has been shut down and removed from puppet, salt, icinga and DNS (except mgmt) (T125018)

after a short grace period, please start with physical decom and the lifecycle steps in datacenter

https://racktables.wikimedia.org/index.php?page=object&tab=default&object_id=1776

eqiad row C : C7

asset: WMF3566


This checklist is able to be copied and pasted into phabricator hardware request tasks for reclaiming systems to spare or decom.

  • - all system services confirmed offline from production use
  • - set all icinga checks to maint mode/disabled while reclaim/decommmission takes place.
  • - remove system from all lvs/pybal active configuration
  • - any service group puppet/heira/dsh config removed
  • - remove site.pp (replace with role::spare if system isn't shut down immediately during this process.)

START NON-INTERRUPPTABLE STEPS

  • - disable puppet on host
  • - remove all remaining puppet references (include role::spare)
  • - power down host
  • - disable switch port
  • - switch port assignment noted on this task (for later removal) (asw-c-eqiad:ge-7/0/24)
  • - remove production dns entries
  • - puppet node clean, puppet node deactivate, salt key removed

END NON-INTERRUPPTABLE STEPS

  • - system disks wiped (by onsite)
  • - system unracked and decommissioned (by onsite), update racktables with result
  • - mgmt dns removed
  • - switch port configration removed from switch once system is unracked..

Related Objects

Event Timeline

Dzahn created this task.Jul 27 2016, 2:21 AM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptJul 27 2016, 2:21 AM
Restricted Application added a subscriber: Southparkfan. · View Herald TranscriptJul 27 2016, 2:22 AM
Dzahn removed Dzahn as the assignee of this task.Aug 6 2016, 2:10 AM
demon added a subscriber: demon.Sep 1 2016, 10:11 PM

I think a month is plenty of grace period, let's kill this thing.

Dzahn awarded a token.Sep 1 2016, 10:59 PM
Dzahn updated the task description. (Show Details)Mar 10 2017, 11:13 PM
Dzahn updated the task description. (Show Details)
Dzahn updated the task description. (Show Details)Mar 10 2017, 11:18 PM
Dzahn assigned this task to RobH.Mar 10 2017, 11:20 PM
Dzahn added a subscriber: RobH.

@RobH this was an older decom task that was still open, i added the newer checklist now and checked the boxes after the fact. assigning to you to check if switch ports was done already since i know you are doing the general audit of decoms anyways. could you look and then forward to chris?

Dzahn updated the task description. (Show Details)Mar 10 2017, 11:21 PM
RobH reassigned this task from RobH to Cmjohnson.Mar 17 2017, 12:27 AM
RobH updated the task description. (Show Details)

The switch port was not disabled, so glad we're adding the checklist to any open decom tasks.

RobH updated the task description. (Show Details)Mar 17 2017, 12:29 AM
Cmjohnson lowered the priority of this task from Normal to Low.Mar 28 2017, 3:52 PM
Cmjohnson moved this task from Backlog to Not urgent on the ops-eqiad board.Apr 27 2017, 8:49 PM
Cmjohnson moved this task from Not urgent to Up next on the ops-eqiad board.May 4 2017, 6:15 PM
Cmjohnson closed this task as Resolved.May 9 2017, 3:25 PM
Cmjohnson updated the task description. (Show Details)

racktables updated