Page MenuHomePhabricator

Special:RecentChanges no longer displays interwiki links on wikis that have added them to MediaWiki:Recentchangestext
Closed, ResolvedPublic

Description

Take the Czech Wikipedia as an example: MediaWiki:Recentchangestext clearly has interwiki links but they no longer show up on Special:RecentChanges.

I'm pretty confident that this started happening a few hours ago (August 4).

Event Timeline

Srdjan_m created this task.Aug 3 2017, 11:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 3 2017, 11:13 PM

I also noticed the same behaviour since today.
Also T102888 (show interwikis from Wikidata on special pages) still has to be solved.

Srdjan_m renamed this task from Special:RecentChanges no longer displays a list of languages on wikis that have added interwiki links to MediaWiki:Recentchangestext to Special:RecentChanges no longer displays interwiki links on wikis that have added them to MediaWiki:Recentchangestext.Aug 4 2017, 3:04 PM
Srdjan_m updated the task description. (Show Details)

This is also happening in the Spanish projects (eswiki, eswikiversity, etc.)

This comment was removed by Srdjan_m.

Was this perhaps caused by https://gerrit.wikimedia.org/r/#/c/368358/ or some related change?

One workaround I've discovered is to move the interwiki links from MediaWiki:Recentchangestext‎ to MediaWiki:Recentchanges-summary‎.

Stryn added a subscriber: Stryn.Aug 6 2017, 8:30 AM
Elitre added a subscriber: Elitre.Aug 10 2017, 3:08 PM
Stryn added a comment.Aug 10 2017, 4:06 PM

One workaround I've discovered is to move the interwiki links from MediaWiki:Recentchangestext‎ to MediaWiki:Recentchanges-summary‎.

It works, but only if you use the local wiki language in your settings.

Was this perhaps caused by https://gerrit.wikimedia.org/r/#/c/368358/ or some related change?

CC'ing @Mooeypoo just in case that's somehow related.

MediaWiki:Recentchangestext‎ is an highly used page on thousands of wikis, this breaking change is unnecessarily disruptive. If the message cannot be moved back to its original location for some technical reason (standardisation of messake keys is not one), then the special page should be instructed to look up both locations.

I am looking at https://cs.wikipedia.org/wiki/Speci%C3%A1ln%C3%AD:Posledn%C3%AD_zm%C4%9Bny and I can see the MediaWiki:Recentchangestext message clearly.

Is this about the new "Recent Changes Enhanced Filters" perhaps? In this version, the MediaWiki:Recentchangestext appears collapsed (though it will 'remember' your setting if you open it) to save room:


(Collapsed)


(Expanded)

I do notice a little bug with the expand button/link when the list is expanded, though, but it doesn't happen in English Wikipedia, so I'll have to debug this further to fix it.

See example in English Wikipedia:

Are we talking about the RCFilters beta feature, or is there a bug I can't reproduce in general Special:RecentChanges without the beta feature on?

@Mooeypoo : this task is not about MediaWiki:Recentchangestext as a whole, but about interwiki links provided by it. Note that no interwiki links are present in your examples. They should be provided by MediaWiki:Recentchangestext page, they are part of the code (see https://cs.wikipedia.org/w/index.php?title=MediaWiki:Recentchangestext&action=edit). But nothing is displayed. This worked well a few weeks ago.

Special: pages don't display interwikilinks, unless if a hack is found. In this case, the hack is to transclude those links using MediaWiki:Recentchangestext.

This is a special case of T66969. Interwiki links act the same as ResourceLoader modules here (which that task talks about) – they are part of the "metadata" of the parser output. Previously, Special:RecentChanges parsed this message "manually", which caused the metadata to be included in the final page (using OutputPage::addWikiText()) – after change https://gerrit.wikimedia.org/r/#/c/368358/ (already linked above), it uses the more common method (Message::parse()) which loses the metadata.

Change 374345 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] SpecialRecentchanges: Restore ability to use language links in 'recentchangestext' message

https://gerrit.wikimedia.org/r/374345

This should be implemented fully automatically in the software (T123063: Special pages should link to all languages in a project.). MediaWiki knows, or should know, the canonical name of Special:RecentChanges on each Wikimedia wiki (same for any special page). And they should all be linked (Compact Language Links solves any UI cluttering issue).

But in the meantime, thanks to @matmarex for fixing the regression.

Change 374345 merged by jenkins-bot:
[mediawiki/core@master] SpecialRecentchanges: Restore ability to use language links in 'recentchangestext' message

https://gerrit.wikimedia.org/r/374345

For testing the fix the following was checked:

  • I added [[:ca:Canvis recents|cawiki interwiki link]] to MediaWiki:Recentchangestext on en.wikipedia.beta.wmflabs

  • the link is displayed & functions correctly on en.wikipedia.beta.wmflabs Special:Recentchanges page

Etonkovidova closed this task as Resolved.Aug 31 2017, 12:05 AM