Page MenuHomePhabricator

Notification numbers always grey in other skins - red/blue highlighting for new items only works in vector/monobook
Closed, ResolvedPublic

Description

In Vector and MonoBook, the notification badge numbers have highlighting red or blue to indicate unseen notifications, and becomes gray after clicking. In other skins, however, the badge numbers are always grey, regardless of new notifications.

This functionality should exist by default for all skins.

Expected (screenshot from MonoBook):

Anything else (screenshot from Example):

Note that some skins such as Minerva, Nimbus, and others with custom handling may not actually care because they don't use the default badges to begin with, but that's a bit beside the point.

Event Timeline

Is this a duplicate of T160653?

Is this a duplicate of T160653?

Possible. I do not know what "wrong colour" means. @Isarra?

Naw, 'wrong colour' was just that it doesn't match the colour scheme of timeless (different red, different blue/grey/whatever it all has). This is it not even using the right kind of colour. If the colours flat out aren't happening, this is an actual functionality bug, as opposed to me just griping as a designer.

Whoo, bugs.

eranroz removed a subscriber: eranroz.Nov 22 2017, 9:56 PM

Something that can be interesting for you: Our wiki (hewiki) has 3 badges - the regular two, and one our own, with number of unseen pages in watchlist. And the third one works very well - becomes green when needed and gray again when needed.

...huh. How was it added? Gadget?

...huh. How was it added? Gadget?

User script.

Isarra added a comment.Jul 7 2018, 9:25 PM

Apparently not really a problem with timeless; the echo notification number colours were only implemented for monobook/vector and simply do not appear in any other skins.

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 7 2018, 9:25 PM
Isarra renamed this task from Timeless notifications are already grey to Notification numbers always grey in other skins - red/blue highlighting for new items only works in vector/monobook.Jul 7 2018, 9:37 PM
Isarra updated the task description. (Show Details)
Isarra added a comment.Jul 7 2018, 9:50 PM

Leaving the Timeless project on this for tracking, since while it's not specific to Timeless, it does affect it.

Change 491757 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/extensions/Echo@master] Apply unseen notifications colours to all skins by default

https://gerrit.wikimedia.org/r/491757

Change 491757 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Apply unseen notifications colours to all skins by default

https://gerrit.wikimedia.org/r/491757

matmarex closed this task as Resolved.Mar 5 2019, 9:36 PM
matmarex assigned this task to Isarra.

Not sure this issue is resolved. I still do not see the icon in red and blue (they remain grey).

Should just be deployment lag. If it's still broken after thursday, please let us know.

Indeed, the color is now there. Thanks