Page MenuHomePhabricator

Make the user's preferred languages more prominent in interlanguage links list
Closed, ResolvedPublic

Description

Author: wardvanheddeghem

Description:
I am a Dutch speaker, and I use both the Dutch and English wikipedia. Many times I look at a topic in both languages, by clicking on the Dutch/English link in the language list on the left side. For a popular article, however, this list is quite long, and it takes some time to look up the language in the list.

SUGGESTION:
Therefore, it would be nice if I could set in the user preference pane some preferred languages (e.g. English, Dutch, French).

This list can then be used in various ways to improve the navigation experience of multilingual users:

  • colourize the preferred languages in the language list (so that I can find them very quickly)
  • or, always put (or repeat) these languages on top of the list
  • provide a link to the language main pages in the header bar

BTW: this bug report is similar to bug 11267 ('User should be able to set fallback language(s) in preferences') but not quite the same, so I decided to file a new bug report.


Version: unspecified
Severity: enhancement
Whiteboard: UniversalLanguageSelector-fixed

Details

Reference
bz16888

Related Objects

StatusAssignedTask
ResolvedAmire80
OpenNone
ResolvedNone
ResolvedAmire80
InvalidNone
ResolvedNemo_bis
DeclinedNone
ResolvedAmire80
ResolvedNone
ResolvedNemo_bis
Resolvedsanthosh
InvalidNone
ResolvedNemo_bis
ResolvedNiharika
ResolvedNemo_bis
ResolvedNone
InvalidNone
ResolvedNiharika
ResolvedNone
InvalidNone
DuplicateNone
DuplicateNikerabbit
DuplicateNikerabbit
Resolvedsanthosh
Duplicatesanthosh
ResolvedNikerabbit
Resolvedsanthosh
ResolvedKartikMistry
ResolvedKartikMistry
ResolvedNikerabbit
OpenKartikMistry
OpenArrbee
ResolvedArrbee
ResolvedAmire80
ResolvedTrizek-WMF
ResolvedNikerabbit
ResolvedAmire80
ResolvedArrbee
ResolvedKartikMistry

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:30 PM
bzimport set Reference to bz16888.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jan 5 2009, 11:28 AM

Interwiki links can be configured using a browser extension like https://addons.opera.com/nl/extensions/details/wikipedia-language-bubble/.

Please see http://www.mediawiki.org/wiki/ULS , a project in development for making language selection easier. Initially ULS will be for changing interface language but may also cover changing between language editions of wikipedia, using interwiki links.

Btw, bug 11267 is not very related to this.

arst wrote:

Here is a nice javascript solution for this, you can put it in your common.js:

var nlArticle = $('.interwiki-nl a').attr('title');
if (nlArticle)

$('h1').append('<span style="margin:0 1em; vertical-align: middle; font-size:0.5em;"><a href="//nl.wikipedia.org/wiki/' + nlArticle + '">' + nlArticle + '</a></span>');

A css solution would be to simply style the link (.interwiki-nl a) in your common.css

jayvdb added a comment.Oct 2 2013, 3:37 AM
  • Bug 22781 has been marked as a duplicate of this bug. ***

Note, it was proposed to make http://thread.gmane.org/gmane.org.wikimedia.mediawiki.i18n/662 into a project for [[mw:Mentorship programs/Possible projects]], the WMF is not going to work on it.
If you want to see this bug fixed, you have to add a section to that page (a mentor should not be too hard to find) and then push it for a GSoC/OPW candidate or chapter to pick it up.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 20 2015, 10:25 AM
Amire80 closed this task as Resolved.Nov 1 2017, 2:35 PM
Amire80 claimed this task.
Amire80 added subscribers: Niharika, Amire80.

The Compact Language Links project is the solution to this bug. It's already developed, after proper design and research work, although there will likely more improvements to it. It's already deployed to most Wikimedia projects, and more are on the way. I am marking this task as resolved. Further deployment to Wikimedia projects is tracked at T66793, and bugs and feature suggestions are tracked at the ULS-CompactLinks Phabricator project.