Create Wikiversity Chinese
Closed, ResolvedPublic

Subscribers
Tokens
"Party Time" token, awarded by Liuxinyu970226."Party Time" token, awarded by BJ6123C7BTD."Like" token, awarded by Wang_Qiliang."Love" token, awarded by Yuriy_kosygin."Love" token, awarded by Adsa562."Yellow Medal" token, awarded by Taiwania_Justo."Love" token, awarded by Shangkuanlc."Love" token, awarded by Cosine02."Love" token, awarded by Jayprakash12345.
Assigned To
Authored By
StevenJ81, Jul 13 2018

Description

The language committee has approved the creation of Wikiversity Chinese.

  • Local file uploads: disabled

Thank you.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJul 13 2018, 8:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm claimed this task.Jul 13 2018, 9:20 PM
Liuxinyu970226 mentioned this in Chinese-Sites.
Liuxinyu970226 awarded a token.
Liuxinyu970226 added a subscriber: Liuxinyu970226.
Liuxinyu970226 added a subscriber: RazeSoldier.EditedJul 14 2018, 8:17 AM

Per "Additional namespaces" field of request template in that page, please create these namespaces:

  1. Portal
  2. School
  3. Topic
  4. Portal_talk
  5. School_talk
  6. Topic_talk

The actual namespaces should keep in English, as we need to define translations of them elsewhere (@RazeSoldier is that wikiversity_family.py?)

No, that's pywikibot, a bot framework.

The actual namespaces should keep in English, as we need to define them elsewhere (@RazeSoldier is that wikiversity_family.py?)

Shouldn't these custom namespaces be defined in mediawiki-config/wmf-config/InitialiseSettings.php?

Jayprakash12345 changed the status of subtask T199600: Add zhwikiversity to pywikibot from Open to Stalled.Jul 14 2018, 9:12 AM

@RazeSoldier yeah we should define translations there.

RazeSoldier added a comment.EditedJul 14 2018, 9:27 AM

@RazeSoldier yeah we should define translations there.

In fact we can define translations in MediaWiki:Conversion-ns<namespace ID> and its subpages, like: zhwiki.

Change 445764 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Initial configuration for zhwikiversity

https://gerrit.wikimedia.org/r/445764

I'd prefer creating namespaces _after_ creating the wiki, not _while_. I've not added them into the configuration patch above then.

Urbanecm triaged this task as Low priority.Jul 14 2018, 10:19 AM
Shangkuanlc rescinded a token.
Shangkuanlc awarded a token.
Shangkuanlc added a subscriber: Shangkuanlc.
Adsa562 added a subscriber: Adsa562.

I haven't been following this task closely, but note that T185799, which was opened prematurely (in January) by @Assoc and just closed by @Liuxinyu970226 as a duplicate of this one, contained the following items in its description that aren't in (or are not the same in) this task:

Local file uploads: admin
Additional namespaces: Portal, School, Topic, Lesson
main page: Wikiversity:首页

So, talk amongst yourselves and decide what, if anything, needs to be done about that.

@Dcljr That's a LTA, why do you trust their so-called configurations?

Wang_Qiliang added a subscriber: Wang_Qiliang.
Zest added a subscriber: Zest.Jul 20 2018, 1:22 AM
Dcljr added a comment.Jul 22 2018, 8:40 PM

@Dcljr That's a LTA, why do you trust their so-called configurations?

I don't. I said y'all need to look at this and decide what needs to be done. If you're saying nothing should be done, then fine.

Urbanecm removed Urbanecm as the assignee of this task.Jul 24 2018, 7:57 PM

Waiting for real wiki creation.

Change 445764 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for zhwikiversity

https://gerrit.wikimedia.org/r/445764

Urbanecm assigned this task to Reedy.Aug 2 2018, 12:26 PM
Urbanecm added a subscriber: Reedy.

Wikis are live. Thank you @Reedy and all who helped! Leaving those tasks opened because other things will be necessary, as they always are when creating new wiki.

Urbanecm changed the status of subtask T199600: Add zhwikiversity to pywikibot from Stalled to Open.Aug 2 2018, 12:27 PM
Urbanecm changed the status of subtask T199603: Add Wikidata support for zhwikiversity when it's created from Stalled to Open.

Change 450011 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/services/restbase/deploy@master] Add new wikis

https://gerrit.wikimedia.org/r/450011

Change 450010 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/services/parsoid@master] Update sitematrix.json

https://gerrit.wikimedia.org/r/450010

Change 450015 had a related patch set uploaded (by Reedy; owner: Reedy):
[analytics/refinery@master] Add new wikis

https://gerrit.wikimedia.org/r/450015

Change 450011 merged by Mobrovac:
[mediawiki/services/restbase/deploy@master] Add new wikis

https://gerrit.wikimedia.org/r/450011

Change 450010 merged by jenkins-bot:
[mediawiki/services/parsoid@master] Update sitematrix.json

https://gerrit.wikimedia.org/r/450010

Change 450015 merged by Fdans:
[analytics/refinery@master] Add new wikis

https://gerrit.wikimedia.org/r/450015

Dcljr added a comment.Aug 7 2018, 11:03 PM

@Urbanecm are you going to create the additional namespaces now (per T199577#4424860 and T199577#4424969)? The imported content contains several pages that are supposed to be in other namespaces but ended up in the mainspace because their namespaces weren't defined yet.

Also, note T201353: Run initSiteStats.php on zhwikiversity after creation of new namespaces, which I guess should be done after the pages actually get into the right namespaces? (I don't know if it matters.)

Dcljr added a comment.EditedAug 7 2018, 11:10 PM

<s>BTW: Is "Topic:" going to be a problem because it's used by the Flow extension?</s>

Edit: Comment made irrelevant by T201675.

Shizhao closed this task as Resolved.Aug 8 2018, 12:08 PM
BJ6123C7BTD awarded a token.
BJ6123C7BTD removed a subscriber: BJ6123C7BTD.
Liuxinyu970226 awarded a token.