Page MenuHomePhabricator

QA page issues feature
Closed, ResolvedPublic

Description

Background

Prior to deploying the A/B test, we would like to do some exploratory testing on the page issues feature, in addition to confirming that there is no regressions from the previously QA'd tasks

Acceptance criteria

  • Ensure page issues work as expected
  • Perform exploratory testing on page issues feature

Sign off steps

  • Identify and create bugs for all the found issues

Setup

test through a number of pages on https://people.wikimedia.org/~jdrewniak/more_ambox/ :

  • for any template, go to "what links here" and select an article with issues
  • not all pages are updates, so it might take a bit of clicking to get a page with issues

take screenshots and report any bugs found:

  • New treatment: to each url, add ?minerva-issues=b
  • Old treatment: default

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 11 2018, 10:02 PM
ovasileva triaged this task as High priority.Sep 18 2018, 10:26 PM
ovasileva updated the task description. (Show Details)Sep 26 2018, 3:38 PM
ovasileva added subscribers: Ryasmeen, ABorbaWMF.
ovasileva updated the task description. (Show Details)Sep 27 2018, 7:41 PM

Pulling into sprint, as @ABorbaWMF, @Ryasmeen, @alexhollender, and @ovasileva are starting testing

ABorbaWMF updated the task description. (Show Details)Sep 27 2018, 8:00 PM
ABorbaWMF added a comment.EditedSep 27 2018, 9:07 PM

Examples so far:
Mac OSX 10.13 Safari 11


Windows 10 Internet Explorer 11

Windows 10 Google Chrome 69

Windows 10 Firefox 62

https://es.m.wikipedia.org/wiki/Coalici%C3%B3n_de_las_Bombas_de_Racimo?minerva-issues=b
Mac OSX 10.13 Safari 11 - This one might be a bug


Windows 10 Microsoft Edge 17 - This one might be a bug

Windows 10 Firefox 62 (64-bit)


Mac OSX 10.13 Google Chrome 69 (64-bit)

Mac OSX 10.13 Safari 11

Mac OSX 10.13 Firefox 62

Mac OSX 10.13 Safari 11

Mac OSX 10.13 Opera 55

Mac OSX 10.13 Safari 11 - This may be a bug
Page issues on ?minerva-issues=a do not appear on ?minerva-issues=b
https://en.wikipedia.org/wiki/Cauchy_sequence?minerva-issues=a

Windows 10 Microsoft Edge 17


Windows 10 Google Chrome 69 (64-bit)

https://ru.m.wikipedia.org/wiki/%D0%9B%D0%B0%D0%B2%D1%80%D0%BE%D0%B2%D1%81%D0%BA%D0%B8%D0%B9,_%D0%9D%D0%B8%D0%BA%D0%BE%D0%BB%D0%B0%D0%B9_%D0%90%D0%BB%D0%B5%D0%BA%D1%81%D0%B5%D0%B5%D0%B2%D0%B8%D1%87?minerva-issues=b

Mac OSX 10.13 Google Chrome 69 (64-bit) - There is some text overlap within the page issue area, upper left side


Windows 8.1 Internet Explorer 11 - There is some text overlap within the page issue area, upper left side

https://pt.m.wikipedia.org/wiki/Papa_Bento_IX?minerva-issues=b
Windows 10 Microsoft Edge 17 - Page issue does not extend to the right edge.


Windows 10 Google Chrome 69 (64-bit)

Confirmation for A/B test readiness - Catalan Wikipedia:

single:
https://ca.m.wikipedia.org/wiki/Murci%C3%A0?minerva-issues=b


miltiple:
https://ca.m.wikipedia.org/wiki/Murci%C3%A0?minerva-issues=b

  • text overlaps on larger screens
  • multiple issues styled incorrectly

Confirmation for A/B test readiness - Japanese Wikipedia
single issues:
https://ja.m.wikipedia.org/w/index.php?title=%E9%87%91%E5%85%89%E6%95%99&useskin=minerva&minerva-issues=b


multiple + section issues:
https://ja.m.wikipedia.org/wiki/%E7%AB%B9%E6%9C%AC%E6%B3%89?minerva-issues=b

multiple issues, uncollapsed

confirmed modals look as expected
status: ready for testing

Tbayer added a comment.EditedSep 28 2018, 9:06 PM

Two bugs involving overlapping text on the Catalan Wikipedia:

https://ca.m.wikipedia.org/wiki/Quina_roja?minerva-issues=b

The affected templates are
https://ca.wikipedia.org/wiki/Template:Falten_refer%C3%A8ncies
https://ca.wikipedia.org/wiki/Template:Millores_m%C3%BAltiples

[edit: probably the same as, or similar to, T204090#4626347 ]

https://it.m.wikipedia.org/wiki/A_priori_e_a_posteriori?minerva-issues=b
Windows 10 Google Chrome 69 (64-bit)


Windows 10 Internet Explorer 11

LGTM

alexhollender added a comment.EditedOct 1 2018, 3:25 PM
languagesingle issuesection issuemultiple issuesminerva desktopnotes
English
link
link
link
link
...
Spanish
link
link
link
link
...
German
link
link
link
link
...
Japanese
link
link
link
link
...
French
link
link
link
link
...
Russian
link
link
link
link
...
Italian
link
(section issues seem to be hidden in Minerva)
link
link
...
Chinese
link
link
link
link
...
Portuguese
link
link
link
link
...
Polish
link
link
link
link
...

https://es.m.wikipedia.org/wiki/Coalici%C3%B3n_de_las_Bombas_de_Racimo?minerva-issues=b
Mac OSX 10.13 Safari 11 - This one might be a bug

This one is a template issue, it's also happening on vector:

ovasileva assigned this task to Ryasmeen.Oct 1 2018, 5:08 PM
ovasileva added a project: Product-QA.
Jdlrobson updated the task description. (Show Details)Oct 1 2018, 5:10 PM
stjn added a subscriber: stjn.EditedOct 2 2018, 12:33 AM

Confirmation for A/B test readiness - Russian Wikipedia
Sidenote: looks so good!
Noted severity working as expected
status: ready for testing

Hi, sorry, can you clarify why this ‘looks so good’ in your opinion? Compared with English Wikipedia template, a lot of secondary information is being displayed, is this an intended effect for non-English projects or is testing being done just for non-layout breaking bugs?

Confirmation for A/B test readiness - Russian Wikipedia
Sidenote: looks so good!
Noted severity working as expected
status: ready for testing

Hi, sorry, can you clarify why this ‘looks so good’ in your opinion? Compared with English Wikipedia template, a lot of secondary information is being displayed, is this an intended effect for non-English projects or is testing being done just for non-layout breaking bugs?

Continuing the conversation at T206007: Russian ambox page issues on Minerva showing secondary information but just to document here as well, my comment was referring to the overall look of the page issues rather than the content. Here, the Russian ambox template does not contain the hide-when-compact class and is thus displaying the entire text of the message

Testing: https://ace.m.wikipedia.org
Chrome: Version 69.0.3497.100

Old treatment:

Text overlap observed on new treatment:


Multiple issues, new treatment with text overlapped:

stjn removed a subscriber: stjn.Oct 2 2018, 10:56 PM

Testing: https://ast.m.wikipedia.org
?minerva-issues=b
Single issue:

Testing: https://av.m.wikipedia.org

Single issue:



Testing: https://az.m.wikipedia.org
Text overlap observed




Text overlap with multiple issues

Testing https://bjn.m.wikipedia.org/wiki/Liverpool_F.C.?minerva-issues=b

Text overlap when multiple issues:

Looks good when there is a single issue though:

Testing:https://be.m.wikipedia.org

Is it acceptable? Page issues banner not extending to the right edge?

Testing Bengali wikipedia.

Banner with Single and Multiple issues looks perfect!




Testing on https://bs.m.wikipedia.org/

Is this a bug?

I see the page issues banner but the pages issues overlay looks empty for several articles.


Ryasmeen removed Ryasmeen as the assignee of this task.Oct 4 2018, 11:29 PM

Trying to come up with a rubric to assess these against.

Good:

  • template icon is yielding to new mobile icon
  • page issue text is being truncated
  • there is a modal to be accessed and it is easily accessible via a "Learn more" button

Has issues:
anything that doesn't qualify as Broken or Good belongs here

Broken:

  • there is overlapping or obscured text
  • there is not a clear distinction between the page issue and the article text (I realize this is somewhat subjective, but for example I'd consider German broken for this reason)

*One thing I'm sort've on the fence about: should lack of truncation qualify as "broken" since it can result in the article contents being pushed nearly or entirely out of view? I'm hesitant to say yes, because there could be many cases where lack of truncation doesn't result in this problem (and I have no sense of how often this will happen). Here are a few examples of how it looks when it occurs:

SpanishRussianFrench

Results thus far:

Good
Catalan
Japanese
English
Chinese
Bengali
Malay

Has issues
Russian
Farsi
Italian
Portuguese
Polish
French
Spanish

Broken
German

Broken
German

Just a note that neither our current nor our future treatment affect German wikipedia - perhaps we can reach out to the German community and see if they're interested in adopting some of the more widely-used templates.

ovasileva closed this task as Resolved.Nov 7 2018, 10:19 PM

All follow-up bugs related to this card have been opened. Resolving. Thanks to everyone who helped with QA here!

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptNov 7 2018, 10:19 PM
This comment was removed by alexhollender.