Page MenuHomePhabricator

Regression: Dancing Search Bar in MediaWiki when menu is hidden
Closed, ResolvedPublicBUG REPORT

Description

NOTE: impacts users resizing the window to 500px, 720-760px, 1170px - 1240px (T253819#6174864), possibly more (no systematic test done). The bug is triggered at different window widths depending on the size of the tabs (which in turn depends on font-size, language, page, login status, ...). A SWAT would be appreciated but is not critical. This can ride the train if necessary.

Not to be confused with the similar bug from 2014: T71729
This one is caused by a regression in T249372: [Dev] DRY up the menu templating code
The distinctive difference is: the "More" menu is not visible in this bug, but it's visible in the old bug.
Related regression that was fixed by reverting the CSS: T253912: gadget regression: addPortletLink doesn't reveal hidden menus in Vector any more [causes disappearance of merge datas on Wikidata]
This bug is caused by not reverting the JS.

Reddit video:
https://www.reddit.com/r/softwaregore/comments/gtbdwu/cant_fit_all_the_buttons_in_the_frame_wikipedia/

Steps to reproduce

  1. Technology used: Chrome Version 81.0.4044.129 (Official Build) (64-bit) on MacOS Mojave 10.14.6 (18G4032)
  2. Navigate to a page on Mediawiki (e.g. https://www.mediawiki.org/wiki/Readers/Web/Team, or https://www.mediawiki.org/wiki/User:KZimmerman_(WMF) as in the attached gif.
  3. Reduce the browser window size, until you reach a point where the search bar area starts alternating its location and expanding & contracting automatically, as seen below in the animated gif.

Expected results

  • The links and search bar should contract to fit, but should not jump around

Actual results



(click on image to see animation)

Popular reddit video.

Environments observed

  • Browser version: Chrome Version 81.0.4044.129 (Official Build) (64-bit)
  • OS version: MacOS Mojave 10.14.6 (18G4032)
  • Device model: MacBook Pro
  • Device language: English

Check any additional observations

Stack trace

Console output

QA Steps

Sign off steps

  • Make sure a task has been created regarding the long term plan for this code in legacy and whether it should be dropped from the codebase.

QA Results - Beta

ACStatusDetails
1T253819#6189686

QA Results - enwiki

ACStatusDetails
1T253819#6200462

Related Objects

Event Timeline

Restricted Application added subscribers: Masumrezarock100, Aklapper. · View Herald TranscriptMay 27 2020, 11:48 PM
Demian added a subscriber: Demian.May 28 2020, 10:34 PM

I've reproduced the effect at 1170px - 1240px width, default (16px) browser font-size.
This is caused by the Vector tab hiding JS.

@Demian: This task is closed as a duplicate - please refer to T71729 instead. Thanks!

Change 600358 had a related patch set uploaded (by Aron Manning; owner: Aron Manning):
[mediawiki/skins/Vector@master] Hotfix: Stop the "dancing vector tabs" issue.

https://gerrit.wikimedia.org/r/600358

Demian reopened this task as Open.Jun 1 2020, 1:57 PM
Demian triaged this task as Unbreak Now! priority.
Demian added a subscriber: Niedzielski.

Reopening. Turns out this is a brand new regression caused by T249372, that looks like the bug reported years ago (T71729). The distinctive difference is: the "More" menu is not visible with this bug, but it's visible with the old bug. To avoid confusing the two bugs which require completely different solutions, the fix for the new bug is uploaded on this ticket.

This is a high-visibility bug as demonstrated by the reddit video which accumulated 21k upvotes in 2 days (IIRC >10k means that it made its way to the front page), therefore setting it to "Unbreak Now". The patch is ready to be merged and SWATed, hopefully the image of Wikipedia will be restored very soon.

cc @Niedzielski (reviewer of the sibling hotfix)

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJun 1 2020, 1:57 PM
ovasileva lowered the priority of this task from Unbreak Now! to High.Jun 1 2020, 2:26 PM

@Demian - while this will be looked at urgently, I don't think it necessarily meets our unbreak now criteria. Dropping this back to high

Demian renamed this task from [Bug] Dancing Search Bar in MediaWiki to Regression: Dancing Search Bar in MediaWiki.Jun 1 2020, 2:37 PM
Demian claimed this task.
Demian updated the task description. (Show Details)

Change 601368 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/Vector@master] Drop the collapsibleTabs code

https://gerrit.wikimedia.org/r/601368

Demian added a comment.Jun 1 2020, 4:39 PM

@Demian - while this will be looked at urgently, I don't think it necessarily meets our unbreak now criteria. Dropping this back to high

@ovasileva You might be right, I'm used to a demanding work environment, where such public facing and highly visible bugs are unacceptable, thus the day does not end until it's fixed. Not to say that that's bad, the adrenaline rush and the intense team work is a great experience, absolutely worth it for me. What I want to say is that I'm sorry that I cannot wrap my mind around the fact that it's still not fixed and I don't see people being interested in fixing it.

Demian updated the task description. (Show Details)Jun 1 2020, 6:39 PM
Jdlrobson renamed this task from Regression: Dancing Search Bar in MediaWiki to Regression: Dancing Search Bar in MediaWiki when menu is hidden.Jun 1 2020, 7:24 PM
Jdlrobson updated the task description. (Show Details)
Demian updated the task description. (Show Details)Jun 1 2020, 7:32 PM
Demian added a comment.Jun 1 2020, 7:36 PM

I've corrected the prevalence of the bug. It takes just a few seconds of window resizing to find a few ranges where it triggers. That's of course only one page, one language, one font-size, each of which alters the trigger ranges. A day of testing might reveal that 500px - 1?00px there's a configuration in which the bug triggers.

Jdlrobson lowered the priority of this task from High to Medium.Jun 1 2020, 7:39 PM

Change 600358 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Fix bug: "dancing vector tabs"

https://gerrit.wikimedia.org/r/600358

Jdlrobson reassigned this task from Demian to Edtadros.Jun 1 2020, 9:04 PM

@Edtadros could you please test this on https://en.wikipedia.beta.wmflabs.org/wiki/Main_Page ? We'll want to test this in production later once the fix goes out as well.

Test Result - Beta

Status: ✅ PASS
Environment: beta
OS: macOS Catalina
Browser: Chrome, Safari, Firefox
Device: MBP
Emulated Device: NA

Test Artifact(s):

QA steps

load https://en.wikipedia.beta.wmflabs.org/wiki/Main_Page as an anonymous user visit with a window width > 800px
Resize the window width resized to 500px
✅ AC1: The menu should not dance.
I tried this on Safari, Chrome, and Firefox. I saw no dancing

Edtadros updated the task description. (Show Details)Jun 3 2020, 4:49 PM

Change 601368 abandoned by Jdlrobson:
[legacy] Drop the collapsibleTabs code

Reason:
To be reconsidered at a later date.

https://gerrit.wikimedia.org/r/601368

Edtadros reassigned this task from Edtadros to ovasileva.Jun 8 2020, 6:25 AM
Edtadros added a subscriber: Edtadros.

Test Result - Prod

Status: ✅ PASS
Environment: enwiki
OS: macOS Catalina
Browser: Chrome, Safari, Firefox
Device: MBP
Emulated Device: NA

Test Artifact(s):

QA steps

Visit https://en.wikipedia.org/wiki/Candeal as an anonymous user visit with a window width > 800px
Resize the window width resized to 500px
✅ AC1: The menu should not dance.
I tried this on Safari, Chrome, and Firefox. I saw no dancing

Edtadros updated the task description. (Show Details)Jun 8 2020, 6:25 AM
ovasileva closed this task as Resolved.Jun 8 2020, 9:37 AM

No more dancing. Looks good!

He7d3r added a subscriber: He7d3r.Jun 18 2020, 10:37 AM