Page MenuHomePhabricator

Argument 3 passed to CachingFallbackLabelDescriptionLookup::buildCacheKey() must be of the type string, null given
Closed, ResolvedPublicPRODUCTION ERROR

Description

Error message
Argument 3 passed to Wikibase\Lib\Store\CachingFallbackLabelDescriptionLookup::buildCacheKey() must be of the type string, null given, called in /srv/mediawiki/php-1.36.0-wmf.3/extensions/Wikibase/lib/includes/Store/CachingFallbackLabelDescriptionLookup.php on line 119
Impact / Notes

A couple of these shortly after rolling 1.36.0-wmf.3 to group1. Not yet treating as a blocker for T257971, but monitoring.

Details

Request ID
024459c3-45d8-4d3b-954e-d96991bcd7e6
Request URL
https://commons.wikimedia.org/wiki/Category:Manzushir_Monastery?uselang=%E2%A7%BCLang%E2%A7%BD
Stack Trace
#0 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Wikibase/lib/includes/Store/CachingFallbackLabelDescriptionLookup.php(119): Wikibase\Lib\Store\CachingFallbackLabelDescriptionLookup->buildCacheKey(Wikibase\DataModel\Entity\ItemId, integer, NULL, string)
#1 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Wikibase/lib/includes/Store/CachingFallbackLabelDescriptionLookup.php(106): Wikibase\Lib\Store\CachingFallbackLabelDescriptionLookup->getTerm(Wikibase\DataModel\Entity\ItemId, NULL, string)
#2 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Wikibase/client/includes/Usage/UsageTrackingLanguageFallbackLabelDescriptionLookup.php(71): Wikibase\Lib\Store\CachingFallbackLabelDescriptionLookup->getLabel(Wikibase\DataModel\Entity\ItemId)
#3 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Wikibase/client/includes/DataAccess/Scribunto/WikibaseLanguageDependentLuaBindings.php(60): Wikibase\Client\Usage\UsageTrackingLanguageFallbackLabelDescriptionLookup->getLabel(Wikibase\DataModel\Entity\ItemId)
#4 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Wikibase/client/includes/DataAccess/Scribunto/Scribunto_LuaWikibaseLibrary.php(606): Wikibase\Client\DataAccess\Scribunto\WikibaseLanguageDependentLuaBindings->getLabel(string)
#5 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Scribunto/includes/engines/LuaSandbox/LuaSandboxCallback.php(26): Wikibase\Client\DataAccess\Scribunto\Scribunto_LuaWikibaseLibrary->getLabel(string)
#6 [internal function]: Scribunto_LuaSandboxCallback->__call(string, array)
#7 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Scribunto/includes/engines/LuaSandbox/LuaSandboxInterpreter.php(113): LuaSandboxFunction->call(LuaSandboxFunction)
#8 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Scribunto/includes/engines/LuaCommon/LuaEngine.php(291): Scribunto_LuaSandboxInterpreter->callFunction(LuaSandboxFunction, LuaSandboxFunction)
#9 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Scribunto/includes/engines/LuaCommon/LuaModule.php(68): Scribunto_LuaEngine->executeFunctionChunk(LuaSandboxFunction, PPTemplateFrame_Hash)
#10 /srv/mediawiki/php-1.36.0-wmf.3/extensions/Scribunto/includes/common/Hooks.php(128): Scribunto_LuaModule->invoke(string, PPTemplateFrame_Hash)
#11 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(3340): ScribuntoHooks::invokeHook(Parser, PPTemplateFrame_Hash, array)
#12 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(3047): Parser->callParserFunction(PPTemplateFrame_Hash, string, array)
#13 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/PPFrame_Hash.php(253): Parser->braceSubstitution(array, PPTemplateFrame_Hash)
#14 /srv/mediawiki/php-1.36.0-wmf.3/extensions/ParserFunctions/includes/ParserFunctions.php(144): PPFrame_Hash->expand(PPNode_Hash_Tree)
#15 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(3340): MediaWiki\Extensions\ParserFunctions\ParserFunctions::ifeq(Parser, PPTemplateFrame_Hash, array)
#16 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(3047): Parser->callParserFunction(PPTemplateFrame_Hash, string, array)
#17 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/PPFrame_Hash.php(253): Parser->braceSubstitution(array, PPTemplateFrame_Hash)
#18 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(3225): PPFrame_Hash->expand(PPNode_Hash_Tree)
#19 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/PPFrame_Hash.php(253): Parser->braceSubstitution(array, PPTemplateFrame_Hash)
#20 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/PPTemplateFrame_Hash.php(89): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#21 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(3222): PPTemplateFrame_Hash->cachedExpand(string, PPNode_Hash_Tree)
#22 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/PPFrame_Hash.php(253): Parser->braceSubstitution(array, PPFrame_Hash)
#23 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(2887): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#24 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(1556): Parser->replaceVariables(string)
#25 /srv/mediawiki/php-1.36.0-wmf.3/includes/parser/Parser.php(651): Parser->internalParse(string)
#26 /srv/mediawiki/php-1.36.0-wmf.3/includes/content/WikitextContent.php(374): Parser->parse(string, Title, ParserOptions, boolean, boolean, integer)
#27 /srv/mediawiki/php-1.36.0-wmf.3/includes/content/AbstractContent.php(590): WikitextContent->fillParserOutput(Title, integer, ParserOptions, boolean, ParserOutput)
#28 /srv/mediawiki/php-1.36.0-wmf.3/includes/Revision/RenderedRevision.php(266): AbstractContent->getParserOutput(Title, integer, ParserOptions, boolean)
#29 /srv/mediawiki/php-1.36.0-wmf.3/includes/Revision/RenderedRevision.php(235): MediaWiki\Revision\RenderedRevision->getSlotParserOutputUncached(WikitextContent, boolean)
#30 /srv/mediawiki/php-1.36.0-wmf.3/includes/Revision/RevisionRenderer.php(215): MediaWiki\Revision\RenderedRevision->getSlotParserOutput(string)
#31 /srv/mediawiki/php-1.36.0-wmf.3/includes/Revision/RevisionRenderer.php(152): MediaWiki\Revision\RevisionRenderer->combineSlotOutput(MediaWiki\Revision\RenderedRevision, array)
#32 [internal function]: MediaWiki\Revision\RevisionRenderer->MediaWiki\Revision\{closure}(MediaWiki\Revision\RenderedRevision, array)
#33 /srv/mediawiki/php-1.36.0-wmf.3/includes/Revision/RenderedRevision.php(197): call_user_func(Closure, MediaWiki\Revision\RenderedRevision, array)
#34 /srv/mediawiki/php-1.36.0-wmf.3/includes/poolcounter/PoolWorkArticleView.php(216): MediaWiki\Revision\RenderedRevision->getRevisionParserOutput()
#35 /srv/mediawiki/php-1.36.0-wmf.3/includes/poolcounter/PoolCounterWork.php(162): PoolWorkArticleView->doWork()
#36 /srv/mediawiki/php-1.36.0-wmf.3/includes/page/Article.php(811): PoolCounterWork->execute()
#37 /srv/mediawiki/php-1.36.0-wmf.3/includes/page/CategoryPage.php(63): Article->view()
#38 /srv/mediawiki/php-1.36.0-wmf.3/includes/actions/ViewAction.php(74): CategoryPage->view()
#39 /srv/mediawiki/php-1.36.0-wmf.3/includes/MediaWiki.php(527): ViewAction->show()
#40 /srv/mediawiki/php-1.36.0-wmf.3/includes/MediaWiki.php(313): MediaWiki->performAction(CategoryTreeCategoryPage, Title)
#41 /srv/mediawiki/php-1.36.0-wmf.3/includes/MediaWiki.php(940): MediaWiki->performRequest()
#42 /srv/mediawiki/php-1.36.0-wmf.3/includes/MediaWiki.php(543): MediaWiki->main()
#43 /srv/mediawiki/php-1.36.0-wmf.3/index.php(53): MediaWiki->run()
#44 /srv/mediawiki/php-1.36.0-wmf.3/index.php(46): wfIndexMain()
#45 /srv/mediawiki/w/index.php(3): require(string)
#46 {main}

Event Timeline

brennen created this task.Aug 5 2020, 7:26 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptAug 5 2020, 7:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
brennen triaged this task as Unbreak Now! priority.Aug 5 2020, 7:54 PM

Since we're already rolled back due to T259745, I'm going to err on the side of marking this a blocker until triaged.

Catrope added a subscriber: Catrope.Aug 5 2020, 8:26 PM
This comment was removed by Catrope.

Adding @Pablo-WMDE as this week's IM and @Addshore and @Michael who touched the code recently.

brennen moved this task from Backlog to Logs/Train on the User-brennen board.Aug 6 2020, 12:05 AM
thiemowmde added a subscriber: thiemowmde.

This is actually the exact same root cause as in T259745: The language fallback chain in question is empty, and calling $languageCode = $languageCodes[0] on an empty array results in the language code being null.

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/608628 is indeed what caused this, specifically https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Wikibase/+/608628/13/lib/includes/TermLanguageFallbackChain.php. I created T259779 to keep track of the common root cause.

Change 618703 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Wikibase@master] Fix CachingFallbackLabelDescriptionLookup failing in edge-cases

https://gerrit.wikimedia.org/r/618703

We discussed this task during the Wikidata-Campsite daily and it will be addressed with high priority.

There is a patch up already which has some red because of another problem (T258184) which is in the making as well.

Change 618579 had a related patch set uploaded (by Ladsgroup; owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Wikibase@wmf/1.36.0-wmf.3] Fix CachingFallbackLabelDescriptionLookup failing in edge-cases

https://gerrit.wikimedia.org/r/618579

Change 618579 merged by Lucas Werkmeister (WMDE):
[mediawiki/extensions/Wikibase@wmf/1.36.0-wmf.3] Fix CachingFallbackLabelDescriptionLookup failing in edge-cases

https://gerrit.wikimedia.org/r/618579

Mentioned in SAL (#wikimedia-operations) [2020-08-06T11:27:17Z] <lucaswerkmeister-wmde@deploy1001> Synchronized php-1.36.0-wmf.3/extensions/Wikibase/lib/: Backport: [[gerrit:618579|Fix CachingFallbackLabelDescriptionLookup failing in edge-cases (T259744)]] (duration: 01m 10s)

This should be fixed on wmf.3 now, but not yet on master. Marking as wmf.4 deployment blocker so we don’t forget about it.

Lucas_Werkmeister_WMDE lowered the priority of this task from Unbreak Now! to High.Aug 6 2020, 12:02 PM

Removing as wmf.3 blocker since it’s fixed on that branch, and lowering priority for the same reason.

Thanks all.

Change 618703 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Fix CachingFallbackLabelDescriptionLookup failing in edge-cases

https://gerrit.wikimedia.org/r/618703

Majavah added a subscriber: Majavah.Aug 8 2020, 8:53 AM

Patch was merged to master, removing as wmf.4 blocker

DannyS712 updated the task description. (Show Details)Aug 8 2020, 9:51 PM
Addshore closed this task as Resolved.Aug 12 2020, 10:10 PM
Addshore claimed this task.

I believe @Lucas_Werkmeister_WMDE said everything is done here :)

Restricted Application added a project: User-Addshore. · View Herald TranscriptAug 12 2020, 10:10 PM