Page MenuHomePhabricator

Accessing diff pages from the watchlist points to revision page rather than diff page as curid parameter is not unset
Closed, ResolvedPublic

Description

Clicking on diff link from the watchlist page does not give access to a diff page anymore. See this example https://fr.m.wikipedia.org/w/index.php?title=Sp%C3%A9cial:MobileDiff/175594335&curid=531698.

This is a new bug.

Reopened for Wikivoyage

Event Timeline

PAC2 created this task.Oct 15 2020, 7:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 15 2020, 7:31 PM
Jdlrobson added a subscriber: Jdlrobson.

Looks like this may have been caused by T263937 but not sure how.

Jdlrobson renamed this task from Accessing diff pages from the watchlist to Accessing diff pages from the watchlist points to revision page rather than diff page as curid parameter is not unset.Oct 15 2020, 8:36 PM
matmarex added a subscriber: matmarex.

Special:MobileDiff is just the worst :(

Change 634358 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] Fix mobile diff redirect when 'curid' query parameter is present

https://gerrit.wikimedia.org/r/634358

Change 634358 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix mobile diff redirect when 'curid' query parameter is present

https://gerrit.wikimedia.org/r/634358

matmarex closed this task as Resolved.Oct 16 2020, 10:01 PM

This will be deployed next week, 20-22 October, per the usual schedule.

@PAC2 If this is a major problem for you, please let me know, and I'll backport it on Monday instead (sorry, it can't be done sooner).

Sorry about the issue.

PAC2 added a comment.Oct 17 2020, 7:45 AM

I'm addict to Wikipedia but I can wait until October 22. Thanks for debugging.

Also, to be clear, this problem only affects the mobile site – you can switch to the desktop site temporarily to use your watchlist (although I understand this is an annoyance).

PAC2 added a comment.Oct 17 2020, 6:28 PM

Of course. That's what I do

This might be worth a backport if possible, given the number of duplicate reports. I suppose it's a good sign that lots of people are using the mobile watchlist!

Andyrom75 reopened this task as Open.Oct 19 2020, 2:12 PM
Andyrom75 updated the task description. (Show Details)
Izno closed this task as Resolved.Oct 19 2020, 2:54 PM

Because it is being deployed this week.

Resolved means a fix has been implemented and merged, not deployed.

Change 634802 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@wmf/1.36.0-wmf.13] Fix mobile diff redirect when 'curid' query parameter is present

https://gerrit.wikimedia.org/r/634802

Change 634802 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@wmf/1.36.0-wmf.13] Fix mobile diff redirect when 'curid' query parameter is present

https://gerrit.wikimedia.org/r/634802

Mentioned in SAL (#wikimedia-operations) [2020-10-19T18:24:16Z] <catrope@deploy1001> Synchronized php-1.36.0-wmf.13/extensions/MobileFrontend/: Fix mobile diff redirect when curid parameter is present (T265654) (duration: 00m 58s)

Deployed to Wikimedia wikis now.

Sorry about this again, the problem was caused by my mistake in the patch for T263937 (I didn't realize the 'curid' parameter needs to be handled here).

For the user-notice in Tech News, does this accurately describe the item? If not, a clearer/better draft would be appreciated. (and for future reference, writing them for us when you add the tag is always appreciated! ;D )

There was a problem with the links to "diffs" from mobile watchlists and recentchanges. This has now been fixed. [1]

Although we backported to wmf13, I think it also needed to be backported to 1.36.0-wmf.14 so I don't think it's fully fixed as of today :(
We may need to backport to wmf14 on Monday if we can.

For the user-notice in Tech News, does this accurately describe the item? If not, a clearer/better draft would be appreciated. (and for future reference, writing them for us when you add the tag is always appreciated! ;D )

There was a problem with the links to "diffs" from mobile watchlists and recentchanges. This has now been fixed. [1]

Maybe clarify it:

Links to "diffs" from mobile watchlists and recentchanges instead linked to the page that was edited. This has now been fixed. [1]

Although we backported to wmf13, I think it also needed to be backported to 1.36.0-wmf.14 so I don't think it's fully fixed as of today :(
We may need to backport to wmf14 on Monday if we can.

The patch https://gerrit.wikimedia.org/r/c/mediawiki/extensions/MobileFrontend/+/634358 seems to already be included in wmf.14 (click the "INCLUDED IN" button), are you still seeing the problem?

My bad I was using the URL https://fr.m.wikipedia.org/w/index.php?title=Sp%C3%A9cial:MobileDiff/175594335&curid=531698. I guess that URL will still use curid over title, but I can confirm the link on watchlist is fixed. I think that's a sign I should sign off for the night :)