Please add cross-wiki talk page notification.
Closed, ResolvedPublic

Description

Author: beesley

Description:
Cross-wiki talk page notification would be a very useful feature so that users could be notified of messages left on one Wikipedia even if they never visit that language.


URL: https://www.mediawiki.org/wiki/Requests_for_comment/Global_notifications
See Also:
T37306: Global (to a wiki farm or family) message delivery (thoughts)
T67661: Echo: Support cross-wiki notifications

Details

Reference
bz1066
bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz1066.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Dec 11 2004, 1:49 AM

dig.mediazilla wrote:

Yes, I also think that this would be a very nice feature.

(In reply to comment #0)

Cross-wiki talk page notification would be a very useful feature so that users
could be notified of messages left on one Wikipedia even if they never visit
that language.

Angela,

I have nothing against this feature, but current collaboration is a m*ss, when I
have to ask and ask and ask again and again for CVS/Developer access rights.
This needs to said once. How did the other developers get their "rights"?

I'll take over to implement this (together with E mail notification
http://bugzilla.wikipedia.org/show_bug.cgi?id=454 , which is already in CVS 1.5

  • everyone can check this out and test.)

As soon, as we have 1.5 running, changes of user_talk pages of every wiki will
trigger an email notification (if this is enabled by the sysop). This has
nothing directly to do with single user-login see also
http://meta.wikipedia.org/SUL again.

Brion and JelUF:
Can you add for me a permanent(!) statistik of foreign (i.e. not own) changes on
user_talk pages for _all_ wikis (as you did in August 2004: 1000 changes on
enwiki - 200 own changes = 800 "foreign" changes. this will be the maximum
number of e-mail notifications per day)

I forget to say, that the http://bugzilla.wikipedia.org/show_bug.cgi?id=454 uses
table watchlist not only for sending the e-mail notification for user_talk pages
(if this is enabled), but also manages now the "You have new message" talk page
notification.

This is, why I offer to take over treating this bugzilla.

psychonaut wrote:

This issue might be better solved by solving Bug 57.

thor.malmjursson wrote:

*** Bug 9524 has been marked as a duplicate of this bug. ***

demon added a comment.Jun 9 2008, 7:24 PM
  • Bug 14488 has been marked as a duplicate of this bug. ***

cometstyles wrote:

Since the successful implementation of SUL, this idea should be given a second-look...

demon added a comment.Aug 13 2008, 5:30 PM
  • Bug 15156 has been marked as a duplicate of this bug. ***

Does this have any hope of implementation? It looks like it had been forgotten for good.

ayg wrote:

Not for good. Someone just has to code it.

This may work, and has been getting some discussion:
http://en.wikipedia.org/wiki/Wikipedia:Integrated_watchlists

M8R-cyc3n3 wrote:

This can simulated using javascript and the API (format=json) except it requires using the watchlist token and might not be terribly efficient.

demon added a comment.May 5 2012, 11:55 PM
  • Bug 30386 has been marked as a duplicate of this bug. ***

probably going to be solved with new notification system:

https://www.mediawiki.org/wiki/Echo_%28Notifications%29

Looking at that screenshot it seems to already have been solved, but not deployed to WMF sites yet.

Qgil added a comment.May 17 2014, 12:48 AM

As far as I'm aware, Echo doesn't provide cross-wiki notifications. I don't know whether Flow has this feature in their roadmap.

(In reply to Quim Gil from comment #16)

As far as I'm aware, Echo doesn't provide cross-wiki notifications. I don't
know whether Flow has this feature in their roadmap.

This is the subject of an RfC: [[mw:Requests for comment/Global notifications]]. It's in the long-term roadmap of "Flow", but for Flow to have it, Echo also needs to support it.

I don't think it's reasonable to list this against MW 1.24; removing milestone.

Qgil added a comment.May 17 2014, 5:20 PM

Sorry, I just wanted to define the version.

werdna removed a subscriber: werdna.Dec 10 2014, 5:23 PM
Nemo_bis set Security to None.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 24 2015, 3:41 PM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptNov 11 2015, 10:23 PM
Meno25 removed a subscriber: Meno25.Nov 29 2015, 7:28 PM
Jdforrester-WMF reopened this task as Open.Dec 8 2015, 8:52 PM

Re-opening as the overall delivery of Global notifications, instead of the technology side.

Qgil removed a subscriber: Qgil.Dec 28 2015, 8:29 PM
Catrope closed this task as Resolved.
Catrope claimed this task.
Catrope added a subscriber: Catrope.

With today's deployment of cross-wiki notifications (now enabled by default on all wikis), I'm closing this as resolved.

Nemo_bis rescinded a token.Jul 16 2016, 8:00 AM
Nemo_bis awarded a token.