Page MenuHomePhabricator

Cite: Parsoid's port does not support all of the PHP extension's config options and i18n messages
Closed, ResolvedPublic

Description

The PHP parser integration into Parsoid does not apply wiki-specific content. This is most obvious in the context of the Cite extension's messages cite_references_link_one and cite_references_link_many, which are over-ridden on enwiki from their default ("↑") to a local value ("^"). Though the PHP parser integration is not destined to last for very long, its replacement will have to find a way to deal with localised messages like this (or have a post-processor do it if we want to keep Parsoid away from wiki-specific details).


Version: unspecified
Severity: normal

Details

Reference
bz43235

Event Timeline

bzimport raised the priority of this task from to Low.
bzimport set Reference to bz43235.

We are handling Cite natively, so none of the PHP extension's config options are supported currently.

[Parsoid component reorg by merging JS/General and General. See bug 50685 for more information. Filter bugmail on this comment. parsoidreorg20130704]

  • Bug 60934 has been marked as a duplicate of this bug. ***

See also bug #49538.

  • Bug 56240 has been marked as a duplicate of this bug. ***

There's an experimental patch at https://gerrit.wikimedia.org/r/#/c/158852/ that uses CSS to style references.

He7d3r added a subscriber: He7d3r.Jul 20 2015, 12:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 20 2015, 12:57 PM
Aklapper removed marcoil as the assignee of this task.Sep 22 2015, 3:38 PM
ssastry raised the priority of this task from Low to Normal.Mar 31 2017, 2:37 PM
ssastry closed this task as Resolved.
ssastry claimed this task.

Resolving this since T51538, T156350, and T156351 cover the specific requirements from this task. Please open a new task with anything not already covered by those tasks.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 31 2017, 2:37 PM