VisualEditor: ISBN link labels (from magic words) can be changed, but not the underlying links
Closed, ResolvedPublic

Description

Intention:
Change an ISBN.

Steps to Reproduce:

  1. Open a page with a pre-existing ISBN number (using the magic word).
  1. Click in the link and open the link inspector.
  1. Correct the numbers in the ISBN.
  1. Close the link inspector.

Actual Results:
The link label does not change. This is not surprising, given VisualEditor's approach to links, but it is sometimes unfortunate; see https://fr.wikipedia.org/w/index.php?title=Massimo_Introvigne&diff=100272017&oldid=94374615

However, the link itself does not change, and if you have done nothing else, it is not possible to save the page, because you have supposedly made no changes.

Expected Results:
Ideal behavior:

Changing "ISBN 1234567890" to "ISBN 1234567891" simply updates the plain wikitext magic word.

Possibly acceptable behavior:

Changing "ISBN 1234567890" to "ISBN 1234567891" updates the link to [[Special:BookSources/1234567891|ISBN 1234567891]].

Reproducible: Always


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=52204

bzimport added a project: VisualEditor-DataModel.Via ConduitNov 22 2014, 3:06 AM
bzimport set Reference to bz61558.
Whatamidoing-WMF created this task.Via LegacyFeb 19 2014, 9:55 PM
NicoV added a comment.Via ConduitJun 23 2014, 2:25 PM

Other recent examples of ISBN problems caused by VE (awful syntax, link incoherent with displayed ISBN, nowiki added) :
https://fr.wikipedia.org/w/index.php?title=Bassin_s%C3%A9dimentaire&diff=prev&oldid=104307942
https://fr.wikipedia.org/w/index.php?title=Louis-Jos%C3%A9_Houde&diff=104782988&oldid=104262388

This is a recurring problem on frwiki.

Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebNov 24 2014, 1:24 AM
Jdforrester-WMF moved this task to Backlog on the VisualEditor 2014/15 Q4 blockers workboard.Via WebApr 15 2015, 6:30 PM
Jdforrester-WMF lowered the priority of this task from "Normal" to "Low".Via WebApr 15 2015, 6:52 PM
Jdforrester-WMF set Story Points to 8.
Krenair added a project: Parsoid.EditedVia WebApr 18 2015, 11:20 AM

The Parsoid output does not look quite right to me:

<a href="./Special:BookSources/0345318641" rel="mw:ExtLink" data-parsoid='{"stx":"magiclink","dsr":[16,34,0,0]}'>ISBN 0-345-31864-1</a>

ExtLink? That href is for a WikiLink...

ssastry moved this task to In Progress on the Parsoid workboard.Via WebApr 28 2015, 6:18 PM
Trizek-WMF added a subscriber: Trizek-WMF.Via WebJun 1 2015, 9:01 PM
Elitre added a subscriber: ssastry.Via WebJun 15 2015, 10:53 AM

@ssastry, are the problems described in this comment also possibly due to Parsoid? Thank you!

ssastry added a comment.Via WebJun 15 2015, 3:00 PM

@ssastry, are the problems described in this comment also possibly due to Parsoid? Thank you!

Looking at [[Special:BookSources/9782981011206|ISBN 978-2-9810112-1-]]<nowiki/>3 .. that looks like VE issues to me. The "3" is not part of the link text so, Parsoid is forced to add a nowiki to preserve HTML semantics. As for editing link text not chaning the underlying link, that is also a VE UX issue.

Jdforrester-WMF moved this task to To Triage on the VisualEditor workboard.Via WebJul 21 2015, 6:18 PM
Jdforrester-WMF moved this task to TR1: Releases on the VisualEditor workboard.Via WebJul 28 2015, 7:23 PM
cscott added a subscriber: cscott.Via WebAug 20 2015, 2:55 PM

@Krenair it's mostly orthogonal to this bug, but we just changed the rel type of ISBN links to mw:WikiLink. I agree that it is more consistent that way.

The VE UX issue still exists: VE should detect edits to ISBN/RFC/PMID links and somehow keep the text and the link in sync. I don't know the best way to do that within the VE codebase.

Krinkle removed a subscriber: Krinkle.Via WebAug 20 2015, 7:44 PM
gerritbot added a subscriber: gerritbot.Via ConduitAug 25 2015, 8:15 PM

Change 233669 had a related patch set uploaded (by Cscott):
WIP: Specialized inspector for ISBN magic links

https://gerrit.wikimedia.org/r/233669

gerritbot added a project: Patch-For-Review.Via ConduitAug 25 2015, 8:15 PM
Jdforrester-WMF moved this task to TR0: Interrupt on the VisualEditor workboard.Via WebAug 26 2015, 1:35 AM
gerritbot added a comment.Via ConduitAug 27 2015, 10:22 PM

Change 233669 had a related patch set uploaded (by Cscott):
Specialized inspector for ISBN magic links

https://gerrit.wikimedia.org/r/233669

gerritbot added a comment.Via ConduitSep 1 2015, 6:34 PM

Change 233669 merged by jenkins-bot:
Specialized inspector for ISBN magic links

https://gerrit.wikimedia.org/r/233669

Jdforrester-WMF closed this task as "Resolved".Via WebSep 1 2015, 6:52 PM
Jdforrester-WMF assigned this task to cscott.
Jdforrester-WMF added a project: user-notice.Via WebSep 8 2015, 6:29 PM
Johan moved this task to Announce in next Tech/News on the user-notice workboard.Via WebSep 9 2015, 9:13 AM
Johan moved this task to In current Tech/News draft on the user-notice workboard.Via WebSep 9 2015, 9:43 AM
Johan moved this task to Recently announced in Tech/News on the user-notice workboard.Via WebSep 17 2015, 4:06 PM
Johan moved this task to Archive on the user-notice workboard.Via WebSep 23 2015, 11:50 AM

Add Comment