Page MenuHomePhabricator

Autocompletion on Special:Search page combined with "enter" key makes impossible to search a non existent article
Closed, ResolvedPublic

Description

Bug reported by Finnish Wikipedia.

On Special:Search when you type a query and hit enter key, you only have access to articles which exists.

  1. go to special:Search on Finnish Wikipedia
  2. type "tasavallan" and hit enter
  3. "Tasavallan presidentti", first suggestion, is loaded on the search form.

"tasavallan" red link result can be found by pressing "search" blue button or use the interface search field, but not with Special:Search. I've reproduced it on French Wikipedia with different words.

Suggestion would be to have the non existent result shown in a different appearance on the list.

Related Objects

StatusAssignedTask
ResolvedEsanders
OpenNone
OpenNone
OpenNone
ResolvedMarkTraceur
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
OpenNone
OpenNone
OpenNone
OpenJdlrobson
OpenJdlrobson
Resolvedmatmarex
OpenNone
Resolvedmatmarex
OpenNone
OpenNone
ResolvedEsanders
OpenNone
ResolvedTTO
ResolvedJayprakash12345
Resolvedmatmarex
OpenNone
ResolvedFlorian
ResolvedFlorian

Event Timeline

Trizek-WMF updated the task description. (Show Details)
Trizek-WMF raised the priority of this task from to Needs Triage.
Trizek-WMF added a subscriber: Trizek-WMF.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 19 2015, 2:32 PM
Trizek-WMF updated the task description. (Show Details)Jul 19 2015, 2:35 PM
Trizek-WMF set Security to None.
Stryn added a subscriber: Stryn.Jul 19 2015, 3:02 PM
Legoktm added a subscriber: matmarex.
Legoktm added a subscriber: Legoktm.
Pxos added a subscriber: Pxos.Jul 20 2015, 10:22 AM
matmarex added a subscriber: Esanders.

Hmm, we should probably look at various browsers' native autocompletion. We always highlight the first suggestion when it appears, so Enter chooses it. Maybe we should stop doing that. I wonder how it'd affect interfaces like VisualEditor's link inspector (@Esanders?).

(As a workaround, you can just press "Tab" once to focus on the "Search" button, and then press Enter to submit.)

We always highlight the first suggestion when it appears, so Enter chooses it. Maybe we should stop doing that.

Yes.

Hmm, we should probably look at various browsers' native autocompletion. We always highlight the first suggestion when it appears, so Enter chooses it. Maybe we should stop doing that. I wonder how it'd affect interfaces like VisualEditor's link inspector (@Esanders?).

The workflow is different on VE, because you can create a link to a non existent article. Here, you can't search a non existent page.

(As a workaround, you can just press "Tab" once to focus on the "Search" button, and then press Enter to submit.)

Reported as "not intuitive" by the Finnish.

(As a workaround, you can just press "Tab" once to focus on the "Search" button, and then press Enter to submit.)

Reported as "not intuitive" by the Finnish.

Yes, I agree, I've only suggested this as a workaround if you need to use the keyboard.

Hmm, we should probably look at various browsers' native autocompletion. We always highlight the first suggestion when it appears, so Enter chooses it. Maybe we should stop doing that. I wonder how it'd affect interfaces like VisualEditor's link inspector (@Esanders?).

The workflow is different on VE, because you can create a link to a non existent article. Here, you can't search a non existent page.

Actually, it seems like it works exactly the same there.

The "workaround" is how it works in VE, yes.

Change 226902 had a related patch set uploaded (by Bartosz Dziewoński):
Revert "Convert Special:Search to OOUI"

https://gerrit.wikimedia.org/r/226902

Restricted Application added a project: Discovery. · View Herald TranscriptJul 24 2015, 8:44 PM

Eww, reverting the code? :-(

Yeah, unless you have a quick fix that doesn't make the UI even more confusing, I'll follow EBernhardson's suggestion to revert (although I personally think this is a rather low-severity issue, clearly others disagree). Looks like we'll have to change OOjs UI's LookupElement to resolve this properly, which might result in unexpected UI changes in VisualEditor and such.

Kill the 'autocomplete' setting on the input box.

But the page used to have autocompletion before it was changed to use OOUI, so that would be a regression.

But the page used to have autocompletion before it was changed to use OOUI, so that would be a regression.

Minor functionality regression is better than major styling regression.

It's not a major styling regression, the page used to use MediaWiki UI, which looks good enough (and close enough to OOjs UI) for simple widgets like this.

It's not a major styling regression, the page used to use MediaWiki UI, which looks good enough (and close enough to OOjs UI) for simple widgets like this.

Not for Monobook users.

Change 226902 merged by jenkins-bot:
Revert "Convert Special:Search to OOUI"

https://gerrit.wikimedia.org/r/226902

Ltrlg added a subscriber: Ltrlg.Jul 24 2015, 9:20 PM

This task seems to be resolved, or are there any other things to do?

Yeah, I'm keeping it open as a reminder, so that it doesn't happen again when we try T100898: Convert Special:Search to OOUI next time. It might be better to close it and open a separate task, I don't really care as long as we don't forget.

(Also, the change is not deployed yet, @EBernhardson mentioned he'll do it on Monday.)

I'm fine with keeping it open :)

Nemo_bis triaged this task as Normal priority.Jul 25 2015, 5:07 PM

Change 227348 had a related patch set uploaded (by EBernhardson):
Revert "Convert Special:Search to OOUI"

https://gerrit.wikimedia.org/r/227348

Change 227348 merged by jenkins-bot:
Revert "Convert Special:Search to OOUI"

https://gerrit.wikimedia.org/r/227348

Jdforrester-WMF moved this task from Backlog to Next-up on the OOUI board.Jul 30 2015, 12:48 AM
Ironholds moved this task from Needs triage to Search on the Discovery board.Aug 4 2015, 8:17 AM

Change 251527 had a related patch set uploaded (by Florianschmidtwelzow):
LookupElement: Make auto-highlighting the first term configurable

https://gerrit.wikimedia.org/r/251527

Change 251530 had a related patch set uploaded (by Florianschmidtwelzow):
Make TitleInputWidget configurable, if term should be highlighted or not

https://gerrit.wikimedia.org/r/251530

If both changes above (^) get's merged, it's possible to specify a highlight option for TitleInputWidget, which will (depending on it's boolean state) allow a direct form submission with return (even if there are suggestions) or not :)

Change 251527 merged by jenkins-bot:
LookupElement: Make auto-highlighting the first term configurable

https://gerrit.wikimedia.org/r/251527

matmarex closed this task as Resolved.Nov 11 2015, 5:03 PM
matmarex assigned this task to Florian.
matmarex removed a project: Patch-For-Review.

Special:Search is still not using OOUI styles at the moment, but when it does (see T100898), this issue will be gone.

Change 251530 merged by jenkins-bot:
Make TitleInputWidget configurable, if term should be highlighted or not

https://gerrit.wikimedia.org/r/251530

Jdforrester-WMF moved this task from Next-up to Reviewing on the OOUI board.Nov 21 2015, 2:29 AM
Pxos removed a subscriber: Pxos.Dec 17 2015, 11:44 PM