Special:ActiveUsers' user interface is awkward (can't filter to arbitrary user groups)
Closed, ResolvedPublic

Description

https://en.wikipedia.org/wiki/Special:ActiveUsers has two checkboxes:

  • Hide bots
  • Hide administrators

What if I just want a list of active bureaucrats? Or active rollbackers? It'd be nice if you could filter to an arbitrary user group, I think. The checkboxes also feel kind of awkward.

MZMcBride updated the task description. (Show Details)
MZMcBride raised the priority of this task from to Needs Triage.
MZMcBride added a subscriber: MZMcBride.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 23 2015, 4:27 AM

Even with the dedicated checkbox, filtering to just a list of active admins doesn't seem possible. :-/

Should those checkboxes be replaced with a Special:Listusers like dropdown? Or should the checkboxes be left as is and and a new dropdown be added there without removing the checkboxes? Personally, I think the former option is better.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 12 2015, 4:52 AM
Qgil moved this task from Backlog to Team radar on the Community-Liaisons board.
Sethakill moved this task from To triage to User/User rights on the MediaWiki-Special-pages board.
Sethakill added a subscriber: Sethakill.

Change 288197 had a related patch set uploaded (by Sethakill):
Change checkboxes to dropdown.

https://gerrit.wikimedia.org/r/288197

I changed checkboxes to dropdown like Glaisher proposed. Now it looks like this:

Is that dropdown allow multiple selects (i.e. I want all admins ans stewards)? :)

Qgil awarded a token.May 12 2016, 10:10 AM

@Trizek-WMF Unfortunately no. It's simple select field with groups.

Is it possible to have a multiple selects dropdown? :3

At this moment no. We need to design and implement this field. Is it necessary at all?

I'm considering possible cases: we had a way before to choose multiple
combinations with the checkboxes. I know some requests I can have to make
can be to select multiple roles at the same time. But I can do several
requests instead of one if that's too complicated to have a multiple-select
dropdown. :)

The very best would have been to have filters (all sysops or bureaucrats
but not sysops who are bureaucrats), but I think that requires more work.

I think it would be useful to have the ability to select multiple values from the input (e.g. Administrators (sysop) and stewards). However, currently, we don't have a nice widget for this, the only one would be a CapsuleMultiselectWidget (in OOJsUI), which, unfortunately, lacks a php only widget (so it works with JavaScript only, and therefore can't be used for forms, that are (and need to be) working without JavaScript. After this problem is resolved, we can create a HTMLForm widget for that and use it on Special:ActiveUsers. For the meantime, I think that the current state is a big improvement and can be used until we've a generalised multi-select widget (there are some open tasks for that, too: https://phabricator.wikimedia.org/search/query/erXUJ6Y5J5vT/#R).

matmarex added subscribers: matmarex, Zppix.

In the current version of the patch (patchset 9), the dropdown does allow multiselect.

Krinkle added a subscriber: Krinkle.EditedOct 19 2016, 10:16 PM

@matmarex Yeah, multiselect would allow rendering of "Active users" for either all users, or for one or more specified groups.

However the old functionality wasn't whitelisting two groups, it was excluding two groups. Specifically with the purpose to render a list of all active users that weren't bots or administrators.

Even if we ignore the use case of "Hiding both bots and administrators". The use case of "Hide bots" seems quite useful and would not be satisfied by a multiselect. Even if a user would try to work around it by selecting all other groups, that would be terrible UX, but also not work since a bot may be in multiple user groups. And the resulting permalink would break whenever a new group is created.

Hmm. I think the user case in the task description (show active users in this user group) is also sensible. I guess we should add options like "Not bots", "Not administrators" etc. to the dropdown?

Is it important to completely eliminate checkboxes?. We can add them in the group menu so the users can see what they have checked .They can again uncheck some options after which the result gets displayed immediately

In which file am i supposed to make changes in order to add my code?

@Raspberrypy: Did you check the files in the patch linked above?

Qgil removed a subscriber: Qgil.Nov 2 2016, 1:56 PM

Change 288197 merged by jenkins-bot:
SpecialActiveUsers: Change checkboxes to dropdown

https://gerrit.wikimedia.org/r/288197

Jdforrester-WMF closed this task as Resolved.Nov 2 2016, 7:57 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Nice improvement here.

Trizek-WMF set Security to None.
Trizek-WMF moved this task from To Triage to In current Tech/News draft on the User-notice board.

Hide bots doesn't work. Why I'm sort only users?

This comment was removed by Boshomi.

@Boshomi I think you meant to post that on some different task?…

Krinkle added a comment.EditedNov 17 2016, 12:54 AM

Change 288197 merged by jenkins-bot:
SpecialActiveUsers: Change checkboxes to dropdown

https://gerrit.wikimedia.org/r/288197

Causes two regressions:

  1. "nobots" feature is now absent. As pointed out in T116354#2730127 this cannot be worked around.
  2. There is a flash of unstyled content in two aspects:
    • Labels have a blank space to the left of them that isn't there initially.
    • Checkboxes are visible at first but are replaced with a dropdown menu after 1-2 seconds or so when using www.mediawiki.org (Chrome latest, MacBook Pro, Fibre, unthrottled)
matmarex reopened this task as Open.Nov 18 2016, 3:01 PM
matmarex claimed this task.

Change 322265 had a related patch set uploaded (by Bartosz Dziewoński):
SpecialActiveUsers: Allow excluding groups too

https://gerrit.wikimedia.org/r/322265

matmarex added a comment.EditedNov 18 2016, 3:07 PM

"nobots" feature is now absent. As pointed out in T116354#2730127 this cannot be worked around.

Okay, I agree this was a mistake. The patch above brings this back.

Labels have a blank space to the left of them that isn't there initially.

This looks like a new Chrome bug regarding the display of <legend> elements, because I can't reproduce this in any other browsers, and it definitely was not happening when I was merging that patch. Filed as T151061.

Checkboxes are visible at first but are replaced with a dropdown menu after 1-2 seconds or so when using www.mediawiki.org (Chrome latest, MacBook Pro, Fibre, unthrottled)

Yes, this is known and was discussed on the patch. I think it's a very small issue, and resolving it would be a lot of work (we'd have to rewrite all the JS code that renders the dropdown into PHP, and render both the functional checkboxes and this non-functional fake in HTML output).

Change 322265 merged by jenkins-bot:
SpecialActiveUsers: Allow excluding groups too

https://gerrit.wikimedia.org/r/322265

matmarex closed this task as Resolved.Nov 21 2016, 10:38 PM