Page MenuHomePhabricator

Move Phabricator from PHP 7.0 to PHP 7.2
Closed, ResolvedPublic

Description

Steps to reproduce

  • There is no steps as this is a feature request.

We should start experimenting with php 7.2 as php 7 includes performance improvements and may reduce the load on phabricator.

Reason we should go with php 7.2 and not 7.0 is because phabricator deamons wont work correctly with php 7 and so they have blocked support for php 7.


This task is now about testing it on wmf as upstream have added support for php 7.2 but have made php 7.0 unsupported.

Related Objects

Event Timeline

Paladox created this task.Nov 18 2016, 5:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 18 2016, 5:03 PM
Paladox removed a subscriber: Phabricator.

I doint know what other tags I should add to this task.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptNov 18 2016, 5:04 PM
Paladox renamed this task from Experimental with php 7.1 on phabricator to Experiment with php 7.1 on phabricator.Nov 18 2016, 5:06 PM

So far this task seems to be based on speculation. Not a single reference for the statements made has been provided.
Please refrain from posting tasks without any references as they are not a good use of anybody's time.

Proposing to close as invalid.

demon added a subscriber: demon.Nov 18 2016, 5:09 PM

So far this task seems to be based on speculation. Not a single reference for the statements made has been provided.
Please refrain from posting tasks without any references as they are not a good use of anybody's time.
Proposing to close as invalid.

This comment isn't very helpful. Whether we act on it or not, the suggestion provided by the task is completely valid.

php 7 performance http://www.zend.com/en/resources/php7_infographic

upstream disabling php 7 support because of a bug https://secure.phabricator.com/rPb53831101f39b15eb9d92fd4b037cf00c8d6b4f7

And upstream here saying they wont support php 7 until 7.1 comes out https://secure.phabricator.com/T9640#184099

Indeed the suggestion is valid.
I merely ask the reporter to please do some basic research first and provide references before creating such tasks. In general.

Indeed the suggestion is valid.
I merely ask the reporter to please do some basic research first and provide references before creating such tasks. In general.

Sorry.

I have done that now in https://phabricator.wikimedia.org/T151070#2806567

demon added a comment.Nov 18 2016, 5:14 PM

Indeed the suggestion is valid.
I merely ask the reporter to please do some basic research first and provide references before creating such tasks. In general.

Fair enough, research is great. But lack of adding links isn't a reason to close a task invalid as long as the OP and the people who are going to work on it understand things just fine.

I apologize for writing "Proposing to close as invalid". That was not justified.
Still I ask the reporter for less "impulsive" comments/descriptions and spending more time to phrase them before publishing them.

Peachey88 changed the task status from Open to Stalled.Jan 12 2017, 6:30 AM
Peachey88 edited projects, added Phabricator (Upstream); removed Phabricator.
Peachey88 added a subscriber: Peachey88.

The upstream task about PHP7 support appears to be: https://secure.phabricator.com/T9640.

I'm setting this task as stalled for now, Because I don't think we should be spending time testing something until upstream starts to support it so we don't build tech-debt having to maintain the infrastructure (and the possibility of custom patches) if they choose not to support php7.

Please feel free to revert the status change if you disagree with my views etc etc

Restricted Application added a project: Upstream. · View Herald TranscriptJan 12 2017, 6:30 AM

Re opening as upstream now support php 7.1+

Paladox changed the task status from Stalled to Open.Jan 13 2017, 12:54 AM
Paladox moved this task from Backlog to Ready To Go on the Phabricator (Upstream) board.

I've tested this on my windows 10 machine which comes with ubuntu on windows bash so i basically ran it on a linux system not windows and it worked.

No errors currently.

This can now be moved forward for prod as this will speed up phabricator in some areas (i doint have any estimates and this is just guessing based on research carried out on php being tested on mediawiki using php 5 and then php 7.)

Paladox updated the task description. (Show Details)
Paladox moved this task from To Triage to Misc on the Phabricator board.Feb 17 2017, 4:57 PM
Dzahn added a subscriber: Dzahn.Feb 12 2018, 10:48 PM

T182832#3965043 now about upgrading to 7.1. experimenting early wouldn't have been bad after all.

Yep. I've spun up a testing stretch instance for phabricator.

I will create a task to add support for stretch within the phabricator class.

I've tested buster php 7.1 packages on stretch and they work see https://phab-stretch.wmflabs.org

Maybe we can either pin php* and the apache2 php package to buster or backport buster packages into stretch-wikimedia?

Aklapper moved this task from Misc to Infrastructure on the Phabricator board.Aug 29 2018, 6:05 PM

Experimentation done? :-)

Dzahn added a comment.May 15 2019, 7:15 PM

We could rename this to PHP 7.2.

Paladox renamed this task from Experiment with php 7.1 on phabricator to Experiment with php 7.2 on phabricator.May 15 2019, 7:17 PM
Paladox updated the task description. (Show Details)

Is there a task beyond T190568 under which "move Phab to PHP72" would go?

Dzahn added a comment.EditedMay 15 2019, 7:20 PM

No, i think the one you linked is the best match currently. It does not necessarily have to be on the same day to switch jessie -> stretch and to PHP 7.2.. it could be separate.

Note: We already have support for this in phabricator's puppet module, we just need to tweak so that it best handles phabricator's load.

Jdforrester-WMF renamed this task from Experiment with php 7.2 on phabricator to Move Phabricator from PHP 7.0 to PHP 7.2.May 15 2019, 7:25 PM
Dzahn added a comment.May 15 2019, 7:29 PM

phab1001, current prod server on jessie is on PHP 5.

phab1003, upcoming stretch server is on PHP 7.2 but we still want to setup php-fpm

Phabricator wouldn't work on PHP 7.0

Change 512080 had a related patch set uploaded (by 20after4; owner: 20after4):
[operations/puppet@production] phab: include php-ldap in the php-fpm config

https://gerrit.wikimedia.org/r/512080

Change 512080 merged by Dzahn:
[operations/puppet@production] phab: include php-ldap in the php-fpm config

https://gerrit.wikimedia.org/r/512080

Change 512082 had a related patch set uploaded (by 20after4; owner: 20after4):
[operations/puppet@production] phab: Configure sapis for all php extensions

https://gerrit.wikimedia.org/r/512082

Dzahn closed this task as Resolved.May 23 2019, 4:49 AM
Dzahn claimed this task.

phab is on phab1003 now which runs PHP 7.2

Change 512082 merged by Dzahn:
[operations/puppet@production] phab: Configure sapis for all php extensions

https://gerrit.wikimedia.org/r/512082