Page MenuHomePhabricator

Sometimes old WikiText editor loads after user has switched to new WikiText editor
Closed, ResolvedPublic1 Story Points

Description

I switched over the the new WikiText editor yesterday, but I still randomly get the old WikiText editor when clicking the Edit tab on articles. I suspect this is an issue with the init code being slow to load.

Event Timeline

kaldari created this task.Dec 17 2016, 10:42 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 17 2016, 10:42 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm added a subscriber: Urbanecm.EditedDec 18 2016, 7:43 PM

I don't think this is radomly. If I wait some amount of time, always NWE shows. So probably this is slowly-loading code.

What browser/OS are you using? I haven't counted carefully, but I feel like I'm seeing this more often in Firefox 50 than in Safari 10.

I just opened ten pages via Special:Random at enwiki in each browser. In Safari, all 10 opened in the 2017 wikitext mode. In Firefox, the first opened with no toolbar at all (the 2003 wikitext editor?), the second and eighth in the 2010 WikiEditor, and the other seven opened as expected in the 2017 wikitext mode. One possibility: Does it load the older versions if the page hasn't finished loading (in Read mode) before I clicked the 'Edit source' button?

Nnvu added a subscriber: Nnvu.Dec 19 2016, 4:20 PM
Nnvu added a comment.Dec 19 2016, 4:40 PM

Using Chrome 55.0.2883.87 m, I never get to use the 2017 wikitext editor when I click on the "Edit wikitext" tab. I always have to click the "Edit wikitext" tab, wait for the 2010 wikitext editor to load, then click again on the "Edit wikitext" tab and I can finally use the 2017 WikiEditor. I've made a few try using Firefox 49.0.2 and I've always got the 2017 WikiEditor.

I have problems only sometime with Chrome. Strange...

Nnvu added a comment.Dec 19 2016, 8:27 PM

I forgot to mention that I have this problem only in ns0, apparently.

I'm using Firefox 50. It does seem to be related to slow-loading code. If I wait to make sure the page has completely loaded, I always get the new 2017 editor.

Nnvu added a comment.Dec 19 2016, 9:31 PM

Yeah, I've tried waiting using Chrome (like 10 minutes) but the new 2017 WikiEditor never loaded, I've always got the 2010 editor.

Nnvu added a comment.Dec 20 2016, 6:03 PM

I've noticed something else: (using Chrome) if I click "Edit source" tab when I'm reading a page I get the 2010 WikiEditor, but if I click "Edito source" from any other tab (History or checking a Diff) I always get the 2017 WikiEditor.

Arrbee added a subscriber: Arrbee.Jan 4 2017, 10:03 AM

I saw this happening when clicking red links i.e. if I select 'Edit Source' on an existing page I see the NWE, but if I click on a red link it shows me the old wikitext editor.

Dvorapa added a subscriber: Dvorapa.Jan 4 2017, 2:31 PM

I can claim this bug I use almost every time keyboard shortcut (alt-shift-e) and it behaves that way really randomly. I think it could be something with namespaces or some different page property, which is more widely expanded through wiki pages

@Dvorapa: Is your account configured to show one tab or two ("Edit" and "Edit source")?

Cswiki users can't have one tab yet. Dvorapa is cswiki user.

I saw this happening when clicking red links i.e. if I select 'Edit Source' on an existing page I see the NWE, but if I click on a red link it shows me the old wikitext editor.

Always?

Urbanecm moved this task from Backlog to Watching on the User-Urbanecm board.Jan 6 2017, 6:57 AM
Dvorapa added a comment.EditedJan 7 2017, 1:55 PM

I found out, that if I press alt-shift-e (to edit a page) when being on its ''What links here'' or ''Related chanes'' page, every time it opens OWE instead of NWE (tested today on cswiki, single edit tab is not accessible for this wiki yet)

Elitre added a subscriber: Elitre.Jan 19 2017, 4:59 PM

I have managed to reproduce this after Pearli reported that he gets the issue when editing a talk page, and then clicking the Edit source link for that section again.

Pearli123 added a subscriber: Pearli123.EditedJan 23 2017, 7:32 PM

It's usually after saving the page and didn't reload it, then clicking edit source again. I think there is a problem with some javascript code.

EDIT:
I've tested other scripts like in gadgets-tab of settings on german wikipedia, and after saving a talk page, none of the scripts start working. Well, i hope it'll help.

I think this bug is common with VisualEditor.

I'm getting this a lot today, and I'm not editing a section. (I have just enabled the 2017WE at ru.wiki, and still get the old editor occasionally.)

Jdforrester-WMF changed the task status from Open to Stalled.Feb 21 2017, 8:30 PM
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

From what I can see, this might be a JavaScript-delivery issue (your browser has chosen not to load the code, e.g. because the network died) but I can't tell for sure. :-( Does anyone have reliable reproduction steps (beyond the below)?

It's usually after saving the page and didn't reload it, then clicking edit source again. I think there is a problem with some javascript code.

That one is T151021: Section(?) edit links aren't re-set-up on save, so clicking on section link opens OWE and then switches to NWE on second edit without a refresh.

I put a few requests for help out.

Stryn added a subscriber: Stryn.Feb 28 2017, 5:00 PM

When I click some link in Wikipedia and then click "edit source" before than the page is fully loaded (under 1 second), it will be opened in the old editor for me. I'm using Firefox. So it's as Kaldari said above. And red links are always opened in the old editor.

Cirdan added a subscriber: Cirdan.Feb 28 2017, 6:57 PM

This was probably fixed by https://gerrit.wikimedia.org/r/#/c/350582/ as going to ?action=edit will now evaluate on the server side that you actually want the new wikitext editor. (not yet deployed)

Jdforrester-WMF closed this task as Resolved.May 10 2017, 3:45 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF set the point value for this task to 1.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 10 2017, 3:45 PM