Page MenuHomePhabricator

'Potential Issues' from ORES should be flagged in Page Curation Toolbar Page Info flyout
Closed, ResolvedPublic3 Story PointsFeature

Description

Current behavior:

The Page Curation tool flags Potential issues in the Page info tab of the page curation toolbar.
These include: Blocked user, Orphan, No categories, No citations etc. There is also a red number on the tab icon indicating the number of potential issues.

Desired behavior:

  • In addition to the existing potential issues, include the "new" potential issues that were added by the Growth team to the feed. These include Spam, Vandalism, and Attack. These are currently available in the NPP feed but are not displayed in the curation toolbar. You can see them here flagged under the "Review" buttons:

Notes:

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

The "Possible issues" functionality is already present in the code but is broken. It was possibly broken by a dev in this commit. It already has support for the 'Blocked user', 'Orphaned', 'No categories' and 'No references' flags. I have submitted a patch which should fix this feature.

Force_Radical added a comment.EditedFeb 26 2019, 3:29 PM

@Niharika would it be possible to get a code review of the patch ? It would be great if this interim fix could be deployed in the next MediaWiki release. Pinging @Insertcleverphrasehere in case they prefer a later release with all the features requested .

@Force_Radical My team doesn't intend to start working on this project for another few weeks. @MMiller_WMF Can someone from Growth do a code review on this?

MMiller_WMF added a subscriber: Catrope.

@Force_Radical -- thanks for working on this code! Yes, I can put this in the queue for Growth team engineers to look at.

@Catrope -- this is going in our code review column.

MMiller_WMF added subscribers: kostajh, SBisson.

Moving volunteer patch into code review column.

kostajh changed the subtype of this task from "Task" to "Bug Report".

I have made the changes to the patch.

Change 492474 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Unbreak potential issues flyout

https://gerrit.wikimedia.org/r/492474

@Insertcleverphrasehere @Force_Radical This change has rolled out last week. Can you confirm if it is works as expected now?

The feature appears to be working as expected yes! I have seen flags for 'Orphan', 'No categories' and 'Blocked Users' are working (the stuff that was originally intended to be implemented). And it is pulling up a red number next to the 'I' symbol related to the number of issues, which is perfect.

It still needs to add the ORES issues that are flagged in the New Pages Feed (Vandalism, Spam, Attack, Copyvio) as well as the others requested in related Phab tasks of the 'additional Tie ins' listed above, so this task should remain open, but great work so far! Thanks, @Force_Radical!

Checked in betalabs - the flag is present and the issues are listed.

To note (besides the issues with missing ORES scores by @Insertcleverphrasehere).

(1) Articles that have ORES "Potential issues: None" may still have Potential issues flagged in flyout (cause Potential issues scoring is independent). Reviewed pages will display Potential issues too.
(2) On Special:NewPagesFeed is not possible to filter e.g. just for pages that 'Are orphaned'. The returned result set will have the pages that are orphaned and orphaned pages that have other problems.

Returning for additional work to Communty-Tech.

Restricted Application added a project: Growth-Team. · View Herald TranscriptMar 18 2019, 10:49 PM

On a side note, we did notice that the 'no references' flag doesn't look for alternate citation styles, only </ref> tags. So it will flag an article that uses an alternate citation style (such as https://en.wikipedia.org/wiki/Get_to_the_Boat) as having 'no references'. Thought it worth reporting the bug, even if it is a relatively uncommon occurrence.

Thanks for the thorough QA, Elena! I'll pull it on the Community-Tech board when we get started on the project.

JTannerWMF moved this task from Inbox to External on the Growth-Team board.Mar 19 2019, 5:44 PM
Niharika triaged this task as Normal priority.Mar 20 2019, 4:34 PM
Niharika updated the task description. (Show Details)
Niharika updated the task description. (Show Details)
Niharika changed the subtype of this task from "Bug Report" to "Feature Request".
Niharika renamed this task from 'Potential Issues' flagged in Page Curation Toolbar Page Info flyout to 'Potential Issues' from ORES should be flagged in Page Curation Toolbar Page Info flyout.Jun 20 2019, 5:12 PM
Niharika updated the task description. (Show Details)
Niharika removed Force_Radical as the assignee of this task.Jun 20 2019, 5:17 PM
Niharika set the point value for this task to 3.
Niharika moved this task from To be estimated/discussed to Estimated on the Community-Tech board.

Change 518816 had a related patch set uploaded (by MusikAnimal; owner: MusikAnimal):
[mediawiki/extensions/PageTriage@master] Indicate possible copyvio in 'potential issues' info flyout

https://gerrit.wikimedia.org/r/518816

@Niharika The "Copyvio" indicator on the main Special:NewPagesFeed interface has a link to the copyvios tool. I assume we'll want to do the same for the info flyout?

Meanwhile, as it turns out, the ORES-based potential issues aren't stored as tags like the other issues are. I guess the thought is they're already pre-stored in the ORES tables, so we don't need to duplicate them in PageTriage. It is certainly possible to surface them in the info flyout but I think it might be pretty tricky. More to come on that.

@MusikAnimal Yes, having the link is desirable.
When you say surfacing ORES-based potential issues will be tricky, which specific potential issues are we talking about?

(didn't mean to move this to "needs review")

Yes, having the link is desirable.

Thanks, I'll get that added.

When you say surfacing ORES-based potential issues will be tricky, which specific potential issues are we talking about?

"Spam", "Vandalism", and "Attack". We just need to query the ORES tables, certainly doable.

Ready for review: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/PageTriage/+/518816 This only includes surfacing copyvios. ORES to come in a separate patch.

Note to reviewers: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/PageTriage/+/518816#message-3e56e630d3ae4e74946f471f923cb3083f26c5b9

@kostajh @Catrope How did you manage to get ORES / Copyvios working on your local? For the above, I simulated a copyvio by manually entering a row in pagetriage_page_tags. Doing this for ORES seems very non-trivial, and as far as I can tell ORES only works in production?

@kostajh @Catrope How did you manage to get ORES / Copyvios working on your local? For the above, I simulated a copyvio by manually entering a row in pagetriage_page_tags. Doing this for ORES seems very non-trivial, and as far as I can tell ORES only works in production?

Sorry for the late reply, IIRC, I manually inserted rows into pagetriage_page_tags for copyvio. For ORES, if I remember right, I set wgOresWikiId to testwiki.

Change 518816 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Indicate copyvio under "Possible issues" in info flyout

https://gerrit.wikimedia.org/r/518816

Now working on surfacing ORES issues. Thanks for the tips, kostajh

Adding copyvios as a potential issue is now tracked at T227218 (patch has been merged). This task is now solely about surfacing the ORES issues.

MusikAnimal removed MusikAnimal as the assignee of this task.Jul 10 2019, 5:04 PM
MusikAnimal added a subscriber: MusikAnimal.
ifried added a subscriber: ifried.Jul 17 2019, 6:13 PM

Change 525163 had a related patch set uploaded (by MusikAnimal; owner: MusikAnimal):
[mediawiki/extensions/PageTriage@master] Add ORES draft quality prediction to toolbar info panel

https://gerrit.wikimedia.org/r/525163

This is ready for review.

Note that we aren't showing a description for the ORES issue, which we do for the other issues. This is because the draft quality predictions are variable; even on English Wikipedia, a new draft quality classification could be introduced and we'd have to remember to create a new description in PageTriage. Instead we show only the classification label, which is already localized, without a description.

Change 525163 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Add ORES draft quality prediction to toolbar info panel

https://gerrit.wikimedia.org/r/525163

dom_walden added a subscriber: dom_walden.

Testing on my local environment, adding scores directly into the ores_classification table. I can see the tags 'Attack', 'Spam' or 'Vandalism' appear in the "Page info" as appropriate.

If ORES marks it as 'OK', then no tag appears.

@Barkeep49 @Insertcleverphrasehere This work should now be live. Can you verify if you're seeing these changes in the curation toolbar? Thanks!

@ifried It appears it is working. Is there a reason that there isn't accompanying text like there are for the other issues? So like "Spam - ORES has identified that this article as containing spam at one time" (is this right? I know the COPYVIO trigger never goes away even after it's been fixed and am guessing this is true for Spam, Vandalism, and attack)

ifried added a comment.EditedTue, Aug 6, 6:19 PM

@Barkeep49 -- Thanks for verifying. In response to your question, @MusikAnimal wrote a bit about this in the above comments from Tue, Jul 23. In short, we only show the classification label without a description. There are complications in displaying customized descriptions, and undesirable hacks would be required to display them. Regarding your question about whether the trigger/label disappears (after the issue is resolved): The logic that's used to pull ORES data for the feed is the same as the one we're now using in the toolbar flyout. For this reason, the labels should have the same behavior as those displayed in Special:NewPagesFeed.

ifried closed this task as Resolved.Tue, Aug 6, 6:20 PM