Page MenuHomePhabricator

Regression: Wikidata item missing in Monobook (WikibaseClient should use the SidebarBeforeOutput hook instead of BaseTemplateToolbox)
Closed, ResolvedPublic

Description

The BaseTemplateToolbox hook is being deprecated (T253416).

The SidebarBeforeOutput hook now includes the toolbox so that hook can be used to add to this array instead

Tech notice: A fix will be available the week of 8th June. Apologies for the inconvenience.

Event Timeline

Ammarpad created this task.Jun 4 2020, 2:32 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptJun 4 2020, 2:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 602385 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/extensions/Wikibase@master] Use SidebarBeforeOutput to add 'Wikidata item' to sidebar.

https://gerrit.wikimedia.org/r/602385

Ammarpad claimed this task.Jun 4 2020, 5:12 PM

Change 602385 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Use SidebarBeforeOutput to add 'Wikidata item' to sidebar.

https://gerrit.wikimedia.org/r/602385

Jdlrobson renamed this task from WikibaseClient should use the SidebarBeforeOutput hook instead of BaseTemplateToolbox to Regression: Wikidata item missing in Monobook (WikibaseClient should use the SidebarBeforeOutput hook instead of BaseTemplateToolbox).Jun 5 2020, 4:26 PM
Jdlrobson added projects: MonoBook, Regression.
Jdlrobson added subscribers: Wurgl, Jdlrobson.

Apologies, due to an error on my part I merged a Monobook patch earlier than I should have meaning the wikidata item is not showing on Monobook (@Wurgl). This patch will fix that so we might want to SWAT this early next week.

Jdlrobson closed this task as Resolved.Jun 5 2020, 8:38 PM

N.B. js hack added in enwiki MediaWiki:Monobook.js

This would be good moment to add Wikidata at the "In other projects" section, not in "Tools".

This would be good moment to add Wikidata at the "In other projects" section, not in "Tools".

I agree. For reference:
T76002: Add Wikidata to the other projects sidebar - This was done in 2014?
T66315: Move "Data item" link outside of sidebar toolbox

A dozen users in en:wp decide. No comment.

"Other projects" has a Wikidata link, that's enough imho. Both are hard to notice...

I'm not saying that is an overwhelming amount of feedback - but it is user feedback, there are only 14 subscribers on this task as well. Some of the feedback is that links to wikidata aren't as useful for readers as they are for editors, as wikidata isn't really reader content; but it is very useful as a tool for editors that incorporate the data in to the presentation content.

SerDIDG added a subscriber: SerDIDG.Jun 8 2020, 8:40 AM
MBH added a subscriber: MBH.Jun 8 2020, 11:59 AM
Sailko added a subscriber: Sailko.Jun 8 2020, 9:48 PM

Please fix it for Vector skin too. Several editors still use that. I cannot link commons to wikipedia anymore. Thank you.

Please fix it for Vector skin too. Several editors still use that. I cannot link commons to wikipedia anymore. Thank you.

I am using Vector and in Commons, I am seeing "Wikidata item" item and "In other projects" section. And similarly I can see them on English Wikipedia.
Please open a new task with description of how to reproduce the problem. The original problem in this task is resolved. Thanks.

Sailko added a comment.Tue, Jun 9, 6:56 AM

Please fix it for Vector skin too. Several editors still use that. I cannot link commons to wikipedia anymore. Thank you.

I am using Vector and in Commons, I am seeing "Wikidata item" item and "In other projects" section. And similarly I can see them on English Wikipedia.
Please open a new task with description of how to reproduce the problem. The original problem in this task is resolved. Thanks.

I wanted to say "Monobook" skin, sorry. I don't know how to open a new task, is there any tutor that can help me? Thank you.

I wanted to say "Monobook" skin, sorry. I don't know how to open a new task, is there any tutor that can help me? Thank you.

Ok, it has been fixed. I don't know whether it was deployed or when it will, but you should just give it some few days. It'll be back.

Sailko added a comment.Tue, Jun 9, 7:15 AM

Thanks for the message. It actually appears in "other projects" only where there is another project already (like commons, quote etc.). Otherwise it doesn't appear at all :(

Ok, it has been fixed. I don't know whether it was deployed or when it will, but you should just give it some few days. It'll be back.

T254485#6197089
It was merged on Friday, Jun 05th. It seems it wasn't Backported (previously SWAT), thus it will be deployed on big wikis (enwiki) on Thursday, Jun 11th.

Thanks for the message. It actually appears in "other projects" only where there is another project already (like commons, quote etc.). Otherwise it doesn't appear at all :(

You can (temporarily, until the problem is really fixed) add a hotfix in your personal monobook.js, as en.wikipedia did. The code is there https://en.wikipedia.org/wiki/MediaWiki:Monobook.js (last dozen of lines)

Thank you, it worked!
Francesco

Il giorno mer 10 giu 2020 alle ore 02:21 Rhadamante <
no-reply@phabricator.wikimedia.org> ha scritto:

Rhadamante added a comment. View Task
https://phabricator.wikimedia.org/T254485

In T254485#6204761 https://phabricator.wikimedia.org/T254485#6204761,
@Sailko https://phabricator.wikimedia.org/p/Sailko/ wrote:

Thanks for the message. It actually appears in "other projects" only where
there is another project already (like commons, quote etc.). Otherwise it
doesn't appear at all :(

You can (temporarily, until the problem is really fixed) add a hotfix in
your personal monobook.js, as en.wikipedia did. The code is there
https://en.wikipedia.org/wiki/MediaWiki:Monobook.js (last dozen of lines)

*TASK DETAIL*
https://phabricator.wikimedia.org/T254485

*EMAIL PREFERENCES*
https://phabricator.wikimedia.org/settings/panel/emailpreferences/

*To: *Ammarpad, Rhadamante
*Cc: *Rhadamante, Sailko, MBH, SerDIDG, NordNordWest, Demian,
Lydia_Pintscher, Lea_Lacroix_WMDE, DannyS712, Izno, Xaosflux, JohanahoJ,
Nirmos, Jdlrobson, Wurgl, WMDE-leszek, Aklapper, Ammarpad, darthmon_wmde,
Viztor, Nandana, lucamauri, Amorymeltzer, Lahi, Gq86, GoranSMilovanovic,
Jayprakash12345, QZanden, LawExplorer, JJMC89, _jensen, rosalieper,
Scott_WUaS, Johan, Wong128hk, Luke081515, Wikidata-bugs, aude, Isarra,
TheDJ, Mbch331, Rxy, Jay8g