Page MenuHomePhabricator

l10n-update not updating Vector and extensions
Closed, DeclinedPublic

Description

https://gerrit.wikimedia.org/r/#/c/219217/1/i18n/mn.json,cm was not reflected in https://en.wikipedia.org/wiki/MediaWiki:Vector-more-actions/mn , nor https://gerrit.wikimedia.org/r/#/c/219217/1/i18n/bs.json,cm (https://translatewiki.net/w/i.php?title=MediaWiki%3AVector-action-move%2Fbs&type=revision&diff=6291923&oldid=5600758 ) in https://meta.wikimedia.org/wiki/MediaWiki:Vector-action-move/bs . https://meta.wikimedia.org/wiki/MediaWiki:Vector-action-move/bs has the correct translation, presumably thanks to the new branch.

Spotted by Srdjan_m.

I did not check other repositories.

Confirmed with Echo as of 2015-11-20:

$ for file in *json; do git blame $file; done  | grep -E "otification-header-(edit-thank|mention-nosection|mention)" | grep 2015-11-19
85943737 (Translation updater bot 2015-11-19 21:35:25 +0100  86)        "notification-header-mention": "$1 در $4 در صفحهٔ بحث $3 به شما {{GENDER:$2|اشاره کرد}}.",
85943737 (Translation updater bot 2015-11-19 21:35:25 +0100  88)        "notification-header-mention-nosection": "$1 در [[:$4|صفحهٔ بحث $3]] به شما {{GENDER:$2|اشاره کرد}}.",

But https://fa.wikipedia.org/wiki/%D9%85%D8%AF%DB%8C%D8%A7%D9%88%DB%8C%DA%A9%DB%8C:Notification-header-mention is still in English.

Event Timeline

Nemo_bis created this task.Jun 25 2015, 5:29 PM
Nemo_bis updated the task description. (Show Details)
Nemo_bis raised the priority of this task from to High.
Nemo_bis added projects: Deployments, I18n.
Nemo_bis added a subscriber: Nemo_bis.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 25 2015, 5:29 PM
Krenair added a subscriber: Krenair.

I have a feeling this is something to do with:

18922 Unknown modifier 'b': [/^Vector\-action\-move/bs/i] in /srv/mediawiki/php-1.26wmf10/includes/specials/SpecialAllMessages.php on line 311

I have a feeling this is something to do with:

18922 Unknown modifier 'b': [/^Vector\-action\-move/bs/i] in /srv/mediawiki/php-1.26wmf10/includes/specials/SpecialAllMessages.php on line 311

https://gerrit.wikimedia.org/r/#/c/220831/

I know nothing about localisation update. (And I have no idea why this would affect it?)

matmarex removed a subscriber: matmarex.Jun 25 2015, 7:20 PM
mmodell moved this task from To Triage to Backlog (Tech) on the Deployments board.Jul 13 2015, 6:21 PM

Do you know if this has happened again since then?

git log i18n assists us; looks like the error keeps occurring: https://ky.wikipedia.org/wiki/MediaWiki:Vector-more-actions is still in English, AKA 800b50ffbde132faa506a1a0f095549bd5686d58 was not reflected on the wikis by LocalisationUpdate. (There were no changes in en.json since August 2014).

Reedy added a subscriber: Reedy.EditedAug 13 2015, 7:50 PM

git log i18n assists us; looks like the error keeps occurring: https://ky.wikipedia.org/wiki/MediaWiki:Vector-more-actions is still in English, AKA 800b50ffbde132faa506a1a0f095549bd5686d58 was not reflected on the wikis by LocalisationUpdate. (There were no changes in en.json since August 2014).

It's not in English for me, it shows "Кененирээк", but ofc, that's not probably localisationupdate fixing it

Reedy added a comment.Aug 14 2015, 8:23 AM

It'd be interesting to see if this is actually all skins, only vector, all extensions... Or just anything that isn't core

It'd be interesting to see if this is actually all skins, only vector, all extensions... Or just anything that isn't core

There are some reports about WikimediaMessages group* messages too.

Honestly, I do not have time to debug localisation update issues on the production on my own.

If there are sufficient reports that it is broken, we can ask someone to look into it.

Nemo_bis added a subscriber: greg.Sep 17 2015, 6:18 AM

Usually reports come when it's too late, i.e. when some prominent feature/string is enabled that proves impossible to translate. :)

Greg, deployments for the skin (and perhaps more) can't currently be trusted to work as expected; do Deployments maintainers plan to do something about it?

Nemo_bis renamed this task from l10n-update not updating Vector to l10n-update not updating Vector and extensions.Sep 22 2015, 4:18 PM

If the problem was just localizationupdate, then today's full scap would have resolved the issue. That doesn't seem to be the case so I think the issue is somewhere else.

That comment is old, see task description for an up to date one (as well as a procedure to find more test cases).

jeblad removed a subscriber: jeblad.Aug 25 2017, 11:49 PM
Krinkle closed this task as Declined.Sep 12 2018, 2:33 AM
Krinkle added a subscriber: Krinkle.

Seems to work fine now. Please file a new task if/when similar issues are seen.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptSep 12 2018, 2:33 AM