Page MenuHomePhabricator

Deploy ULS/UniversalLanguageSelector to all Wikimedia wikis (tracking)
Closed, DuplicatePublic

Description

Author: etjazz

Description:
This is not about a bug! I just follow the guidelines at Wikipedia Village Pump about proposals for changes in the software and post this here.

I just have a suggestion of a very general type: Would it be possible to add a means to switch language from every Wikimedia page? Some pages contain the possibility to switch to another language, but some have not. I am multilingual, and therefore would need such a feature quite frequently. If there is no link to other languages, or the language I want to go to is not listed, it is always quite awkward to restart from scratch at the homepage.


Version: unspecified
Severity: enhancement
URL: https://bugzilla.wikimedia.org/buglist.cgi?status_whiteboard_type=allwordssubstr&query_format=advanced&status_whiteboard=UniversalLanguageSelector-fixed
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=43359
https://bugzilla.wikimedia.org/show_bug.cgi?id=39960
https://bugzilla.wikimedia.org/show_bug.cgi?id=34590

Details

Reference
bz13097

Related Objects

StatusAssignedTask
ResolvedNone
ResolvedNikerabbit
ResolvedNone
Declinedsiebrand
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
DuplicateNikerabbit
ResolvedNone
ResolvedNone
Resolvedsanthosh
DeclinedPginer-WMF
ResolvedAmire80
ResolvedAmire80
OpenNone
ResolvedNone
ResolvedNikerabbit
ResolvedNikerabbit
DeclinedNone
Resolvedsanthosh
Resolvedori
DeclinedNone
Resolvedtomasz
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
Resolvedbrion
DeclinedNone

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 10:04 PM
bzimport set Reference to bz13097.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Feb 21 2008, 5:39 PM

etjazz wrote:

What about a multilingual search? Would also be handy...

brion added a comment.Dec 19 2008, 2:16 AM

Deassigning myself, leaving this for the general queue after we mull over some stuff.

This will be solved by [[mw:Universal_Language_Selector]], you might want to add your feedback there.

(In reply to comment #3)

This will be solved by [[mw:Universal_Language_Selector]], you might want to
add your feedback there.

Switching from LATER to the second most relevant resolution for fear of information loss. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/65116
(Should probably be marked duplicate of some tracking bug for ULS deployment now.)

Since I couldn't find a deployment tracker, converting this one to it.

Also adding a handful of bugs I think are blockers. Selected based on their bug titles only (looked specifically for quality and usability).

If some are less important, please remove them with rationale. And add more as needed.

Clarifying summary: this is not a tracking bug for regular i18ndeploy requests (shell requests for WebFonts/Narayam/ULS on individual wikis).

  • Bug 34982 has been marked as a duplicate of this bug. ***

(In reply to comment #8)

This is nearly done, see
https://www.mediawiki.org/wiki/UniversalLanguageSelector/Deployment/Planning

That was completed on 2013-07-09 as planned, but I don't think that fixes this bug yet because language selection is for logged-in users only; blocker bug 42186 is still open.
Ops have not yet come up with a solution for that, so no plans exist and there are no useful bug reports, but as soon as they exist they should be added as blockers of this bug.

See Erik's bug 46306 comment 115 for the current status of plans.

All subtasks already belong to a specific column on the Wikimedia-Extension-setup project board.

Would someone wants to keep this tracking bug or could we close it?

Aklapper added a subscriber: Arrbee.

All subtasks already belong to a specific column on the Wikimedia-Extension-setup project board.
Would someone wants to keep this tracking bug or could we close it?

Language-Team / @Arrbee should know...

Nikerabbit closed this task as Resolved.Jul 12 2016, 9:06 AM
Nikerabbit claimed this task.
Nikerabbit added a subscriber: Nikerabbit.

Just forgotten.

Forgotten by whom? ULS (this task) is the proposed solution for T5665, which is not fixed yet. T58464 is the current culprit.

What's unclear is whether T58292 is really still open or can be considered resolved/not a blocker.

Niklas on IRC:

Nikerabbit> Nemo_bis: so mark something as dupe then?

Now fixing some relations to skip the middlemen and reduce open tasks...

ULS extension (what this task was about) itself has been deployed to all wikis. Anonymous language selection was never a requirement for finishing this task.