Page MenuHomePhabricator

Feedback for creator should also be posted to article talk page
Closed, ResolvedPublic5 Story Points

Description

Value proposition

When reviewing an article with Page Curation, you have the option to 'add a message to creator'. It has been suggested that these messages should also be added to the talk page in a new section. This would ensure that reviewers are able to see prior notes and also be able to follow-up on comments made by past reviewers.

Risk

There is a possible risk of the conversation being fragmented because of the same message being in two places instead of one. The reviewers agree on this not being a big problem.

Required changes:

  • Change Add a message for the creator (optional): to instead be Add a message for the creator. This message will also be posted to the article talk page.
  • Replace the placeholder in the input box with: Write a helpful note for $username and future reviewers.
  • When a user adds a comment in the input box and submits it, the message is posted to both the creator's talk page and the article's talk page.
  • For the article talk page message:
    • Section heading: Feedback from New Page review process
    • Message: I left the following feedback for the creator/future reviewers while reviewing this article: $message. -- Signed by $reviewer
    • Question: Can this be a community-controlled template?
    • Revision tag: pagetriage (see T226789)

Notes

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 19 2018, 8:30 AM

@Insertcleverphrasehere: Adding PageCuration project tag so this task can be found when looking at PageCuration tasks at https://phabricator.wikimedia.org/tag/mediawiki-extensions-pagecuration/ . No need to add team tags like Growth-Team; that is up to each team (or automatic filters).

JTannerWMF moved this task from Inbox to External on the Growth-Team board.Mar 19 2019, 6:08 PM
JTannerWMF added a subscriber: JTannerWMF.

It appears the CommTech team is working on this.

Niharika renamed this task from Tagging Feedback in Page Curation Tools should also be sent to talk page to Feedback for creator should also be posted to article talk page.Jun 4 2019, 5:31 PM
Niharika triaged this task as Normal priority.
Niharika updated the task description. (Show Details)
Niharika added a project: Community-Tech.

@Barkeep49 @Insertcleverphrasehere It would be helpful if you could glance at the task description and verify if it fulfills what was requested. Thank you!

@Niharika that seems to capture what was requested from my perspective but ICPH did a lot more on that front and so I would defer to him should he say differently.

Niharika set the point value for this task to 5.Jun 6 2019, 5:30 PM
HMonroy claimed this task.Jun 28 2019, 12:07 AM
Samwilson updated the task description. (Show Details)Jun 28 2019, 12:35 AM

Just wanted to drop by to make a reminder that this was intended to be tied into the 'info tab so that these messages also get flagged for reviewers to follow up on in the info tab. (detailed in task T207452) It isn't specifically mentioned in the summary above.

ifried updated the task description. (Show Details)Jul 17 2019, 10:24 PM
ifried added a subscriber: ifried.

@Insertcleverphrasehere Thanks! I added that note to the description.

HMonroy updated the task description. (Show Details)Jul 22 2019, 10:13 PM
HMonroy updated the task description. (Show Details)

Change 525877 had a related patch set uploaded (by HMonroy; owner: HMonroy):
[mediawiki/extensions/PageTriage@master] Post to article talk page when feedback is submitted for creator

https://gerrit.wikimedia.org/r/525877

ifried updated the task description. (Show Details)Aug 9 2019, 11:05 PM

Change 525877 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Post to article talk page when feedback is submitted for creator

https://gerrit.wikimedia.org/r/525877

dom_walden added a subscriber: dom_walden.

Testing on https://en.wikipedia.beta.wmflabs.org/wiki/

  • Change Add a message for the creator (optional): to instead be Add a message for the creator. This message will also be posted to the article talk page.
  • Replace the placeholder in the input box with: Write a helpful note for $username and future reviewers.

Both true.

  • When a user adds a comment in the input box and submits it, the message is posted to both the creator's talk page and the article's talk page.

Yep. Because this uses the standard api.php?action=edit, I did not test it very thoroughly.

  • For the article talk page message:
    • Section heading: Feedback from New Page review process
    • Message: I left the following feedback for the creator/future reviewers while reviewing this article: $message. -- Signed by $reviewer

I notice that we automatically add a "." at the end of the user's message on the Talk page. So, if the user has already ended their message with a full stop, the final message has two of them. (See, for example, https://en.wikipedia.beta.wmflabs.org/wiki/Talk:Drwpb_Page_2)
This is not the case for the message sent to the author's User_talk page.
Let me know if you want a bug raising.

  • Revision tag: pagetriage (see T226789)

"Tag: PageTriage" appears, for example, next to the revision in the Talk page's history.

@Insertcleverphrasehere @Barkeep49 This work should now be on production. When you get a chance, can you verify that you see these changes in Page Curation? Thanks!

I believe this went live with the note to reviewers and is working.

ifried closed this task as Resolved.Sep 4 2019, 4:59 PM

Thanks, @Barkeep49. I marked this work as done.

@ifried I don't know if it was meant to be part of this task, but shouldn't feedback added when applying tags also be posted to the talk page?

ifried added a comment.Sep 6 2019, 2:53 AM

@DannyS712 That wasn't in the scope of this ticket/task, but it can certainly be written as a feature request ticket. Thanks!

DannyS712 updated the task description. (Show Details)Sep 6 2019, 3:01 AM

@DannyS712 That wasn't in the scope of this ticket/task, but it can certainly be written as a feature request ticket. Thanks!

In that case, I clarified the feature request to cover just the reviewing, as opposed to tagging

DannyS712 updated the task description. (Show Details)Sep 6 2019, 3:02 AM