Page MenuHomePhabricator

RTL Wikis problem with tags in RC, history, contribs etc. in Chrome 76 and Chrome 77
Closed, InvalidPublic

Description

Today I realized that fawiki (and all RTL wikis) has a problem in recent changes, history, contribs, watchlist and perhaps all other pages that contain a list of edits: When an edit has one or more tags, the "(" character (which is supposed to close the parentheses containing tags) jumps to first of its edit row, ruins the entire row. If you have rollback/sysop right, it gets worse since revert button also jumps to the first of the row, after "(".
I thought it can be a problem caused by tools and scripts I use, so I asked fawiki users about this problem, all said they are also experiencing this problem. I checked common.js, common.css, vector.css and even changed my skin to timeless. Still, it is broken. I checked arwiki and ckbwiki (RtL wikis), they have the very same problem. I also checked enwiki and frwiki (LLR wikis), no problem there. I think it's a problem related to RTL wikis only. It must be the result of a recent global change, since it wasn't broken yesterday.

To reproduce this issue, please go to fawiki RC, you will see that "(" before each edit's page name (note that only tagged edits have this problem, not untagged ones).

Browser info: Google Chrome, v76.0.3809.132 / Win 10
It looks like this problem only occurs in Google Chrome, not other browsers.
No difference between normal and safe mode.

Further report:
Google Chrome 76.0.3809.100 (Official Build) (64-bit)
Revision ed9d447d30203dc5069e540f05079e493fc1c132-refs/branch-heads/3809@{#990}
OS Linux

Event Timeline

Ahmad252 created this task.Sep 5 2019, 11:10 AM
Restricted Application added a project: I18n. · View Herald TranscriptSep 5 2019, 11:10 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ahmad252 updated the task description. (Show Details)Sep 5 2019, 11:11 AM
Ahmad252 renamed this task from RtL Wikis problem in tags in RC, history, contribs etc. to RtL Wikis problem with tags in RC, history, contribs etc..Sep 5 2019, 11:13 AM
Amire80 added a subscriber: Amire80.

Can you please post a screenshot of this? I more or less imagine what can cause problems of this kind, but I don't actually see an example on Recent Changes in fawiki.

Also, which browser do you use?

I personally use Chrome, don't know about the others. Here's the screenshot:

I cannot reproduce it in Chrome.

Can you please try logging out and looking at the page again? This problem may be caused by one of the user scripts or gadgets that you're using, so we need to rule that out first.

No luck, I still have this problem. This is the exact address of RC I'm looking at. I think it isn't caused by a gadget or something since I checked fa, ckb and arwiki, all have this problem.

Have you tried it while logged out, or only in other wikis?

What is the red "واگردان" button in the beginning of each line in the screenshot? I don't see it if I go to Recent Changes.

Ahmad252 added a comment.EditedSep 5 2019, 11:56 AM

That's "rollback" button (which is only visible to rollbackers and sysops). However, I tried while logged out, the problem was still there.

OK, can you please make a screenshot while logged-out? I want to rule out every possible difference that your account may have.

4nn1l2 added a subscriber: 4nn1l2.EditedSep 5 2019, 12:36 PM

I saw no problems at fawiki either on Firefox or Chrome, logged in or logged out. Maybe it's related to a particular OS.

I'm not sure, let me ask others in fawiki.

Hi @Ahmad252, thanks for taking the time to report this!
Unfortunately this report lacks some information: Please add a more complete description to this report by always providing a clear list of steps to reproduce (including a URL link that anyone can click), browser information, browser version information, operating system information, and also check if the problem also happens in safemode (see https://www.mediawiki.org/wiki/Help:Locating_broken_scripts ). Thanks!

You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster.

Aklapper changed the task status from Open to Stalled.Sep 5 2019, 12:57 PM
Ahmad252 updated the task description. (Show Details)Sep 5 2019, 1:06 PM

@Aklapper Hi, I just edited the task with more detailed info. Thanks for pointing it out.

This is a rather high priority issue but I can't reproduce it. Maybe because I use the enhanced RC:

It's not just RC, I experience this problem in history and contribs as well. I checked contributions of a user in arwiki, and I only got this, just like fawiki:


I would say It's a problem of my system or something, but I see User:Mosi and User:Wikimostafa in fawiki have the very same problem, and I haven't updated anything (like my OS and/or browser) since yesterday.

Can you put the CSS rules for the tags? I have a feeling they are being eaten by CSS

Update: I experienced no problem in a firefox-based browser and Microsoft Edge works fine as well. Despite this, I checked Google Chrome in different situations, no luck.

@Ladsgroup There is this .mw-tag-markers::after, I think it is the one responsible for that (. To be honest, it's somehow confusing since it contains exact the same thing in Firefox and Chrome:

.mw-tag-markers::after, .mw-uctop::after {
    content: ')';
}

Yup, I was able to reproduce it in chrome. If the line breaks, it shows the closing bracket but before the content which looks interesting:


I feel this is a bug in chrome. @Volker_E is a better person to take a look at this.

Volker_E changed the task status from Stalled to Open.EditedSep 5 2019, 5:55 PM
Volker_E added a subscriber: Jdlrobson.

This is connected to recent patches on T219348 relying on CSS pseudo-content that's not internationalized. Thanks for reporting @Ahmad252!

There's two options, as Edge and Firefox get it right: Either search/report upstream if this is expected behaviour to have generated content like '(' brackets be mirrored in RTL languages and Chrome gets it wrong, not adhering to the standard.
Or to address it with specific CSS rule for RTL languages.

Volker_E renamed this task from RtL Wikis problem with tags in RC, history, contribs etc. to RTL Wikis problem with tags in RC, history, contribs etc..Sep 5 2019, 5:56 PM
Volker_E triaged this task as High priority.
Volker_E updated the task description. (Show Details)
Volker_E updated the task description. (Show Details)Sep 5 2019, 5:59 PM
Ahmad252 updated the task description. (Show Details)Sep 5 2019, 7:50 PM
Volker_E updated the task description. (Show Details)Sep 5 2019, 9:32 PM
Huji added a subscriber: Huji.Sep 6 2019, 7:28 PM

... Edge and Firefox get it right ...

For the record, so does Safari. Which is interesting, because Chrome and Safari are both based on WebKit, yet somehow Safari gets this right but Chrome does not.

YonaB added a subscriber: YonaB.Sep 8 2019, 7:56 AM

There is a complaint about it also in the Hebrew Wikipedia, which is my home wiki, but I still cannot reproduce it. I am testing in Chrome 76 on a Mac. I also tried on Windows, with the RC filters enabled and disabled, with admin account and non-admin account, and nothing helped—I just cannot reproduce it anywhere.

@Volker_E, which CSS rule are you talking about? Do you know how to reproduce it?

There is a complaint about it also in the Hebrew Wikipedia, which is my home wiki, but I still cannot reproduce it. I am testing in Chrome 76 on a Mac. I also tried on Windows, with the RC filters enabled and disabled, with admin account and non-admin account, and nothing helped—I just cannot reproduce it anywhere.

Hi Amire80, visit this history page: https://ar.wikipedia.org/w/index.php?title=Stratifin&action=history

Look your left, after each ..PHP7, there should be a closing bracket "(": Spot marked in red below. But with this bug, each bracket is lonely left at extreme right. Spot marked with green. I viewed this history on Mac and Chrome 76.

alanajjar added a comment.EditedSep 9 2019, 10:36 AM

From T232317.

Same issue on Arabic Wikipedia as below, e.g:

Special:RecentChanges

  • Display language= Arabic

  • Display language= English

So it seems this got introduced in Chrome 76, here's the still working version 75 as comparison:

Volker_E lowered the priority of this task from High to Normal.Sep 17 2019, 10:55 PM

Problem still exist, I have opened a discussion in Chrome bugs. Please add any further information you have.

Filed as https://crbug.com/1010641 with a minimal reduction

Generally speaking, Chrome 76 seems to be rather buggy for us

That is the first stable version that supposed to enable LayoutNG (revamped layout engine inside of Chrome which itself resolved many different bidi/CTL issues) publicly but it became complicated as it got disabled for Google Chrome users last minute for some reason using some magic that doesn't apply to Chromium users and may many others.

Fix will be in Chrome 78

Aklapper renamed this task from RTL Wikis problem with tags in RC, history, contribs etc. to RTL Wikis problem with tags in RC, history, contribs etc. in Chrome 76 and Chrome 77.Oct 4 2019, 8:19 AM
Aklapper added a project: Upstream.

@Ebraminio: Thanks for the explanation and for bringing this upstream! Really appreciated.

If there is nothing to fix in Wikimedia controlled code, we should probably close this task as invalid?

Ebraminio closed this task as Invalid.Oct 4 2019, 4:09 PM

Yep. Thanks