Notification messages for mentions assume article namespace, do not reflect other namespaces
Closed, ResolvedPublic

Description

Messages such as 'Yoshimi mentioned you on talk page in "Wyoming"' do not work completely well with discussion pages in other namespaces.

For example, in the English Wikipedia [[Wikipedia:Village pump (technical)]] is itself a discussion page, and it also has a talk page - [[Wikipedia talk:Village pump (technical)]]. So when the message says 'Yoshimi mentioned you on talk page in "Wikipedia:Village pump (technical)"' does it refer to the main page or to the talk page?

My proposed solution is to create new message that won't mention the word "talk" in the message if the page is not actually in one of the talk namespaces. Something like this: 'Yoshimi mentioned you in a discussion in "Wikipedia:Village pump (technical)"'.

This was noticed by Dolev ([[User:דולב]]), an experienced user on the Hebrew Wikipedia.


In the team meeting Feb. 17 2016 we made some decisions about how to handle namespaces in notifications:

  • Use only the page name in secondary links. No namespace.
  • But do reflect the full namespace in a tool tip for the secondary link.
  • In secondary links, differentiate namespaces using the following three icons: 1) "user speech bubble" for usertalk, 2) "speech bubbles" for talk, 3) the "article" icon for everything else.
  • In the message header, continue to use the namespace with the page name (while applying the truncation rule defined in T121822 -- currently 50 characters)

See Also:
T57491: "mention" notifications on Meta don't work for ns0
T59273: Improve echo message for mention on talk page of person making the mention
T66504: Notification involving suppressed revision produces erroneous link
T57671: Echo: Namespace is not indicated for posts to talk pages other than article talk

There are a very large number of changes, so older changes are hidden. Show Older Changes
jrbs added a subscriber: jrbs.

@Legoktm Didn't I see code for this on your screen on Monday? Is there a patch in Gerrit?

Catrope reassigned this task from Legoktm to jmatazzoni.EditedDec 17 2015, 11:41 PM
Catrope added subscribers: jmatazzoni, Pginer-WMF.

We discussed this this week, and decided to go with the following suggestion by @Pginer-WMF:

Assigning to @jmatazzoni to write actual text for these.

Catrope changed the title from "Messages about talk pages are not completely adapted to non-talk namespaces" to "Notification messages for mentions assume article namespace, do not reflect other namespaces".Dec 17 2015, 11:42 PM
jmatazzoni added a comment.EditedDec 18 2015, 12:56 AM

Her's my go at defining messaging for the scenarios described above:

EXTENDED MESSAGING FOR MENTIONS

ON ARTICLE TALK PAGES (no change)

  • Big Bird mentioned you on the Amphibians talk page in "Can frogs talk?".
  • [if the mention is not in a topic] Big Bird mentioned you on the Amphibians talk page.

ON USER TALK PAGES

  • Big Bird mentioned you on the user talk page of Miss Piggy in "Things that are green".
  • [if the mention is not in a topic] Big Bird mentioned you on the user talk page of Miss Piggy.
  • [if it is the mentioner's own talk page] Big Bird mentioned you on his talk page in "Things that are green".
  • [if it is the mentioner's own talk page but not in a topic] Big Bird mentioned you on his talk page.

ON ALL OTHER PAGES

  • Big Bird mentioned you on Wikipedia:Administrator's Noticeboard in “Administrators we love”.
  • [if the mention is not in a topic] Big Bird mentioned you on Wikipedia:Administrator's Noticeboard.
jmatazzoni removed jmatazzoni as the assignee of this task.Dec 18 2015, 12:59 AM
Mattflaschen added a comment.EditedDec 29 2015, 7:45 PM

For the secondary links, we decided:

Refer in links to just “Paris” using icons for main (page icon) and talk (speech bubble icon) namespaces and use namespace for other namespaces. e.g., Portal talk:Paris. Also use icons regardless to distinguish subject (Paris or Portal:Paris) and talk page (Talk:Paris or Portal talk:Paris).

For the secondary links, we decided:

Refer in links to just “Paris” using icons for main (page icon) and talk (speech bubble icon) namespaces and use namespace for other namespaces. e.g., Portal talk:Paris. Also use icons regardless to distinguish subject (Paris or Portal:Paris) and talk page (Talk:Paris or Portal talk:Paris).

What should be the "page icon"? @Pginer-WMF

Change 265177 had a related patch set uploaded (by Sbisson):
[wip] Rephrase mention notifications

https://gerrit.wikimedia.org/r/265177

For the secondary links, we decided:

Refer in links to just “Paris” using icons for main (page icon) and talk (speech bubble icon) namespaces and use namespace for other namespaces. e.g., Portal talk:Paris. Also use icons regardless to distinguish subject (Paris or Portal:Paris) and talk page (Talk:Paris or Portal talk:Paris).

What should be the "page icon"? @Pginer-WMF

It's the "Article" icon from the ooui collection:
uniE100 - article.svg

For the secondary links, we decided:

Refer in links to just “Paris” using icons for main (page icon) and talk (speech bubble icon) namespaces and use namespace for other namespaces. e.g., Portal talk:Paris. Also use icons regardless to distinguish subject (Paris or Portal:Paris) and talk page (Talk:Paris or Portal talk:Paris).

What should be the "page icon"? @Pginer-WMF

It's the "Article" icon from the ooui collection:
uniE100 - article.svg

AIUI this is a secondary link icon, right? Secondary link icons use OOUI, so you should be able to simply use 'icon' => 'article'

AIUI this is a secondary link icon, right? Secondary link icons use OOUI, so you should be able to simply use 'icon' => 'article'

I had to add the files and add it to mediawiki/badgeicons.json for it to work, is it normal?

AIUI this is a secondary link icon, right? Secondary link icons use OOUI, so you should be able to simply use 'icon' => 'article'

I had to add the files and add it to mediawiki/badgeicons.json for it to work, is it normal?

No, it's in OOUI so you should not have had to do that. Maybe it's in a different icon pack and you need to load it?

Try depending on the oojs-ui.styles.icons-article module.

Try depending on the oojs-ui.styles.icons-article module.

Thanks. I found the 'article' icon under oojs-ui.styles.icons-content.

Change 265177 merged by jenkins-bot:
Rephrase mention notifications

https://gerrit.wikimedia.org/r/265177

matej_suchanek added a comment.EditedJan 29 2016, 3:32 PM

@SBisson Does parameter $4 in notification-header-mention-user-talkpage support gender? (I expect it does but there is no note about this in /qqq.)

Change 267266 had a related patch set uploaded (by Sbisson):
Support GENDER in mention-on-user-talk messages

https://gerrit.wikimedia.org/r/267266

@SBisson Does parameter $4 in notification-header-mention-user-talkpage support gender? (I expect it does but there is no note about this in /qqq.)

Well, it works for most cases (not all) but it's really by accident. I was considering this a page name, which is also technically true, but in the context of the message it's really the username. I've added proper formatting, gender support, and documentation.

Thanks for catching this!

Nice to see some i18n love in this area!

Change 267266 merged by jenkins-bot:
Support GENDER in mention-on-user-talk messages

https://gerrit.wikimedia.org/r/267266

Checked in betalabs according to the following cases

Split mentions into 4 cases:

    • Mentioned on article talk page
    • Mentioned on agent's talk page
    • Mentioned on another user's talk page
  • Mentioned on any other page

Adjust secondary link
icon: article or talk
text: without namespace for article and article talk

  • Mentioned on article talk page

'Thank' Notifications reflect namespaces - in the screenshot below: Talk, User talk, and Wikipedia.

Is it ok?

This screenshot is for flow-mention but this task is for mention on wikitext pages.

'Thank' Notifications reflect namespaces - in the screenshot below: Talk, User talk, and Wikipedia.

Is it ok?

Not related to this ticket but that doesn't seem ok. Are these flow-thank? And is the last one a topic title with a template?

On this screenshot, is "their" used because that's what you get if you select the "gender neutral" pref under "How do you prefer to be described?"

On this screenshot, is "their" used because that's what you get if you select the "gender neutral" pref under "How do you prefer to be described?"

Yes, it's singular "their".

Etonkovidova added a comment.EditedFeb 1 2016, 5:13 PM

@jmatazzoni - yes, 'their' is used for gender neutral reference.

@SBisson
Template display is ok, in this case - it was reported and Matt is working on it. Sorry, I should've used a different screenshot.

@SBisson

this task is for mention on wikitext pages

  • I am not able to trigger Mention notifications from non-Flow pages with [[User: username]].
  • in fact, no Notifications are coming from edits on non-Flow pages
  • in fact, no Notifications are coming from edits on non-Flow pages

This might be due to job queue misfunctioning on Beta. https://gerrit.wikimedia.org/r/#/c/266949/ needs review and should work around this issue at least on enwiki beta.

This comment was removed by Etonkovidova.

Checked in betalabs

  • talk pages from Main space are referenced in the message as [Name of the article] talk page and displayed without Talk: in their title
  • other namespaces' Talk pages are referenced directly in the message, e.g. Wikimedia talk:EchoTest and in the links.
  • non-talk pages from non-main space are referenced with their namespaces.

jmatazzoni added a comment.EditedFeb 17 2016, 8:13 PM

In the team meeting Feb. 17 we made some decisions about how to handle namespaces in notifications:

  • Use only the page name in secondary links. No namespace.
  • But do reflect the full namespace in a tool tip for the secondary link.
  • In secondary links, differentiate namespaces using the following three icons: 1) "user speech bubble" for usertalk, 2) "speech bubbles" for talk, 3) the "article" icon for everything else.
  • In the message header, continue to use the namespace with the page name (while applying the truncation rule defined in T121822 -- currently 50 characters)

[copying this decision to the ticket description]

jmatazzoni edited the task description. (Show Details)Feb 17 2016, 8:14 PM
jmatazzoni moved this task from Product Review to Needs Review on the Collab-Archive-2015-2016 board.
jmatazzoni moved this task from Needs Review to In Development on the Collab-Archive-2015-2016 board.

In the decision above, I just realized I should have said:

In the message body, continue to use the full namespace with the page name, within the limits of the truncation rules.

adding to the decision.

jmatazzoni edited the task description. (Show Details)Feb 18 2016, 10:30 PM
jmatazzoni added a subscriber: SBisson.

In the decision above, I just realized I should have said:

In the message body, continue to use the full namespace with the page name, within the limits of the truncation rules.

adding to the decision.

Message bodies are almost always excerpts of user-created content. We don't know if they contain titles or usernames or anything else. The best we can do is show as much as possible of it on one line.

If you know of some where we build the content based on a message, let me know and I'll verify that the rule is applied correctly.

Stephane wrote:

Message bodies are almost always excerpts of user-created content. We don't know if they contain titles or usernames or anything else.

Thanks for seeking clarification Stephane. That's not what I meant to say. I was actually thinking of the header, not the body, and was only saying that we should continue to apply whatever truncation rules apply in the header. I.e., I think that's 50 characters.

So, I'll try again:

In the message header, continue to use the namespace with the page name (while applying the truncation rule defined in T121822 -- currently 50 characters).

Is that more clear?

jmatazzoni edited the task description. (Show Details)Feb 18 2016, 11:47 PM
Etonkovidova added a comment.EditedFeb 22 2016, 9:12 PM

Checked in betalabs.

> - Use only the page name in secondary links. No namespace.
- But do reflect the full namespace in a tool tip for the secondary link.

In secondary links, differentiate namespaces using the following three icons:

  1. "user speech bubble" for usertalk

2) "speech bubbles" for talk,

  1. the "article" icon for everything else. -- look at the screenshots below

> - In the message header, continue to use the namespace with the page name (while applying the truncation rule defined in T121822 -- currently 50 characters)



However, please confirm that the following looks as designed:

  1. per @jmatazzoni - OK in 'Reply' the namespace is not mentioned anywhere

'EchoTest1' is in MediaWiki talk:EchoTest1
'Mavetuna1' in in Wikipedia:Mavetuna1


  1. Vertical positioning of secondary icons is off - a known issue

@SBisson
Please correct #2 "speech bubbles" for talk pages (Article talk).

Change 272700 had a related patch set uploaded (by Sbisson):
Notification: use speechBubbles icon for all talk pages

https://gerrit.wikimedia.org/r/272700

@SBisson
Please correct #2 "speech bubbles" for talk pages (Article talk).

Should be fixed by https://gerrit.wikimedia.org/r/272700

Change 272700 merged by jenkins-bot:
Notification: use speechBubbles icon for all talk pages

https://gerrit.wikimedia.org/r/272700

"Speech bubbles" icon for all Talk pages:
@jmatazzoni Mention messages do not have references to a namespace as. e.g. post/new topic message do. Is it OK?

Mention messages do not have references to a namespace as. e.g. post/new topic message do. Is it OK?

Yes, the Mention messages appear to be correct. If by "reference to the namespace" you mean a reference in the message header, that is not in the spec, so these are good. The only indications that this is in talk would be the speechbubbles icons, which I see here, and in the tooltips. @Etonkovidova, are the tooltips present?

Yes, the namespace names are present in tooltips.

jmatazzoni closed this task as "Resolved".Feb 25 2016, 6:19 PM

Mention messages do not have references to a namespace as. e.g. post/new topic message do. Is it OK?

Yes, the Mention messages appear to be correct. If by "reference to the namespace" you mean a reference in the message header, that is not in the spec, so these are good. The only indications that this is in talk would be the speechbubbles icons, which I see here, and in the tooltips. @Etonkovidova, are the tooltips present?

I thought the spec was to do that in the header, just not in the secondary links:

In the message header, continue to use the namespace with the page name (while applying the truncation rule defined in T121822 -- currently 50 characters).

Is that more clear?

Never mind, that's not applicable, since the board name doesn't appear in the header with or without namespace.

Matt wrote:

...since the board name doesn't appear in the header with or without namespace.

Well, it will when it's the description that was edited. But I'm pretty sure that's what's happening. Right @Etonkovidova ?

Add Comment