Show HTML summaries on all wikis
Closed, ResolvedPublic2 Story Points

Description

Background

Prior to deploying page previews to all wikis, we would like to switch to the new summary endpoint so that all users will be able to see html previews

Pre-task checklist

  • Ensure all subtasks are closed before picking up this task.

Acceptance criteria

  • Switch all projects to new summary endpoint
  • Perform a full round of QA on feature
  • Announce switch (village pumps, wikitech-l)
  • Add the deployment to the Readers Web Release Timeline page.

QA

Related Objects

ovasileva created this task.Dec 7 2017, 1:08 PM
ovasileva triaged this task as Normal priority.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 7 2017, 1:08 PM
phuedx renamed this task from Switch all projects to new summary endpoint to Show HTML summaries on all wikis.Dec 8 2017, 5:28 PM
ovasileva updated the task description. (Show Details)Dec 12 2017, 3:31 PM
ovasileva moved this task from Backlog to Next Up on the Page-Previews board.Dec 12 2017, 3:48 PM
Jdlrobson updated the task description. (Show Details)Jan 9 2018, 5:19 PM
phuedx updated the task description. (Show Details)Jan 9 2018, 5:20 PM
ovasileva set the point value for this task to 2.Jan 9 2018, 5:29 PM
ovasileva raised the priority of this task from Normal to High.Feb 21 2018, 4:06 PM
Jdlrobson updated the task description. (Show Details)Feb 22 2018, 10:19 PM
pmiazga claimed this task.Feb 26 2018, 6:13 PM

Change 414751 had a related patch set uploaded (by Pmiazga; owner: Pmiazga):
[operations/mediawiki-config@master] Enable HTML Previews on all wikipedias

https://gerrit.wikimedia.org/r/414751

Dvorapa removed a subscriber: Dvorapa.Feb 26 2018, 9:58 PM

Requires SWAT deploy. I added this task to mid-day European SWAT on Feb 28th

Change 414751 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable HTML Previews on all wikipedias

https://gerrit.wikimedia.org/r/414751

Mentioned in SAL (#wikimedia-operations) [2018-02-28T14:32:45Z] <zfilipin@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:414751|Enable HTML Previews on all wikipedias (T182319)]] (duration: 00m 57s)

Page https://ar.wikipedia.org/wiki/%D8%B1%D9%8A%D8%A7%D8%B6%D9%8A%D8%A7%D8%AA:

المبرهنة الأساسية في الجبر


الاستمثال

عدد بي

now live. here's some initial bugs/concerns:

multiple previews with cutoff text on arwiki (I will be opening a bug for this)

  1. Go to https://ar.wikipedia.org/wiki/%D9%87%D9%86%D8%AF%D8%B3%D8%A9_%D8%B1%D9%8A%D8%A7%D8%B6%D9%8A%D8%A9
  2. Hover over والمساحات

Observed - text is cutoff

Note: seeing this in many other places on arwiki:



Formulas not always rendered

  1. Go to https://en.wikipedia.org/wiki/Invertible_matrix
  2. Hover over Linear Algebra


Could replicate across a few wikis:

bearND added a comment.EditedFeb 28 2018, 4:44 PM

@ovasileva that thumbnail is still appearing on arwiki because its summary is still on 1.3.0. Once the page gets modified or purged it should be rerendered with the latest. I have not pushed yet to get all pages on all wikis to the latest version because the client side thumbnail fix should land with the train today IIUC.

About the formulas not always rendered:
Would you post the links to the articles you used on the other wikis than en so I can check them out? It could be that not all summaries have been forced to the latest version yet.

The enwiki Linear algebra preview looks good in my browser (tested Chrome and FF):

Maybe a (browser) cache issue? https://en.wikipedia.org/api/rest_v1/page/summary/Linear_algebra returns an extract_html with the <img> tag for me:

<p><b>Linear algebra</b> is the branch of mathematics concerning linear equations such as</p><dl><dd><span class="mwe-math-element"><img src="https://wikimedia.org/api/rest_v1/media/math/render/svg/f4f0f2986d54c01f3bccf464d266dfac923c80f3" class="mwe-math-fallback-image-inline" aria-hidden="true" style="vertical-align:-0.671ex;width:22.811ex;height:2.509ex;" /></span></dd></dl>
ABorbaWMF added a subscriber: ABorbaWMF.EditedFeb 28 2018, 5:54 PM

So far I have been able to reproduce the text cutoff on arwiki across a few browsers:

I have not been able to reproduce the enwiki issue with linear algebra. But I have seen problems on hewiki for the same article

But I did see some problems on eswiki with math https://es.wikipedia.org/wiki/Matriz_invertible

And similar problems on ruwiki https://ru.wikipedia.org/wiki/%D0%9C%D0%B5%D1%82%D0%BE%D0%B4_%D0%93%D0%B0%D1%83%D1%81%D1%81%D0%B0

Jdlrobson added a comment.EditedFeb 28 2018, 6:44 PM

Maybe a (browser) cache issue? https://en.wikipedia.org/api/rest_v1/page/summary/Linear_algebra returns an extract_html with the <img> tag for me:

These are all caching issues. I purged the Linear Algebra article shortly after seeing this bug report.

Page https://ar.wikipedia.org/wiki/%D8%B1%D9%8A%D8%A7%D8%B6%D9%8A%D8%A7%D8%AA:

Also caching...

But I did see some problems on eswiki with math https://es.wikipedia.org/wiki/Matriz_invertible

This was a caching problem. I purged the target page and now this is showing correctly.

And similar problems on ruwiki https://ru.wikipedia.org/wiki/%D0%9C%D0%B5%D1%82%D0%BE%D0%B4_%D0%93%D0%B0%D1%83%D1%81%D1%81%D0%B0

Also caching fixed by a purge.

Please ignore any issues like this in QA from now on. I think we can safely attribute them to old outdated copies of the HTML.

bearND added a comment.EditedFeb 28 2018, 11:21 PM

When you encounter issues like this note what Spec version the summary for the target page page is at. You can check with something like:

curl -sI "https://ar.wikipedia.org/api/rest_v1/page/summary/%D8%B1%D9%8A%D8%A7%D8%B6%D9%8A%D8%A7%D8%AA" | grep Spec
content-type: application/json; charset=utf-8; profile="https://www.mediawiki.org/wiki/Specs/Summary/1.3.0"

If this still shows 1.2.0 then that explains why we would see the math markup.

FWIW, the 1.3.1 would fix the thumbnail issue server side, 1.3.2 would fix most chemical formulas. There is still one outstanding issue with more complex chemical formulas.

Nirzar added a subscriber: Nirzar.Feb 28 2018, 11:30 PM

ar wikipedia changes line-height to 1.6em for their script.

We have a max-height property on popups set to 140px

because of 1.6em line height, 140px is not the correct max height, it should be 130px for ar wikipedia.

for any wikipedia that basically touches line height of their content should adjust the max-height of popups

.mwe-popups.mwe-popups-is-not-tall .mwe-popups-extract {max-height:130px;}
if you add above rule in local css, it fixes the issue

I don't know how we going to deal with custom line-heights per wiki in a systematic way but we should document this

Change 414861 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Introduce View.prototype.parseHTML Always use local jQuery where possible

https://gerrit.wikimedia.org/r/414861

Sorry bout the above spam ^

ar wikipedia changes line-height to 1.6em for their script.
for any wikipedia that basically touches line height of their content should adjust the max-height of popups

Fixed:https://ar.wikipedia.org/w/index.php?title=%D9%85%D9%8A%D8%AF%D9%8A%D8%A7%D9%88%D9%8A%D9%83%D9%8A%3ACommon.css&type=revision&diff=27560800&oldid=27457556

bearND added a comment.Mar 1 2018, 4:12 AM

for any wikipedia that basically touches line height of their content should adjust the max-height of popups

How are you going to deal with summaries of pages like this one:

The line height here is rather -- variable.

Nirzar added a comment.Mar 1 2018, 4:30 AM

The line height here is rather -- variable.

the line-height is actually the same, if you look at computed line-height and compare with any other text on that wikipedia. the fading will work properly as long as we match the max-height to the line-height if line-height is custom.

Thank you @Jdlrobson for adding that css! the issue looks fixed to me as well.

bearND added a comment.EditedMar 1 2018, 5:49 AM

Never mind. Looks ok from my sandbox on arwiki:


The earlier screenshot was from the comparison report, which doesn't have any prod CSS.

Sorry bout the above spam ^

ar wikipedia changes line-height to 1.6em for their script.
for any wikipedia that basically touches line height of their content should adjust the max-height of popups

Fixed:https://ar.wikipedia.org/w/index.php?title=%D9%85%D9%8A%D8%AF%D9%8A%D8%A7%D9%88%D9%8A%D9%83%D9%8A%3ACommon.css&type=revision&diff=27560800&oldid=27457556

It's fixed, thanks @Jdlrobson! I pulled the separate bug T188521: Page previews text and formulas cut off on arwiki into the sprint for @ABorbaWMF to do some cross-browser testing if necessary.

ovasileva reassigned this task from pmiazga to ABorbaWMF.Mar 1 2018, 6:07 PM
ovasileva added a subscriber: pmiazga.

I think this can move to sign off. It looks like some of the issues identified above are either fixed or tracked elsewhere. There is a note in the original description to check the Acetic Acid pages and view the previews. I'm not sure if this is the desired result. Here is the preview and page for Acetic Anhydride:


ovasileva updated the task description. (Show Details)Mar 5 2018, 5:57 PM
ovasileva claimed this task.Mar 5 2018, 6:03 PM
ovasileva updated the task description. (Show Details)Mar 7 2018, 12:34 PM
ovasileva updated the task description. (Show Details)Mar 7 2018, 12:43 PM
ovasileva closed this task as Resolved.

All acceptance criteria are completed. Some smaller issues and edge cases are tracked under T187936: List of issues of 1.3.0 summary endpoint results and its subtasks. For now, html previews are live and looking pretty good.