Page MenuHomePhabricator

Show HTML summaries on cswiki
Closed, ResolvedPublic2 Story Points

Description

Background

In T173639: Hovercard text extract is broken for `* ` sequence in parenthesis, cswiki community members proposed testing the HTML summaries produced by the new Summary API. We would like to release it to cswiki first and do a round of QA prior to switching all projects to showing HTML summaries.

Acceptance criteria

  • Switch cswiki to showing HTML summaries
  • Prepare test articles for QA
  • Do a round of QA (full test plan) on cswiki
  • Ping @bearND and @Mholloway when this has happened.

Sign off steps

  • If any bugs are discovered during QA we may want to revert the change (Olga's decision). Bugs should be captured. We shouldn't rush to fix anything while the code is in production.

Done in https://www.mediawiki.org/w/index.php?title=Reading%2FWeb%2FRelease_timeline&type=revision&diff=2721756&oldid=2720598.

Developer Notes

  1. This is as simple as adding $wgPopupsGateway = 'restbaseHTML'; to the config. Note that this gateway is different from the "RESTBase Plain" gateway, which is currently in use on all of the Wikipedias.

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Jdlrobson updated the task description. (Show Details)Feb 5 2018, 6:20 PM
Jdlrobson added subscribers: Mholloway, bearND.

Probably blocked till at least Wednesday

Deploy now delayed until Monday.

bearND added a comment.EditedFeb 20 2018, 5:07 PM

Here's the latest comparison run for the Czech html extracts from TextExtracts vs the MCS summary implementation: http://wpsummary.surge.sh/1.2.0-b0be98c/html/cs.html. See also T179875#3986429. Starting soon.

ovasileva raised the priority of this task from Normal to High.Feb 21 2018, 4:05 PM
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptFeb 21 2018, 4:05 PM

Summarizing: @EddieGP's config change patch can be merged pending verification (see QA notes above) of the summary v1.3 rollout.

The summaries for all pages on cswiki are now rendered using MCS.

Vachovec1 added a comment.EditedFeb 21 2018, 9:22 PM

The summaries for all pages on cswiki are now rendered using MCS.

I found no problems with the summary texts so far. But I stumbled across a lot of pages for which I see in the summary a blank space in the place of (expected) picture. E.g. Douglas MacArthur‎, Benito Mussolini, Chester Nimitz, Prezident Spojených států amerických, Labradoodle and others.

bearND added a comment.EditedFeb 21 2018, 10:19 PM

The thumbnail in this page preview looks definitely wrong:
On https://cs.wikipedia.org/wiki/Donald_Trump hover over "prezident Spojených států amerických"

The thumbnail URL in the summary for the target page (https://cs.wikipedia.org/api/rest_v1/page/summary/Prezident_Spojen%C3%BDch_st%C3%A1t%C5%AF_americk%C3%BDch) looks right, though: https://upload.wikimedia.org/wikipedia/commons/0/0e/Donald_Trump_Pentagon_2017.jpg

I can also reproduce the same on a few enwiki pages, see new subtask T187955.

The thumbnail in this page preview looks definitely wrong:
On https://cs.wikipedia.org/wiki/Donald_Trump hover over "prezident Spojených států amerických"

I see a blank space instead of icon. But that could be a matter of different browser. I am using Firefox 52.6.0 ESR.

bearND added a comment.EditedFeb 21 2018, 10:52 PM

Correct. I can repro it on FF showing blank space. What I showed above was with Chrome.
Thank you for reporting this.

The cswiki page summaries have been re-rendered with the correct thumbnail size. We're still working through other wikis but for cs the blank thumbnail image issue should be resolved.

The cswiki page summaries have been re-rendered with the correct thumbnail size. We're still working through other wikis but for cs the blank thumbnail image issue should be resolved.

The situation has improved, but I am still getting blank spaces instead of thumbnail for some of the above mentioned pages:

Douglas MacArthur‎
Benito Mussolini
Prezident Spojených států amerických

Thumbnail is served correctly now for:

Labradoodle
Chester Nimitz

@bearND - we're planning on switching html previews on today during the European mid-day SWAT.

The cswiki page summaries have been re-rendered with the correct thumbnail size. We're still working through other wikis but for cs the blank thumbnail image issue should be resolved.

The situation has improved, but I am still getting blank spaces instead of thumbnail for some of the above mentioned pages:
Douglas MacArthur‎
Benito Mussolini
Prezident Spojených států amerických

But these seems like rare exceptions. The only other failed thumbnails I've found so far are for Friedrich Engels and Adolf Hitler. Perhaps some lokal cache issue? I'll try with another browser.

@Vachovec1 - just checked through some of these as well - I'm seeing thumbnails on Prezident Spojených států amerických, Friedrich Engels, Benito Mussolini

Change 396318 merged by jenkins-bot:
[operations/mediawiki-config@master] Show HTML summaries on cswiki

https://gerrit.wikimedia.org/r/396318

Vachovec1 added a comment.EditedFeb 22 2018, 2:09 PM

@Vachovec1 - just checked through some of these as well - I'm seeing thumbnails on Prezident Spojených států amerických, Friedrich Engels, Benito Mussolini

Definitely caching issue. It worked as expected in Chrome. But for the Firefox, the cache was very persistent. A simple purge may not be enough, I needed minor edits for Prezident Spojených států amerických and Benito Mussolini's summary thumbnails to work.

Mentioned in SAL (#wikimedia-operations) [2018-02-22T14:26:53Z] <zfilipin@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:396318|Show HTML summaries on cswiki (T182321)]] (duration: 01m 13s)

EddieGP removed a subscriber: EddieGP.Feb 22 2018, 2:28 PM

It seems there is some collision between the page previews code and "Zvýrazňovat přesměrování" (highlight redirects) gadget now. The redirects in the text extract are now highligted with rose background and overline. See for example previews for:

Anna
Ctiborův dub

If the gadget is disabled, the page previews behave as expected.

html previews now live. math looks great!

some small issues detected (listing them here and we can move to appropriate bugs later):

that's all I've noticed for now, but will keep testing.

(@Vachovec1) After switching HTML previews on, should we maybe inform Czech Wikipedia community about what happened and how to track bugs right?

Vachovec1 added a comment.EditedFeb 22 2018, 3:07 PM

(@Vachovec1) After switching HTML previews on, should we maybe inform Czech Wikipedia community about what happened and how to track bugs right?

It would be definitely helpful to post an appropriate message in our Village pump (technical): Wikipedie:Pod lípou (technika).

@Vachovec1, @Dvorapa - yup, we'll be posting a message later today. Next step here would be to QA internally but we'll be asking for some help in identifying edge cases in our message as well

@ovasileva - T182321#3992796 is an example of an edge case or a bug? The preview should probably not accept css definitions designed for the normal article text. The above mentioned gadget may not be the only one that will influence the preview.

ovasileva added a comment.EditedFeb 22 2018, 3:39 PM

@Vachovec1 - good catch. I don't think we had thought about how all the gadgets might work with the feature. I'll open a separate task for this. For posterity, here's an example of the preview:

issue now logged here: https://phabricator.wikimedia.org/T188005
@Vachovec1 - I'm a bit conflicted on whether this is a bug or not. I can see a case being made for an editor who enabled the gadget to expect redirects within previews as well.

@ovasileva - T182321#3992796 is an example of an edge case or a bug? The preview should probably not accept css definitions designed for the normal article text. The above mentioned gadget may not be the only one that will influence the preview.

that should be fixed in the gadget. The styling introduced by said gadget is very generic. Vachovec1 would you be so kind to flag that to the gadget author(s)?

phuedx updated the task description. (Show Details)Feb 22 2018, 5:06 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson moved this task from Doing to Needs QA on the Readers-Web-Kanbanana-Board-Old board.

over to you Anthony!

@ABorbaWMF - this would require going through all the page previews test cases (they should now have relevant articles on cswiki)

IPA not always removed (https://cs.wikipedia.org/wiki/Geometrie, hover over Jánosem Bolyaiem

This is by design. We don't scrub any content inside square brackets and we do not scrub parenthetical with one word. This would need to be marked up on wiki with the desired behaviour.

fading with mathematical formulas can be confusing (for example, go to https://cs.wikipedia.org/wiki/Geometrie, hover over algebraických variet
longer formulas not appearing correctly (https://cs.wikipedia.org/wiki/Geometrie, hover over polynomu)

We should open tickets for these and put them in the design backlog. We cannot change the preview content but we can change the presentation.

@ovasileva - T182321#3992796 is an example of an edge case or a bug? The preview should probably not accept css definitions designed for the normal article text. The above mentioned gadget may not be the only one that will influence the preview.

that should be fixed in the gadget. The styling introduced by said gadget is very generic. Vachovec1 would you be so kind to flag that to the gadget author(s)?

Well, the gadget definition is here:

MediaWiki:Gadget-HighlightRedirects.css

It's actualy very simple/basic code. So what would you propose?

The en-wiki has something very similar:

MediaWiki:Gadget-DisambiguationLinks.css (author: @kaldari)

I presume that the behaviour would be the same.

@ovasileva - T182321#3992796 is an example of an edge case or a bug? The preview should probably not accept css definitions designed for the normal article text. The above mentioned gadget may not be the only one that will influence the preview.

that should be fixed in the gadget. The styling introduced by said gadget is very generic. Vachovec1 would you be so kind to flag that to the gadget author(s)?

Well, the gadget definition is here:
MediaWiki:Gadget-HighlightRedirects.css
It's actualy very simple/basic code. So what would you propose?
The en-wiki has something very similar:
MediaWiki:Gadget-DisambiguationLinks.css (author: @kaldari)
I presume that the behaviour would be the same.

This conversation continues in T188005.

Looks good so far for me. Here are some examples with different previews (images, math, bold, parens, etc) on different os/browsers:










I have some reservations about the "fading" logic. Look at the following previews:


Notice the fading. This is not good. The fading should definitely not be applied to the first line of the text. Another thing: it would be great if the fading would not be applied to the last word of the sentence.

A remark: this happens mostly for the previews without the picture or with the "horizontal" picture. The previews with the "vertical" picture have usually much more room for the text before the "fading" is applied, so the short text summaries are usually presented as whole, without fading.

Dvorapa added a comment.EditedFeb 23 2018, 8:54 PM

I agree, the first sentence should not fade like this in the middle of the object:

"Jonathan Kuck is figure ska..."
"Brian Hansen is figure skat..."
(skater? skateboarder?)

Nirzar added a comment.Mar 1 2018, 1:27 AM

The fading should definitely not be applied to the first line of the text

We could potentially define "min-height" to content to 40px to solve for this particular case. if you apply 40px as a min-height, it won't apply the fading to the first line. I find this way a bit unreliable and of course I will speak with an engineer to figure out what is the downside.

ovasileva closed this task as Resolved.Mar 2 2018, 2:01 PM

No new bugs observed - resolving this for now. Logged the issue with longer formulas (T188734), although I'm not sure we can do much about it. All else looks good!

@ovasileva And T188581, but all the original issues were solved by HTML summaries, so this task is resolved

@ovasileva And T188581, but all the original issues were solved by HTML summaries, so this task is resolved

yes, that's the other one. Thanks @Dvorapa, @Vachovec1 and everyone else for all your help with QA

Dvorapa moved this task from Next Up to Done on the Page-Previews board.Mar 2 2018, 3:47 PM

@ovasileva And finally T183833 looks still unresolved