Watchlist is no longer showing seen indicators and point types have become small
Closed, ResolvedPublic

Description

Current reports on enwiki at:
https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Watchlist_problem?

I've noticed today that my watchlist is no longer differentiating between changes I've seen and changes I haven't. Each entry now just starts with the same period/full stop. Using >Firefox on Mac, and no relevant preference options that I can see. Tried Chrome on Mac too, and the differentiation between seen and unseen changes also does not show. >Anyone else seen this, and any idea what the problem is? Boing! said Zebedee (talk) 12:54, 19 October 2018 (UTC)

Same here, using Firefox 62.0.3 under Windows 7, 32-bit. The bullet points are now much smaller (are the size of periods) and undifferentiated. Dhtwiki (talk) 13:09, 19 October >2018 (UTC)

    I've got the same problem. Chrome Version 69.0.3497.81 (Official Build) (64-bit) on a Windows 7 terminal. Simonm223 (talk) 13:19, 19 October 2018 (UTC)

Disabling "improved watchlist" restores functionality for some users

Xaosflux created this task.Oct 19 2018, 2:20 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 19 2018, 2:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Xaosflux updated the task description. (Show Details)Oct 19 2018, 2:23 PM

Yup same here. This is a hug issue.

Managed to figure out an okay work around by turning on the gadget "Display pages on your watchlist that have changed since your last visit in bold". So this issue is less critical.

Thanks for filing this, @Xaosflux and @Doc_James. We're looking into this now. cc @Catrope @SBisson @kostajh @kaldari.

greg triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptOct 19 2018, 5:41 PM

FWIW, I tried a git bisect but ended up with the wrong commit (i.e. not the one which introduced the problem). This may be because I erroneously typed "good" instead of "bad" or vice versa, or there may be another explanation: in order to speed up the bisect, I always used the same composer and vendor, without running update.php. This could mean that the problem is in an external library (in this case, the obvious choice would be OOUI).

greg lowered the priority of this task from Unbreak Now! to High.Oct 19 2018, 5:54 PM
greg added a subscriber: greg.

Managed to figure out an okay work around by turning on the gadget "Display pages on your watchlist that have changed since your last visit in bold". So this issue is less critical.

Thanks @Daimona . I was about to start bisecting myself, but I'll try the OOUI release first with this knowledge.

My testing so far confirms that this is a regression between wmf.24 and wmf.26.

wmf.24:

wmf.26:

However, you can work around this by enabling this gadget:

Which highlights seen changes in bold, even though the radio buttons are still broken:

Thanks! I suspected that. Now looking at the difference in generated CSS and figuring out how to patch this with a [[MediaWiki:Common.css]] change.

Samtar added a subscriber: Samtar.Oct 19 2018, 6:59 PM

Change 468633 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Fix completely broken highlight circles

https://gerrit.wikimedia.org/r/468633

Change 468633 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Fix completely broken highlight circles

https://gerrit.wikimedia.org/r/468633

Change 468636 had a related patch set uploaded (by 20after4; owner: Catrope):
[mediawiki/core@wmf/1.32.0-wmf.26] RCFilters: Fix completely broken highlight circles

https://gerrit.wikimedia.org/r/468636

Change 468636 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.26] RCFilters: Fix completely broken highlight circles

https://gerrit.wikimedia.org/r/468636

Mentioned in SAL (#wikimedia-operations) [2018-10-19T20:33:37Z] <twentyafterfour> deployed RCFilters: Fix completely broken highlight circles refs T207472

Change 468672 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Fix highlight circles for unseen changes

https://gerrit.wikimedia.org/r/468672

The fix has been deployed to production, and I updated English Wikipedia Village Pump here. There is only one outstanding issue: when using highlighting, all highlighted rows have filled-in circles, whether they are seen or unseen. The fix for that has been written by @Catrope and will be deployed on Monday. Thank you for your patience as we worked on this, and please let us know if anything else is amiss.

Change 468672 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Fix highlight circles for unseen changes

https://gerrit.wikimedia.org/r/468672

Trizek-WMF renamed this task from Improved watchlist is no longer showing seen indicators and point types have become small to Watchlist is no longer showing seen indicators and point types have become small.

Change 468987 had a related patch set uploaded (by Bartosz Dziewoński; owner: Catrope):
[mediawiki/core@REL1_32] RCFilters: Fix completely broken highlight circles

https://gerrit.wikimedia.org/r/468987

Change 468988 had a related patch set uploaded (by Bartosz Dziewoński; owner: Catrope):
[mediawiki/core@REL1_32] RCFilters: Fix highlight circles for unseen changes

https://gerrit.wikimedia.org/r/468988

Change 468987 merged by jenkins-bot:
[mediawiki/core@REL1_32] RCFilters: Fix completely broken highlight circles

https://gerrit.wikimedia.org/r/468987

Change 468988 merged by jenkins-bot:
[mediawiki/core@REL1_32] RCFilters: Fix highlight circles for unseen changes

https://gerrit.wikimedia.org/r/468988

SBisson assigned this task to Catrope.
SBisson moved this task from Incoming to QA on the Growth-Team (Current Sprint) board.

Change 469040 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@wmf/1.32.0-wmf.26] RCFilters: Fix highlight circles for unseen changes

https://gerrit.wikimedia.org/r/469040

Change 469040 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.26] RCFilters: Fix highlight circles for unseen changes

https://gerrit.wikimedia.org/r/469040

Mentioned in SAL (#wikimedia-operations) [2018-10-22T18:38:22Z] <jforrester@deploy1001> Synchronized php-1.32.0-wmf.26/resources/src/mediawiki.rcfilters/styles/mw.rcfilters.ui.ChangesListWrapperWidget.highlightCircles.seenunseen.less: SWAT RCFIlters: Fix highlight circles for unseen changes T207472 (duration: 00m 46s)

Etonkovidova closed this task as Resolved.Wed, Oct 24, 5:20 PM