Page MenuHomePhabricator

Enable semantic relationship between code review changesets and maniphest tasks in phabricator
Closed, ResolvedPublic

Tokens
"Like" token, awarded by fgiunchedi."100" token, awarded by MarcoAurelio."Mountain of Wealth" token, awarded by Krenair."Barnstar" token, awarded by greg."Love" token, awarded by Tgr."Yellow Medal" token, awarded by matmarex."Love" token, awarded by Dzahn."Meh!" token, awarded by zeljkofilipin."Love" token, awarded by Quiddity.
Assigned To
Authored By
mmodell, Aug 6 2019

Description

It should be possible to define the type of relationship between a task and an associated review.
Additionally, that relationship, plus the status of the code review, should be displayed at the top of the Phabricator task (somewhere near the @mentions section)

Event Timeline

mmodell created this task.Aug 6 2019, 2:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 6 2019, 2:57 PM

This would probably involve some changes in phabricator as well as the gerrit plugin: its-phabricator

mmodell triaged this task as Normal priority.Aug 6 2019, 6:18 PM
Tgr added a subscriber: Tgr.Aug 7 2019, 11:14 AM

Presumably this is about Gerrit changesets?

Related:

mmodell claimed this task.Fri, Nov 8, 11:15 AM
hashar added subscribers: hashar, Krinkle.

I guess that would address a feature I have listed T209463 namely for each task add a link to a Gerrit search query for bug:Txxxx ( https://gerrit.wikimedia.org/r/#/q/bug:T12345 ) :] I have marked it as a duplicate of your task :]

mmodell closed this task as Resolved.Fri, Nov 8, 2:58 PM
hashar added a comment.Fri, Nov 8, 3:11 PM

10/10 totally aced.

Example https://gerrit.wikimedia.org/r/c/548964 which has Bug: T236746 and is thus attached to T236746. Under that task description:

As far as I concerned that fully address my idea from T209463 and even exceed it. Thank you Santa Mukunda!

I have no idea how you managed to implement and deploy that in less than four hours though.

Dzahn awarded a token.Fri, Nov 8, 7:14 PM
matmarex added a subscriber: matmarex.

This is the best usability improvement on Phabricator since the day the "Close As Duplicate" button was added.

Tgr awarded a token.Fri, Nov 8, 9:46 PM
greg awarded a token.Fri, Nov 8, 10:54 PM

antoine-approve

(comment best seen via the web interface)

fgiunchedi added a subscriber: fgiunchedi.