Page MenuHomePhabricator

1.35.0-wmf.10 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.35.0-wmf.10
Release Date
1575849600
Backup Conductor
Jdforrester-WMF

2019 week 50 1.35-wmf.10 Changes wmf/1.35.0-wmf.10

This MediaWiki Train Deployment is scheduled for the week of Monday, December 9th:

Monday December 9thTuesday, December 10thWednesday, December 11thThursday, December 12thFriday
SWAT deployments only.Branch wmf.10 and deploy to Group 0 Wikis.Deploy wmf.10 to Group 1 Wikis.Deploy wmf.10 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.10 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.35.0-wmf.9
Next: 1.35.0-wmf.11

Event Timeline

mmodell created this task.Sep 25 2019, 10:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2019, 10:14 PM
thcipriani assigned this task to dduvall.Dec 3 2019, 9:54 PM
thcipriani added subscribers: dduvall, thcipriani.

@dduvall as train conductor with @Jdforrester-WMF as backup.

Note for deployers (i.e. Dan): T240248 is ongoing. While not (yet) a blocker for this train, coordination with @awight is probably a good idea. James is fully apprised of the situation.

T240316 looks pretty bad for Wikidata. And if the problem is oauth I assume also others.

Mentioned in SAL (#wikimedia-operations) [2019-12-10T19:01:19Z] <marxarelli> cutting branch for 1.35.0-wmf.10 cc: T233858

Mentioned in SAL (#wikimedia-operations) [2019-12-10T21:25:14Z] <marxarelli> promoted group0 to 1.35.0-wmf.10 cc: T233858

mmodell updated Backup Conductor, added: Jdforrester-WMF.Dec 11 2019, 3:08 AM

Not a priority at all, but wherever the description content is actually set (edit task reveals nothing), forward.This is missing a space.

dduvall closed this task as Resolved.Dec 12 2019, 8:22 PM
dduvall triaged this task as Medium priority.