Page MenuHomePhabricator

1.35.0-wmf.31 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.35.0-wmf.31
Release Date
May 4 2020, 12:00 AM
Backup Conductor
hashar

2020 week 19 1.35-wmf.31 Changes wmf/1.35.0-wmf.31

This MediaWiki Train Deployment is scheduled for the week of Monday, May 4th:

Monday May 4thTuesday, May 5thWednesday, May 6thThursday, May 7thFriday
Backports only.Branch wmf.31 and deploy to Group 0 Wikis.Deploy wmf.31 to Group 1 Wikis.Deploy wmf.31 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.31 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.35.0-wmf.30
Next: 1.35.0-wmf.32

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2020, 10:29 PM
thcipriani triaged this task as Medium priority.
thcipriani updated Backup Conductor, added: hashar.
brennen moved this task from Backlog to Next on the User-brennen board.May 4 2020, 7:17 PM

Mentioned in SAL (#wikimedia-operations) [2020-05-05T16:18:53Z] <brennen> notice: planning branch cut for 1.35.0-wmf.31 (T249963) at 16:30 UTC

Mentioned in SAL (#wikimedia-operations) [2020-05-05T16:48:09Z] <brennen> 1.35.0-wmf.31 was branched at 4d3fed31a435e7bd24925a154f89a9407670986d for T249963

Mentioned in SAL (#wikimedia-operations) [2020-05-05T19:02:27Z] <brennen> train status: 1.35.0-wmf.31: presently pressing enter through scap-cdb-rebuild; at 8% (T249963, T223287)

brennen moved this task from Next to In Progress on the User-brennen board.May 5 2020, 9:21 PM

I'm not rolling back at present, but yeah, marking those as blockers for going forward.

I'm not rolling back at present, but yeah, marking those as blockers for going forward.

...so I caused three blockers for the train? Wow. Anyway, patches pending for both tasks, unable to test locally unfortunately

...so I caused three blockers for the train? Wow. Anyway, patches pending for both tasks, unable to test locally unfortunately

This seems to be pretty finicky work. Thanks for the rapid response.

...so I caused three blockers for the train? Wow. Anyway, patches pending for both tasks, unable to test locally unfortunately

This seems to be pretty finicky work. Thanks for the rapid response.

Both had +2 and are merging. Backports available:

DannyS712 added a project: User-DannyS712.EditedMay 5 2020, 9:38 PM
DannyS712 moved this task from Unsorted to In progress on the User-DannyS712 board.

I should be available to fix any more issues discovered with my revision work :)

<humor>jouncebot announces SWAT saying Note: If you break AND fix the wikis, you will be rewarded with a sticker. - what if you break AND fix core? three times?</humor>

Mentioned in SAL (#wikimedia-operations) [2020-05-06T19:03:05Z] <brennen> 1.35.0-wmf.31 train unblocked (T249963), rolling forward to group0

Mentioned in SAL (#wikimedia-operations) [2020-05-06T19:03:44Z] <brennen> CORRECTION: 1.35.0-wmf.31 train unblocked (T249963), rolling forward to group1

End-of-workday notes before I sign off: Stable on group1 as of this comment. It's confirmed that T252077 is not a blocker.

Rolled back to group0 at 02:56 UTC for T252079; writing a "blocked" status update mail.

brennen reassigned this task from brennen to hashar.May 7 2020, 3:44 AM
brennen added a subscriber: brennen.

Logging off; reassigning to Antoine for now as backup conductor in case the train can roll before I'm awake.

Change 594947 had a related patch set uploaded (by Hashar; owner: Hashar):
[operations/mediawiki-config@master] group1 wikis to 1.35.0-wmf.31 (2)

https://gerrit.wikimedia.org/r/594947

Change 594947 merged by jenkins-bot:
[operations/mediawiki-config@master] group1 wikis to 1.35.0-wmf.31 (2)

https://gerrit.wikimedia.org/r/594947

brennen claimed this task.May 7 2020, 3:42 PM
brennen added a subscriber: hashar.

Change 595030 had a related patch set uploaded (by Brennen Bearnes; owner: Brennen Bearnes):
[operations/mediawiki-config@master] Revert "all wikis to 1.35.0-wmf.31"

https://gerrit.wikimedia.org/r/595030

Change 595030 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "all wikis to 1.35.0-wmf.31"

https://gerrit.wikimedia.org/r/595030

Change 595075 had a related patch set uploaded (by Brennen Bearnes; owner: Brennen Bearnes):
[operations/mediawiki-config@master] All wikis except test to 1.35.0-wmf.30

https://gerrit.wikimedia.org/r/595075

Change 595075 merged by jenkins-bot:
[operations/mediawiki-config@master] All wikis except test to 1.35.0-wmf.30

https://gerrit.wikimedia.org/r/595075

Current status of T252179: Edits saved via PageUpdater need autopatrol status set:

  • All (5/5) reverts merged to respective master branches
  • No (0/4, one not needed) reverts merged to wmf.31
  • No (0/4) reverts deployed to wmf.31

For the train to proceed:

  • the 4 backports need to be merged
  • the 4 backports need to be deployed

Once unblocked, if mediawiki.org is updated to wmf.31, it should be easy to confirm that the issue was fixed

Mentioned in SAL (#wikimedia-operations) [2020-05-11T15:42:28Z] <brennen> syncing backports to 1.35.0-wmf.31 (T249963) for T252179

Mentioned in SAL (#wikimedia-operations) [2020-05-11T16:13:46Z] <brennen@deploy1001> rebuilt and synchronized wikiversions files: mediawikiwiki to 1.35.0-wmf.31 (T249963) for testing T252179

brennen closed this task as Resolved.May 11 2020, 6:18 PM

Appears stable on all wikis, but will continue monitoring. Thanks all for assistance with this one.

We've had a huge spikes on INSERTS on our primary masters - even though it has happened before and it is being tracked at T247028, this happened again right after yesterday's release see T247028#6128426
Not sure if we should reopen this task.

thcipriani reopened this task as Open.May 12 2020, 3:22 PM

We've had a huge spikes on INSERTS on our primary masters - even though it has happened before and it is being tracked at T247028, this happened again right after yesterday's release see T247028#6128426
Not sure if we should reopen this task.

Let's do, so we can block the next train while we investigate.

Jdforrester-WMF closed this task as Resolved.May 12 2020, 3:25 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Moved blocker dependency to T247028.