Page MenuHomePhabricator

"Share" button (tools) extension for Wikimedia projects
Open, NormalPublic

Description

Author: OmkarShetkar

Description:
I attended the recent 10th anniversary celebrations of Wikipedia in Bangalore. In the public event we had a discussion regarding giving socialization look to Wikipedia. On the contrary we had a view that it will dilute the very purpose of Wikipedia. Of course I agree that Wikipedia should not be used as a scratch pad to scribble something. It is a repository of authentic and informative knowledge. But that information should be sharable with others. It is the fact that user can reach to that information only if he is interested to know it. There is no chance that if one user finds one information very useful wants to share with others. Can we have popular SHARE button in Wikipedia? By this Wikipedia articles will have more number of visitors and possibly more contributors.

The extension is available, but has to be completed and is not in use anywhere: https://www.mediawiki.org/wiki/Extension:WikiShare


See Also:

Details

Reference
bz27027

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:17 PM
bzimport set Reference to bz27027.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jan 29 2011, 9:16 AM
Reedy added a comment.Jan 29 2011, 9:20 AM

Changing to extension requests

What do you mean by a "share button"? Easy-access links to share content on Facebook and Twitter and the like?

If so, this could probably be implemented in an extension (might be already, even), but might make more sense as site-wide JavaScript. It depends on how many sites want this feature and what level of control (localization, exclusion of certain share sites on some projects, etc.) is possible. Extensions are often more controllable and easier to install Wikimedia-wide.

This was recently brought up on en.wiki, discussion went the way that it should be a user js or gadget, Although I can't find the discussion I was thinking about, this one also covers it: http://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28technical%29/Archive_83#Revisiting_social_media_links

And here is a example of a share box implemented via user js: http://en.wikipedia.org/wiki/User:TheDJ/sharebox.js

I also know there are several extensions that already do this, but I don't know what type of state they are in.

Omkar, would the sharebox that p858snake pointed to solve this problem for you?

There's also several share templates in use that don't need custom js. See https://secure.wikimedia.org/wikinews/en/wiki/Template:Social_bookmarks for an example (although that one uses custom js to make short urls, but it works without it).

This would also be great on mobile.

  • Bug 31853 has been marked as a duplicate of this bug. ***

Another example of an implementation through site-wide JS/CSS changes is on the Hebrew Wikipedia. Here, the share features are simply part of the toolbox and only shown when the toolbox is expanded.

http://he.wikipedia.org/

admin wrote:

There are some additional notes on this topic here:
http://www.mediawiki.org/wiki/User:Dantman/Post_to_social_media_feeds

I've put up a temporary solution for Enterprise Wikis via AddThis:
http://www.mediawiki.org/wiki/Extension:AddThis

Are there others interested in collaborating on a more polished solution that would stand a chance at deployment on WMF wikis?

(In reply to comment #10)

There are some additional notes on this topic here:
http://www.mediawiki.org/wiki/User:Dantman/Post_to_social_media_feeds
I've put up a temporary solution for Enterprise Wikis via AddThis:
http://www.mediawiki.org/wiki/Extension:AddThis
Are there others interested in collaborating on a more polished solution that
would stand a chance at deployment on WMF wikis?

Issue is more that the Wikipedian's (or some groups of them anyways) don't want it.

admin wrote:

By chance, does anyone know when was it last brought up on WP? It's already active on some languages - so I'm curious of their opposition would still hold muster and how recent it was.

Plus at what point does the size of the vocal opposition come into consideration? From the discussions on WP I could find - it looked like a core minority voice. The traffic and popularity of these sites and features is staggering. Looking at the top 100 sites on the web - I think a case could be made that the web is reaching critical mass on that the topic of if sharing features are accepted and expected.

(In reply to comment #12)

By chance, does anyone know when was it last brought up on WP? It's already
active on some languages - so I'm curious of their opposition would still hold
muster and how recent it was.

About a week ago: http://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28proposals%29/Archive_81#Does_Wikipedia_need_a_.E2.80.9Cshare.E2.80.9D_button.3F

I agree its probably a vocal minority, but I don't really see how that changes things.

OTOH, en.wikipedia is not the be all and end all of the world. If there's other wikis who would benefit from a "sharing" extension (Commons, and Wikinews already use their own js I believe in addition to the other lang wp's mentioned above, and perhaps there are benefits from doing this in php instead of site js), then there still would be good reason to look into the issue.

admin wrote:

That's a fair point as well. I have to imagine it's time will eventually come on enWP. Although even reading that conversation - I would feel confident building evidence of enough support to move forward with at least a trial. The people who oppose it often cite technically (it allows FB to stalk you) or otherwise inaccurate statements (it turns WP into a social network). Taking them seriously is hard to do... :) As has been pointed out in several essays and discussions - you could get a vocal minority to oppose just about ANY change to the interface of WP. I imagine suggesting a print feature (I know it already exists) would get arguments about paper use hurting environment going against WP's digital purpose, etc...not even realizing it's already there. I suspect at some point someone authoritative is just going to have to press the green button. But I digress... :)

In the meantime, I think you're right, support for the language and other interested WMF wikis is a worthwhile undertaking. In particular I think good points have been brought up about the dangers in some of the solutions wikis are currently using - some of which some may argue violate WMF privacy polices, etc.

I'm confident there are workable solutions for non-WMF wikis, but feel a reasonable solution within the technical guidelines and ethos of WMF wikis is lacking.

Were already using this on the english signpost. Pick any article and click show. And its done in a way that doesn't reveal any personal data. And this is only one way to do it. We could also add share options by allowing users to opt into them. Register an account and then turn on any share options you want. That way users could be empowered to choose and not be beholden to a vocal minority.

admin wrote:

That's a great idea! Would also solve the problem of "playing favorites" amongst the services. Essentially any service could be added by a developer as an option for users. New to MW dev, what's the best next step?

Slightly off topic, but do you have any examples of anybody doing this in a way " which may argue violate WMF privacy polices"? (Just curious, personally I imagine that would be a bad thing if anyone is doing that).

I'm somewhat doubtful of the opt in, since i feel the benefit is primarily to newbies and anons, but that's just my opinion, so don't let that stop you from pursuing that line of coding.

admin wrote:

Bawolff: This is from long back (sorry about that) - but it looks like whoever may have been doing it cleaned it up. Someone mentioned it in IRC (I should have clarified that earlier) and I didn't think to ask where. I've done a sort of random sampling of WMF projects and didn't see anything odd. Not sure if it was happening and later removed - or it just appeared that way at one point. In any case - working on a new extension now: http://www.mediawiki.org/wiki/Extension:WikiShare

Once it's done I may visit all WMF projects to tally which have the share buttons and see if any are using APIs or such - if nothing else to let them know this extension is a possible solution. I like the idea of a more consistent use - especially for smaller or possibly less tech-savy projects.

The subject and first post of this report refers to Wikipedia.

We have also

Bug 57802 - An easy way to share wiki content on social media services

which is about MediaWiki in general. I'm not sure how much duplication there is between both reports, but in any case it is good to connect the old discussion with the new proposal for a Possible Project

  • Bug 57802 has been marked as a duplicate of this bug. ***

(In reply to comment #19)

The subject and first post of this report refers to Wikipedia.
We have also
Bug 57802 - An easy way to share wiki content on social media services
which is about MediaWiki in general.

Given that MediaWiki is the platform for Wikipedia, these bugs are duplicates.

I'm not sure how much duplication there is between both reports, but in any
case it is good to connect the old discussion with the new proposal for a
Possible Project

I'll copy the comments from bug 57802 below.

(Copied from bug 57802 comment 0)

An easy way to share wiki content on social media services

Wikipedia, as well as other wikis based on MediaWiki, provide an easy way to
accumulate and document knowledge, but it is difficult to share it on social
media. According to https://strategy.wikimedia.org/wiki/Product_Whitepaper 84%
of Wikimedia users were Facebook users as well in 2010, with the portion
incresing from previous years. The situation is probably similar with other
social media sites. It only makes sense to have an effective "bridge" between
MediaWiki and popular social media site. More details here.

Some previous work you can use as a base, improve, or learn from:

Extension:Widgets

Extension:WidgetsFramework - experimental extension

Extension:AddThis

Extension:Facebook - just Facebook

Extension:WikiShare - unstable version, seems like it's not worked on any more

Mentor: Yaron Koren

URL:https://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects#An_easy_way_to_share_wiki_content_on_social_media_services

(Copied from bug 57802 comment 1)

This proposal has been listed at
https://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects and we are
filing a report to gather community feedback and share updates.

Dzahn added a comment.Dec 3 2013, 9:08 PM

also see an enhancement request i made here for sharing after uploading images:

https://bugzilla.wikimedia.org/show_bug.cgi?id=40456

See also https://meta.wikimedia.org/wiki/Social_media_plugins which seems to be the main link-hub for related info.

Quiddity updated the task description. (Show Details)Dec 4 2014, 7:57 PM
Quiddity set Security to None.
Ricordisamoa added a subscriber: Ricordisamoa.
Dzahn removed a subscriber: Dzahn.Jan 12 2015, 4:38 PM
Jdlrobson moved this task from Needs triage to Triaged on the Mobile board.Jan 21 2015, 12:04 AM
Nemo_bis renamed this task from "Share" button (tools) in Wikipedia to "Share" button (tools) extension for Wikimedia projects.Jan 27 2015, 6:29 PM
Nemo_bis changed the task status from Open to Stalled.
Nemo_bis updated the task description. (Show Details)
Nemo_bis removed a project: Mobile.
Nemo_bis added a subscriber: Nemo_bis.EditedJan 27 2015, 6:37 PM

I'd consider this report WORKSFORME, because extensions already exist to do this. As for the Wikimedia site request/extension setup request, this is clearly INVALID at the moment for lack of consensus and rationale/requirements.

As for the rationale at https://www.mediawiki.org/wiki/Outreach_programs/Possible_projects#An_easy_way_to_share_wiki_content_on_social_media_services , which was also copied above, it's extremely weak, among other things because it's based on 2010 data. So far, no data was provided to prove e.g. that a significant audience of social websites is *not* using Wikimedia projects *and* would be within reach of users who *do* use them. I doubt we can find data on the effects of such buttons because there are few sites at a similar scale.

All in all, this is stalled and I suggest interested people to find or perform scientific research proving it's worth spending resources on this attempt, and/or to discuss on the relevant Meta-Wiki page, which already has more information and discussion than this report.

Wikimedia will apply to Google Summer of Code and Outreachy on Tuesday, February 17. If you want this task to become a featured project idea, please follow these instructions.

Quiddity updated the task description. (Show Details)Feb 13 2015, 11:32 PM

I will remove this task from Possible-Tech-Projects. In order to be featured for GSoC/Outreachy candidates, it will need two mentors with good backing and thick skin.

Izno updated the task description. (Show Details)Apr 27 2017, 1:50 PM
MacFan4000 closed this task as Resolved.Oct 23 2017, 7:55 PM
MacFan4000 claimed this task.
Quiddity reopened this task as Open.Oct 23 2017, 8:11 PM
Quiddity removed MacFan4000 as the assignee of this task.
Quiddity added a subscriber: MacFan4000.

Re-opening, as the task has not been resolved, merely one avenue closed off.

Sidenote: @MacFan4000 - Please be careful to not self-assign tasks you haven't worked on (I realize that Phabricator automatically does this for unassigned tasks when someone resolves them, so please fix this when closing tasks, thanks.)

Qgil removed a subscriber: Qgil.Nov 3 2017, 3:07 PM