Page MenuHomePhabricator

Parsoid should mark interwiki links as such
Closed, ResolvedPublic

Description

Right now there is no distinction between external links and interwiki links, except in data-parsoid (which is private). This makes it difficult for Flow (and other read HTML users) to style interwiki links correctly.

Related Objects

Event Timeline

Catrope created this task.Apr 23 2015, 11:59 PM
Catrope raised the priority of this task from to Needs Triage.
Catrope updated the task description. (Show Details)
Catrope added projects: Parsoid, Parsoid-DOM.
Catrope added a subscriber: Catrope.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 23 2015, 11:59 PM
Arlolra triaged this task as Normal priority.Jul 20 2015, 5:28 PM
Arlolra added a subscriber: Arlolra.

Related to T100856

This comment was removed by Josve05a.
Josve05a raised the priority of this task from Normal to High.Aug 7 2015, 4:07 PM
Josve05a lowered the priority of this task from High to Normal.

This was removed as part of T55432: Typeof cleanup and smart serialization of new language and interwiki links. With ISBN, RFC, etc links, it is possible for clients to figure this out, but this is far more complex for interwiki links. So, we should consider adding this back since this affects HTML clients that inspect Parsoid HTML (for semantics or for styling in UIs).

cscott added a subscriber: cscott.Sep 19 2017, 4:51 PM

Note:

This also causes [[:en:WP:Flow#Design FAQ]] -> https://en.wikipedia.org/wiki/Wikipedia:Flow#Design%20FAQ meaing that section links with spaces in them breaks. This is a huge...no-no.

the HTML5 ID stuff affects this too. I believe the default WMF config is to use legacy section IDs for interwiki links where we're not positive the other wiki is using new-style IDs yet. Parsoid doesn't make this distinction...

Krinkle removed a subscriber: Krinkle.Sep 19 2017, 8:36 PM
ssastry assigned this task to Sbailey.Oct 10 2017, 5:28 PM
ssastry moved this task from Link syntax (links & media) to Next Up on the Parsoid board.

Change 393832 had a related patch set uploaded (by Sbailey; owner: Sbailey):
[mediawiki/services/parsoid@master] WIP T97093 Interlink/WikiLink change

https://gerrit.wikimedia.org/r/393832

Change 393832 merged by jenkins-bot:
[mediawiki/services/parsoid@master] T97093: Use mw:WikiLink/InterWiki for interwiki links

https://gerrit.wikimedia.org/r/393832

Change 396069 had a related patch set uploaded (by C. Scott Ananian; owner: C. Scott Ananian):
[mediawiki/extensions/VisualEditor@master] Interwiki links are a type of external link

https://gerrit.wikimedia.org/r/396069

Arlolra closed this task as Resolved.Dec 12 2017, 8:07 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 12 2017, 8:07 PM

Change 396069 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Interwiki links are a type of external link

https://gerrit.wikimedia.org/r/396069

Bencemac added a comment.EditedDec 22 2017, 6:39 PM

Maybe because of the patch, now the external links look like interwiki links (without that little arrow) in 2017 wikitext editor's preview mode.

Example: "első körben itt"
https://www.facebook.com/SwordArtOnlineUSA/

Edited: @Arlolra Could you check this?

Bencemac reopened this task as Open.Jan 16 2018, 6:05 PM

See my previous comment. Now the problem is that, the external links look like interwiki links.

Maybe because of the patch, now the external links look like interwiki links (without that little arrow) in 2017 wikitext editor's preview mode.

Looks like that has been resolved in T58756 in February 2018.

matmarex closed this task as Resolved.May 8 2019, 10:13 PM