Create Wikivoyage Finnish
Closed, ResolvedPublic

Description

On behalf of the language committee, I'm requesting the creation of Wikivoyage Finnish.

https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikivoyage_Finnish

Language code: fi
Site URL: fi.wikivoyage.org
Project name: Wikimatkat
Project namespace: Wikimatkat
Project talk namespace: Keskustelu Wikimatkoista
Project logo: https://commons.wikimedia.org/wiki/File:Wikivoyage-Logo-fi.svg
Timezone: Europe/Helsinki

Local file uploads: disabled

Thank you.

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes
Acer added a comment.Nov 27 2016, 11:44 PM

OK, no problem. But just for the record, the dump doesnt include user accounts. It's not a full database, just an XML export. There are userpages but no actual accounts behind them. We added a prefix (WT-) to those userpages to make it clear they precede the migration to Wikimedia and avoid any possible future pagename conflict.

Okay... I'm talking about accounts/permissions because importing XML dumps is a privileged action, I can't just do it as a new user on a wiki.

Acer added a comment.Nov 27 2016, 11:56 PM

Ah, right. I misunderstood. Guess I'll have to nag a Steward then :)

Ah, right. I misunderstood. Guess I'll have to nag a Steward then :)

Importing new wikis is usually done by @MF-Warburg or @SPQRobin which are in the new-wikis-importer global group. Better to ask these two users as they're very experienced in doing this.

Nikki added a subscriber: Nikki.Nov 28 2016, 12:37 PM

Everything is already arranged about that.

@Krenair Does the operations/puppet gerrit changes need to be merged before or after wiki creation?

Given that this will be public and not require any Apache config changes to work (it's a language-project one where an existing wildcard should match), no puppet patches should be required beforehand. You could probably safely do the .labsdb alias change beforehand but I wouldn't do the restbase change until afterwards as I don't know how it might behave.

Nuria moved this task from Next Up to Ready to Deploy on the Analytics-Kanban board.
greg added a comment.Nov 30 2016, 5:02 PM

These patches look good to me, let's schedule deployment after the train (group1 1.29.0-wmf.3->1.29.0-wmf.4) on Wednesday? CC @greg

hey, sorry, I missed this. That's would have been fine :) Is it still possible or do you all want to wait until tomorrow (Thurs) or next week?

It's not too late to do it at the suggested time, is it?

greg added a comment.Nov 30 2016, 7:01 PM

If ya'll are ready, it's fine with me.

Change 323698 merged by Andrew Bogott:
Labs configuration for fi.wikivoyage.org

https://gerrit.wikimedia.org/r/323698

Nuria moved this task from Ready to Deploy to Done on the Analytics-Kanban board.Nov 30 2016, 9:32 PM

Change 323695 merged by jenkins-bot:
Initial configuration for fi.wikivoyage.org

https://gerrit.wikimedia.org/r/323695

Change 324614 had a related patch set uploaded (by Alex Monk):
Update SiteMatrix data fork for last 3 wiki creations

https://gerrit.wikimedia.org/r/324614

Change 324616 had a related patch set uploaded (by Alex Monk):
Whitelist fiwikivoyage

https://gerrit.wikimedia.org/r/324616

Change 324616 abandoned by Alex Monk:
Whitelist fiwikivoyage

Reason:
Just realised this is a duplicate of Ic7d67f1a

https://gerrit.wikimedia.org/r/324616

Change 323696 merged by Dzahn:
RESTBase configuration for fi.wikivoyage.org

https://gerrit.wikimedia.org/r/323696

Stuff to do:

  • RB restart
  • Parsoid deploy - @ssastry?
  • Labs replicas - @chasemp or @Andrew need to run something like maintain-views --databases fiwikivoyage --debug on the labsdb machines
  • Wikidata support - can you check this @hoo? I got a lot of 'done.' results but also 'No localisation cache found for English. Please run maintenance/rebuildLocalisationCache.php.' from some wikis - e.g. exception 969eedb7fd12a470d95b00dd
  • cxserver - I think this is blocked on imports or something? @Nikerabbit?
  • Determine $wgCategoryCollation - no idea

Change 324614 merged by jenkins-bot:
Update SiteMatrix data fork for last 3 wiki creations

https://gerrit.wikimedia.org/r/324614

Stuff to do:

  • Labs replicas - @chasemp or @Andrew need to run something like maintain-views --databases fiwikivoyage --debug on the labsdb machines

Also, make sure a valid row is added to meta_p so that the wiki is included in cross-wiki queries and global metrics.

yeah, do that with maintain-meta_p

hoo added a comment.Dec 1 2016, 1:14 AM
  • Wikidata support - can you check this @hoo? I got a lot of 'done.' results but also 'No localisation cache found for English. Please run maintenance/rebuildLocalisationCache.php.' from some wikis - e.g. exception 969eedb7fd12a470d95b00dd

Fixed by running mwscriptwikiset extensions/Wikidata/extensions/Wikibase/lib/maintenance/populateSitesTable.php wikidataclient.dblist --force-protocol https. There was a problem on fiwikivoyage, so I pruned the sites and site_identifiers tables there and ran the script again (just for that wiki).

Works now: https://www.wikidata.org/w/index.php?diff=412805985 / https://fi.wikivoyage.org/wiki/Etusivu

Mentioned in SAL (#wikimedia-operations) [2016-12-01T01:20:12Z] <hoo> Ran "CREATE TABLE wbc_entity_usage LIKE dewikivoyage.wbc_entity_usage;" for fiwikivoyage on db1075 (s3 master) (Related: T151570)

  • cxserver - I think this is blocked on imports or something? @Nikerabbit?

cxserver only supports Wikipedias right now, so nothing to do (cc @KartikMistry)

Change 323699 abandoned by Joal:
Configuration for fi.wikivoyage.org

Reason:
merged in that patch https://gerrit.wikimedia.org/r/#/c/324671 (sorry for the mess guys)

https://gerrit.wikimedia.org/r/323699

  • Labs replicas - @chasemp or @Andrew need to run something like maintain-views --databases fiwikivoyage --debug on the labsdb machines

done

Change 324766 had a related patch set uploaded (by Alex Monk):
Revert "Revert "RESTBase configuration for fi.wikivoyage.org""

https://gerrit.wikimedia.org/r/324766

Acer added a comment.Dec 2 2016, 1:22 PM

The inline language codes are linking to Wikipedias. So for instance, ;de: is linking to de.wp instead of de.wikivoyage. Not sure if that can be fixed locally? Is this it? https://fi.wikivoyage.org/wiki/Toiminnot:Interwiki

aude added a subscriber: aude.Dec 2 2016, 1:58 PM

@Acer i think it's an issue with the sites table. Can take a look....

aude added a comment.Dec 2 2016, 2:40 PM

In wikibase and the sites / site_identifiers table or config, I don't see anything obviously wrong but definitely see the issue on the wiki

aude added a comment.Dec 2 2016, 2:43 PM

@Stryn looks like that is the issue. thanks

Stuff to do:

Also, make sure a valid row is added to meta_p so that the wiki is included in cross-wiki queries and global metrics.

  • Labs replicas - @chasemp or @Andrew need to run something like maintain-views --databases fiwikivoyage --debug on the labsdb machines

done

Still needs to be added to meta_p. Per @chasemp, we may wanna avoid using the script and insert the row manually for now (specify at least dbname, slice and url). This is needed in order for contributions from this wiki to be included in various tools that assist editors in patrolling edits, discovering spam, vandalism and other quality issues.

So, updated list of stuff to do:

  • Interwiki map update - deploy https://gerrit.wikimedia.org/r/#/c/324918/
  • RB patch and restart - deployers lack permissions to do this, needs ops and ideally restbase-admins/restbase-roots
  • Parsoid deploy - deployers lack permissions to do this, probably needs deploy-server and maybe parsoid-admin or something
  • Labs replicas - ops (probably @chasemp or @Andrew) need to deal with meta_p, again deployers don't have the required permissions
  • Determine $wgCategoryCollation - no idea still
Acer added a comment.Dec 4 2016, 5:09 PM

Also, Finnish needs to be added to the Wikivoyage portal. (https://www.wikivoyage.org)
Both the direct link and as a language option for the search bar. Thanks,

Also, Finnish needs to be added to the Wikivoyage portal. (https://www.wikivoyage.org)
Both the direct link and as a language option for the search bar. Thanks,

This is handled through Meta-Wiki and later updates are pushed to Gerrit. I've not added the wiki to the Wikivoyage template there because Module:Project portal hasn't reported it as existent so maybe that's an indicative that the wiki needs to be added elsewhere in the config. EmausBot hasn't noticed it either. Will investigate.

Added and I'll try to take care of the gerrit stuff too.

Acer added a comment.Dec 4 2016, 5:47 PM

Added and I'll try to take care of the gerrit stuff too.

Thanks!

Change 325178 had a related patch set uploaded (by MarcoAurelio):
Updated stats and added fi.wikivoyage to the www.wikivoyage.org portal

https://gerrit.wikimedia.org/r/325178

They also asked fixing of inflected forms of sitename with {{GRAMMAR}} at https://fi.wikipedia.org/wiki/Wikipedia:Kahvihuone_(tekniikka)#Taivutusongelma. I can fix that easily.

Change 325178 merged by jenkins-bot:
Updated stats and added fi.wikivoyage to the www.wikivoyage.org portal

https://gerrit.wikimedia.org/r/325178

@Andrew) need to deal with meta_p, again deployers don't have the required permissions

A note (partially for myself) on meta_p. Need to come up with these values if the normal script is not working out to do a manual insert.

Example:

          dbname: huwikinews
            lang: hu
            name: Wikihírek
          family: wikinews
             url: https://hu.wikinews.org
            size: 1
           slice: s3.labsdb
       is_closed: 1
        has_echo: 0
 has_flaggedrevs: 0
has_visualeditor: 0
    has_wikidata: 1
    is_sensitive: 0

@Andrew) need to deal with meta_p, again deployers don't have the required permissions

A note (partially for myself) on meta_p. Need to come up with these values if the normal script is not working out to do a manual insert.

Example:

         dbname: huwikinews
            lang: hu
            name: Wikihírek
          family: wikinews
             url: https://hu.wikinews.org
            size: 1
           slice: s3.labsdb
       is_closed: 1
        has_echo: 0
 has_flaggedrevs: 0
has_visualeditor: 0
    has_wikidata: 1
    is_sensitive: 0

I can't believe I'm helping bypass running another maintenance script, but you can easily (after applying my commit from August to fix the existing script) modify the script to dump that:
{'has_wikidata': 1, 'slice': 's3.labsdb', 'is_sensitive': 0, 'name': 'Wikimatkat', 'has_flaggedrevs': 0, 'has_visualeditor': 1, 'lang': 'fi', 'is_closed': 0, 'size': 1, 'family': 'wikivoyage', 'dbname': 'fiwikivoyage', 'url': 'https://fi.wikivoyage.org'}

  • RB patch and restart - deployers lack permissions to do this, needs ops and ideally restbase-admins/restbase-roots
  • Labs replicas - @chasemp likely to manually insert into meta_p
  • Determine $wgCategoryCollation - no idea still
Stryn added a comment.Dec 8 2016, 12:12 PM

It is known that VisualEditor is still not working on the project? It just blanks the page. For example https://fi.wikivoyage.org/wiki/Cēsis?veaction=edit

That's the main thing we need RESTBase support for. In future I'm thinking maybe have VE disabled by default until after RB has begun to recognise the wiki.

@jcrespo

Can you help me fix this sometime this week?

pymysql.err.OperationalError: (1044, u"Access denied for user 'maintainviews'@'localhost' to database 'meta_p'")

I think it's reasonable to piggyback the maintain-meta_p use case onto the maintainviews user as they are part of the same package deal etc. Sometime in the near future I would like to fold meta_p maintenance into the maintain-views script even.

Hey @chasemp!

Do you need ALL privileges for maintainviews@localhost for the meta_p database then?
Where is that meta_p DB, I cannot see it in labsdb1009 but I can see it in labsdb1003 for instance (sorry if I am missing some context!).
Also looking at: modules/toollabs/files/sql I can see it is supposed to be on s7?

I have been talking to Chase on IRC and he gave me all the info needed.
We did the first test with labsdb1009 and it worked, so we have propagated the new grants to labsdb1001,1003,1010 and 1011

I have been talking to Chase on IRC and he gave me all the info needed.
We did the first test with labsdb1009 and it worked, so we have propagated the new grants to labsdb1001,1003,1010 and 1011

Thank you sir.

MariaDB MARIADB labsdb1001 meta_p > select * from wiki where dbname='fiwikivoyage'\G;
*************************** 1. row ***************************
          dbname: fiwikivoyage
            lang: fi
            name: Wikimatkat
          family: wikivoyage
             url: https://fi.wikivoyage.org
            size: 1
           slice: s3.labsdb
       is_closed: 0
        has_echo: 0
 has_flaggedrevs: 0
has_visualeditor: 1
    has_wikidata: 1
    is_sensitive: 0
1 row in set (0.00 sec)

hotpatched w/ https://gerrit.wikimedia.org/r/#/c/325949/ to get it done

Thanks Chase. That leaves RB (which I will be having words with certain people about) and collation (which @Dereckson might know about?)

Ideal collation candidate is uca-fi, already used by other Finnish projects.

Where is it configured?

Dereckson added a comment.EditedDec 11 2016, 11:12 AM

Where is it configured?

$wgCategoryCollation in wmf-config/InitialiseSettings.php, around line 14200.

Change 326409 had a related patch set uploaded (by Odder):
Set $wgCategoryCollation for Finnish Wikivoyage

https://gerrit.wikimedia.org/r/326409

https://wikitech.wikimedia.org/w/index.php?title=Add_a_wiki&diff=1126855&oldid=1069881
godog/Filippo has offered to look at the RB patch probably this week

Stryn added a comment.Dec 21 2016, 5:49 PM

Seems like no progress has happened since the last message. As the VE is the default editor for IP's and other users on the Wikivoyage, I hope that those who have tried editing there have figured out how to change to the wikitext editor.

Change 324766 merged by Giuseppe Lavagetto:
Revert "Revert "RESTBase configuration for fi.wikivoyage.org""

https://gerrit.wikimedia.org/r/324766

Change 326409 merged by jenkins-bot:
Set $wgCategoryCollation for Finnish Wikivoyage

https://gerrit.wikimedia.org/r/326409

Mentioned in SAL (#wikimedia-operations) [2017-01-11T21:03:12Z] <Reedy> update collation of fiwikivoyage T151570

Krenair closed this task as Resolved.Jan 11 2017, 9:12 PM
Krenair claimed this task.

I think this is done.

Meno25 removed a subscriber: Meno25.Jan 13 2017, 6:32 AM