Page MenuHomePhabricator

Revert to last revision by user should not mention
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Make an edit to some page
  2. Let somebody (User A) edit the page after you
  3. Let somebody else (User B) revert that edit from User A to the last revision before, which you did

Expected behavior
Nothing should happen. This is not anything you as an author of the previous revision should be aware of.

Current behavior
You are notified someone's edit was reverted back to your revision.

Example
Today I got mention from this edit: https://www.mediawiki.org/w/index.php?title=Translations:Help:Logging_in/Page_display_title/cs&oldid=prev&diff=2737190 which made me to fill in a task here. See the history of that page to understand, what happenned.

Event Timeline

Dvorapa created this task.Mar 15 2018, 9:15 PM
Restricted Application added subscribers: Zoranzoki21, Aklapper. · View Herald TranscriptMar 15 2018, 9:15 PM
TBolliger added a subscriber: TBolliger.

I will note that the revert message is decided by the wiki. So for example, the English wikipedia message will not send out such pings. Nor will Spanish.
It will for French and Hindi.
Etc.

We can probably ignore the entire message in case of reverts. @MaxSem knows more about it than I do.

MusikAnimal added a subscriber: MusikAnimal.EditedMar 15 2018, 9:44 PM

Yeah it looks like mediawiki.org is using the default message, while enwiki and others have a customized one.

For the time being I've manually updated the message on mediawiki.org, so you shouldn't get pinged anymore.

It appears reverts are ignored when the "undo" method was used, but not when "rollback" was used. This seems like an error, since they were supposed to all be ignored per comments on the parent task (T32750#3997501).

It seems that the $undidRevId parameter is not passed to the 'PageContentSaveComplete' hook when rollbacking, but Echo code assumes it is.

Yes I think you're right.. let's focus on fixing that? Nevermind updating the messages =p

MaxSem claimed this task.Mar 15 2018, 10:38 PM

Jumping on the bandwagon here. I'm getting way too many emails from this. :p

Same here. It affects bot accounts significantly. For example; my bot (TurkászBot) has the latest edit on many pages, which means I got plenty of notification in short period.

Stryn added a subscriber: Stryn.Mar 16 2018, 8:20 AM

There is the same problem on Wikipedia in Italian, cf. https://meta.wikimedia.org/wiki/Talk:Community_Tech/Ping_users_from_the_edit_summary#Reverts_to_last_edit_by_XXX
There is the same problem on Wikidata: I have been notified for the edit https://www.wikidata.org/w/index.php?title=Q1420&oldid=prev&diff=650083501

I suspect that it comes from https://translatewiki.net/wiki/MediaWiki:Revertpage ...and its numerous subpages... but I have no account on translatewiki.net...

Conny added a subscriber: Conny.Mar 16 2018, 8:33 AM
Matthiasb added a subscriber: Matthiasb.EditedMar 16 2018, 9:48 AM

<s>Sorry, no. It is correct that people are notified if their contribution was reverted.

Else this should be hardcoded, so local admins cannot circumvent the feature like happened in DE:WP in https://de.wikipedia.org/wiki/Spezial:Diff/175063376</s>

Revoking comment; local community users convinced me that for most users my preference won't apply.

Daimona added a subscriber: Daimona.
Cirdan added a subscriber: Cirdan.Mar 16 2018, 10:07 AM
It is correct that people are notified if their contribution was reverted.

This is not what this task is about. The feature you are mentioning has existed for a long time.

Nnvu added a subscriber: Nnvu.Mar 16 2018, 1:11 PM

As a workaround for it.wiki, we edited the MediaWiki:Revertpage message to use [[:User:$1|$1]]. Definitely not the definitive solution, but at least it should work until a better solution is found.

New feedback about that issue. That's a bit bothering, like the user mentioned:

That's true that I am quite active, but receiving notifications when other users revert back to a version that I authored is distracting and not requested.

I set up email filters, but I'm having to set up multiple filters for the different languages my bot runs on, which is 13 at current.

Niharika triaged this task as High priority.Mar 16 2018, 5:32 PM
Niharika edited projects, added Community-Tech-Sprint; removed Community-Tech.

Increasing the priority on this.

I do not understand in these things as you do, of course, so I'm curious: Why do you not just add a colon to the message original text?

I do not understand in these things as you do, of course, so I'm curious: Why do you not just add a colon to the message original text?

Too many messages to update. And because the software change broke this, I think the fix should be made in the feature. If it turns out very hard to do that, then we can change the messages.

If people do want to change the messages in the meanwhile to mitigate the issue, they can do what @Daimona did above -

As a workaround for it.wiki, we edited the MediaWiki:Revertpage message to use [[:User:$1|$1]]. Definitely not the definitive solution, but at least it should work until a better solution is found.

Change 420125 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/core@master] Pass revision being reverted to edit code

https://gerrit.wikimedia.org/r/420125

Change 420133 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/extensions/Echo@master] Properly handle undos/reverts and links in them

https://gerrit.wikimedia.org/r/420133

Maybe the original MediaWiki message could use a colon as well. Depending on local customization just creates more issues, even if Max is fixing the underlying issue in Echo itself.

He7d3r added a subscriber: He7d3r.Mar 19 2018, 10:57 AM

Change 420125 merged by jenkins-bot:
[mediawiki/core@master] Pass revision being reverted to edit code

https://gerrit.wikimedia.org/r/420125

Maybe the original MediaWiki message could use a colon as well. Depending on local customization just creates more issues, even if Max is fixing the underlying issue in Echo itself.

My gut feeling is that anything in MediaWiki core should not depend on/be affected by an extension (Echo in this case).
And even if we do update the default wording, a lot of wikis have their own modified messages which we'd have to fix anyway.
We're not depending on local customization though. The patch above is to not send out *any* notifications from a non-manual revert, irrespective of project/language.

Change 420133 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Properly handle undos/reverts and links in them

https://gerrit.wikimedia.org/r/420133

Change 422079 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/extensions/Echo@master] Detect reverts differently

https://gerrit.wikimedia.org/r/422079

Change 422079 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Detect reverts differently

https://gerrit.wikimedia.org/r/422079

TBolliger closed this task as Resolved.Mar 27 2018, 9:05 PM
TBolliger moved this task from Needs Review/Feedback to Q1 2018-19 on the Community-Tech-Sprint board.