Invite to participate in research from the translation dashboard
Closed, ResolvedPublic

Description

The Research team (Research) is working on an area that is relevant to Content Translation, and needs contributions that are related to translation. Since this may be relevant to Content Translation users we want to invite them to participate in this research.

The proposal is to show a message where we explain the purpose of the invite and provide options to join the experiment or discard the message. Some more details:

  • The invite will be shown on the suggestions tab of the translation dashboard.
  • The invite will be shown when both the source and target languages selected for suggestions belong to the list of languages the research is targeting (Arabic, Japanese, English, French, Spanish, Russian).
  • Discarding the invite won't show it again for the user.
  • Accepting the invite will lead the user to http://gapfinder-tools.wmflabs.org/section-alignment/?s=en&d=ru (where s and d will be the language codes for source and destination languages the user selected)
  • The invite will be available for about 2 weeks.

The invite will be developed in a way that can be repurposed in the future. The idea is to use a similar invite to encourage users to try the version 2 of Content Translation when it is ready for a wider exposure.

Design details

The graphical asset for the icon is shown below:

Text for the message:

Help to improve this tool. We want to make it easy to extend existing articles when translating, and you can help the research behind it.

Actions:

  • Participate in the research
  • No, thanks

The mockup below shows the idea:

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2018, 9:42 AM
Pginer-WMF triaged this task as Normal priority.May 11 2018, 9:42 AM
Pginer-WMF raised the priority of this task from Normal to High.May 31 2018, 7:45 AM
Pginer-WMF updated the task description. (Show Details)May 31 2018, 7:47 AM
Pginer-WMF updated the task description. (Show Details)Jun 7 2018, 10:17 AM

@Pginer-WMF, is that message displayed when people choose pairs of languages or by default? If by default, there is a risk that people feel surprised when they will see language that are not theirs.

Also, most people having wok in progress on CX have a direct access to the "In progress" page than the "Suggestions" one, right? Will they see that message?

@Pginer-WMF, is that message displayed when people choose pairs of languages or by default? If by default, there is a risk that people feel surprised when they will see language that are not theirs.

The message will be shown only when the selected language pair is one of the language pairs that are relevant for the research study, and the target link will include the language parameters for people to provide translations on the same languages by default. That is, a user that selected Russian-to-Japanese will see the invite and reach the research page for those languages.

Also, most people having wok in progress on CX have a direct access to the "In progress" page than the "Suggestions" one, right? Will they see that message?

The initial idea is to show the invite on the suggestions view only. There is a significant percentage of people that create translations by suing suggestions, those people may also more open to try new things (as opposed to go to the tool to translate specific article they already have in mind).
We can consider making the invite more visible by showing it in other views, but note that for the In-progress view the default language filters are "All languages" to "All languages", which makes it hard to target the right users.

Change 438119 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Create invitation widget

https://gerrit.wikimedia.org/r/438119

Change 438120 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Invite to participate in research from the translation dashboard

https://gerrit.wikimedia.org/r/438120

On gerrit patch, @Esanders wrote about the icon:

This didn't read as a test tube to me, probably because of the closed top. Also there is already a chemistry icon in the Math extension that you could re-use:
https://github.com/wikimedia/mediawiki-extensions-Math/blob/master/modules/ve-math/chem.svg

On gerrit patch, @Esanders wrote about the icon:

This didn't read as a test tube to me, probably because of the closed top. Also there is already a chemistry icon in the Math extension that you could re-use:
https://github.com/wikimedia/mediawiki-extensions-Math/blob/master/modules/ve-math/chem.svg

The chemistry icons among other advanced editing icons are in a process of revision. @Volker_E was in favour of the use of the test tube metaphor, but we can keep using the current one for now in order to avoid delays due to icon debates. Here is the blue version if needed:

Change 438119 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Create invitation widget

https://gerrit.wikimedia.org/r/438119

Change 438120 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Invite to participate in research from the translation dashboard

https://gerrit.wikimedia.org/r/438120

When will it be out? I'm asking for User-notice.

When will it be out? I'm asking for User-notice.

It will go along with a train this week.

When will it be out? I'm asking for User-notice.

It will go along with a train this week.

IIRC, there is no train this week, while the Release Engineering team has an offsite.
Anyway, that should be in the next edition of Tech News.

Etonkovidova closed this task as Resolved.Jun 19 2018, 12:31 AM
Etonkovidova added a subscriber: Etonkovidova.

Checked in cx-testing for different browsers. All specs are in place (the icon looks a little bit too small, but the icon size was small in the mockup too, so it's subjective).

@Pginer-WMF

  • Discarding the invite won't show it again for the user.

The invite will appear again if the same user logs in from a different computer or a browser.

  • Discarding the invite won't show it again for the user.

The invite will appear again if the same user logs in from a different computer or a browser.

Yes, that is to be expected. We have agreed to use local storage here and local storage is browser local. We don't use database in this case to simplify the process of getting invitation in production, because it will be displayed for 2-4 weeks.

The ticket description says:

The invite will be developed in a way that can be repurposed in the future. The idea is to use a similar invite to encourage users to try the version 2 of Content Translation when it is ready for a wider exposure.

Because of this, DB usage might be needed in the future to save the user's choice, but we don't need it yet.

Please note, translation TO enwiki are currently restricted by way of an edit filter to those that are extendedconfirmed. Just an FYI (see https://en.wikipedia.org/wiki/WP:CXT)

Trizek-WMF added a comment.EditedJun 26 2018, 12:24 PM

Please note, translation TO enwiki are currently restricted by way of an edit filter to those that are extendedconfirmed. Just an FYI (see https://en.wikipedia.org/wiki/WP:CXT)

I don't think it will impact much while that experiment is not asking people to create translations using CX. We try to find people interested by certain pairs of languages, nothing more. :)

Vvjjkkii renamed this task from Invite to participate in research from the translation dashboard to g5caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Petar.petkovic as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot assigned this task to Petar.petkovic.
CommunityTechBot closed this task as Resolved.
CommunityTechBot renamed this task from g5caaaaaaa to Invite to participate in research from the translation dashboard.
CommunityTechBot added subscribers: gerritbot, Aklapper.