New diffs show lines in the wrong order
Closed, ResolvedPublic8 Story Points

Description

It's the third time for the last 10 days that I see diffs basically spoiled: the lines in the right column are in the wrong order. Haven't found an existing task, maybe I searched badly.

  1. https://ru.wikipedia.org/w/index.php?title=Шаблон:Результат_выборов&diff=93301102&oldid=58674687&diffmode=source
| page     = {{#if: {{{1|}}} | Википедия:Заявки на статус администратора/{{{1}}}{{#if: {{{номер|}}} | _{{{номер}}} }} }}

part is shown below

}}

while it's actually above

| template = Шаблон:Результат выборов администратора
  1. https://ru.wikipedia.org/w/index.php?title=Шаблон:Кабинет_министров_Израиля&diff=prev&oldid=93086598
|стиль_групп     = text-align:center; background:{{Цвет/Израиль}};

is below

|класс_тела      = hlist

Actually it's above

|стиль_тела      =
  1. https://ru.wikipedia.org/w/index.php?title=MediaWiki:Gadget-referenceTooltips.js&diff=prev&oldid=93294312

The same story with the line

					if ( mw.loader.getState( 'oojs-ui' ) !== 'ready' ) {
There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 13 2018, 5:20 PM
SerDIDG added a subscriber: SerDIDG.

(I assume "new diff engine" refers to T195375.)

Jack_who_built_the_house renamed this task from New diff engine shows lines in the wrong order to New diffs show lines in the wrong order.Jun 15 2018, 6:36 PM
Vvjjkkii renamed this task from New diffs show lines in the wrong order to q2aaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot renamed this task from q2aaaaaaaa to New diffs show lines in the wrong order.
CommunityTechBot added a subscriber: Aklapper.
Pipetricker added a subscriber: Pipetricker.EditedJul 5 2018, 9:19 AM

Another example (from User:Larske at svwiki):

https://sv.wikipedia.org/w/index.php?title=Tom_Tits_Experiment&diff=next&oldid=43109604

Notice that the bullet points are ordered by year, but in the diff, the 2017 line appears out of order, after the 2018 line in the right column.

Larske added a subscriber: Larske.Jul 5 2018, 9:22 AM

I guess T199770 and T195951 are duplicate?

Yes, pretty much looks like.

WMDE-Fisch set the point value for this task to 5.
WMDE-Fisch added subscribers: jkroll, WMDE-Fisch.

We will have a look at this at least an investigation if the regression is caused by changes on wikidiff2. @jkroll

Change 450024 had a related patch set uploaded (by Jkroll; owner: Jkroll):
[mediawiki/php/wikidiff2@master] [WiP] Fix ordering of lines in some diffs

https://gerrit.wikimedia.org/r/450024

WMDE-Fisch changed the point value for this task from 5 to 8.

Change 452925 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/php/wikidiff2@master] Streamline and document detectDissimilarChanges implementation

https://gerrit.wikimedia.org/r/452925

T202190 is probably the same issue.

Change 450024 merged by jenkins-bot:
[mediawiki/php/wikidiff2@master] Fix misplaced ordering of lines in some diffs

https://gerrit.wikimedia.org/r/450024

We could fix this issue and will start releasing and deploying the fixed version as soon as possible.

Change 452925 merged by jenkins-bot:
[mediawiki/php/wikidiff2@master] Streamline and document detectDissimilarChanges implementation

https://gerrit.wikimedia.org/r/452925

Lea_WMDE closed this task as Resolved.Aug 23 2018, 10:27 AM
Lea_WMDE removed a project: User-notice.
Lea_WMDE added a subscriber: Lea_WMDE.

@matej_suchanek This will be released with a new version of the wikidiff2 library, meaning outside of the train. The new wikidiff2 release is going to take some more time, see T202301. Can we postpone the announcement until we actually deploy?

Lea_WMDE reopened this task as Open.Aug 23 2018, 10:28 AM

My intention was to tell the folks this is a known problem, it was patched and the fix will be deployed soon. This would also give them the ability to track the progress since you already have a task for it. Re-adding User-notice, so that this issue is not forgotten and letting chief TN editors decide.

thanks for clarifying :)

WMDE-Fisch closed this task as Resolved.Sep 4 2018, 1:43 PM

The deployment of the bugfixed version for that issue was just finished today so the problem should be resolved. I checked the linked diffs and they seemed all fine now.