Page MenuHomePhabricator

Personalized first day: translate and test copy
Closed, ResolvedPublic

Description

This task will mostly be for @Trizek-WMF. After the copy for the new survey is written in T206375 (including questions, headers, buttons, and other text), we will need to translate it into Czech and Korean, and make sure that Czech and Korean respondents share an understanding with our team over what the questions and responses mean.

We will likely want to test these with multiple speakers of those languages.

Event Timeline

Restricted Application added a subscriber: revi. · View Herald TranscriptOct 6 2018, 12:54 AM
Trizek-WMF changed the task status from Open to Stalled.Oct 8 2018, 2:25 PM
Trizek-WMF claimed this task.
Trizek-WMF triaged this task as Normal priority.
Trizek-WMF moved this task from Inbox to Upcoming Work on the Growth-Team board.

Stalled until the source messages are ready.

However, @MMiller_WMF I would advise to have those messages on Translatewiki as a separate group, so that we can potentially work with more communities.

Restricted Application added a subscriber: Urbanecm. · View Herald TranscriptOct 11 2018, 4:58 PM

@Trizek-WMF -- could you please tell us some more about whether we should expect to use Translatewiki for this, or to translate locally? @SBisson, @RHo, @Catrope, and I were wondering what to plan for.

MMiller_WMF renamed this task from Personalized first day: translate and test survey questions to Personalized first day: translate and test copy.Oct 18 2018, 8:20 PM
MMiller_WMF updated the task description. (Show Details)

Use translatewiki.net

  • Pros:
    • we can open Personalized First day to more wikis almost when we want because translations would be ready (the translatewiki community is really reactive)
  • Cons:
    • for now (and until fixed, WIP), sync with translatewiki is only done once a week through the train

Have local messages

  • Pros:
    • we can try different messages for each wiki (translatewiki messages are translations of a source) and update them whenever we want (there is a delay from translatewiki). However, that works as well if we use translatewiki, while it is possible to override locally any message. (That a weak pro.)
  • Cons:
    • if the tool remains in production for whatever reason, a transfer to translatewiki will have to be made again (no idea on how complicated that is)
JTannerWMF set Due Date to Oct 31 2018, 12:00 AM.Oct 19 2018, 8:06 PM
Restricted Application changed the subtype of this task from "Task" to "Deadline". · View Herald TranscriptOct 19 2018, 8:06 PM

Use translatewiki.net

  • Pros:
    • we can open Personalized First day to more wikis almost when we want because translations would be ready (the translatewiki community is really reactive)
  • Cons:
    • for now (and until fixed, WIP), sync with translatewiki is only done once a week through the train

Really? I thought there was no special deploy window for localized strings. IIRC i18n cache rebuild is done only on train and deployers tend to avoid it in SWATs, because it (IIRC) require full scap, which takes up to 45 minutes, while SWAT is one hour and should deploy 6 patches.

Have local messages

  • Pros:
    • we can try different messages for each wiki (translatewiki messages are translations of a source) and update them whenever we want (there is a delay from translatewiki). However, that works as well if we use translatewiki, while it is possible to override locally any message. (That a weak pro.)
  • Cons:
    • if the tool remains in production for whatever reason, a transfer to translatewiki will have to be made again (no idea on how complicated that is)

If you delete message from the en.json file, it won't be deleted automatically from translatewiki.net. If you think you need it again, you will not do the manual deletion part.

revi added a comment.Oct 20 2018, 3:32 AM

Use translatewiki.net

  • Pros:
    • we can open Personalized First day to more wikis almost when we want because translations would be ready (the translatewiki community is really reactive)
  • Cons:
    • for now (and until fixed, WIP), sync with translatewiki is only done once a week through the train

Relevant task: T205563 and T206694 IIRC.

@MMiller_WMF, is the deadline for that task still relevant? IIRC, there is no text already available to translate.

Brief update: we will be loading the text to Translatewiki this week, hopefully within a couple days.

Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald TranscriptOct 30 2018, 5:16 PM

The Welcome survey messages are now in TWN under the ext-growthexperiments-welcomesurvey message group.

See https://translatewiki.net/wiki/Special:MessageGroupStats?group=ext-growthexperiments-welcomesurvey&suppressempty=1&x=D

The Welcome survey messages are now in TWN under the ext-growthexperiments-welcomesurvey message group.
See https://translatewiki.net/wiki/Special:MessageGroupStats?group=ext-growthexperiments-welcomesurvey&suppressempty=1&x=D

Hi Stephane, why is welcomesurvey-sidebar-editing-link3-text and others in https://github.com/wikimedia/mediawiki-extensions-GrowthExperiments/blob/master/i18n/welcomesurvey/en.json empty? It caused empty messages on Translatewiki.net created. If we do not want to use those messages anymore, we should probably delete them from en.json (and qqq.json, if present) and inform TWN to delete those messages from their system (IIRC messages won't get deleted otherwise).

The Welcome survey messages are now in TWN under the ext-growthexperiments-welcomesurvey message group.
See https://translatewiki.net/wiki/Special:MessageGroupStats?group=ext-growthexperiments-welcomesurvey&suppressempty=1&x=D

Hi Stephane, why is welcomesurvey-sidebar-editing-link3-text and others in https://github.com/wikimedia/mediawiki-extensions-GrowthExperiments/blob/master/i18n/welcomesurvey/en.json empty? It caused empty messages on Translatewiki.net created. If we do not want to use those messages anymore, we should probably delete them from en.json (and qqq.json, if present) and inform TWN to delete those messages from their system (IIRC messages won't get deleted otherwise).

Hi Martin, the 4 messages related to editing link 3 and link 4 are left blank intentionally. We have messages for 4 links in the "Getting started with editing" side panel but we're only using 2 of them at the moment. They are defined so we can quickly have between 0 and 4 links on different wikis without changing the code. Each link has a message that ends with -text and one that ends with -title.

You can submit blank (like de has done) or ignore them (like ko has done) and it's fine.

Thank you for explaining it.

Since the messages are on Translatewiki, I am now putting this in progress.

FYI @revi @Urbanecm

@Urbanecm and @revi -- could you please confirm on this ticket that you have looked over the translations? @Urbanecm, I noticed that three messages are untranslated in Czech.

https://translatewiki.net/w/i.php?title=Special:MessageGroupStats&group=ext-growthexperiments-welcomesurvey

revi added a comment.Nov 7 2018, 5:26 PM

Confirmed.

MMiller_WMF changed the task status from Stalled to Open.Nov 8 2018, 7:58 PM

@revi and @Urbanecm -- we now have the survey available in the Beta Cluster. It would be great if you could try it out. We're interested in your opinions on all the parts, but in particular, we want you to make sure the translations are all rendering correctly, and nothing is cut off, and that they make sense in the context of the survey. Here are the links for your two languages:

Would you be able to do this by Tuesday, 2018-11-13?

@Urbanecm and @revi -- could you please confirm on this ticket that you have looked over the translations? @Urbanecm, I noticed that three messages are untranslated in Czech.
https://translatewiki.net/w/i.php?title=Special:MessageGroupStats&group=ext-growthexperiments-welcomesurvey

Confirmed.

@revi and @Urbanecm -- we now have the survey available in the Beta Cluster. It would be great if you could try it out. We're interested in your opinions on all the parts, but in particular, we want you to make sure the translations are all rendering correctly, and nothing is cut off, and that they make sense in the context of the survey. Here are the links for your two languages:

Would you be able to do this by Tuesday, 2018-11-13?

No, because the links you gave us doesn't work. They redirects to the main page. How can I check it if I cannot view the survey?

@Urbanecm -- sorry about that. I think what happened is that your account is in the control group (the group that does not get the survey, for the purposes of our experiment. To make sure you get the survey, you can add &welcome-survey-experimental-group=exp1_group1 to the URL.

So like this:

Does that work?

Yes, thank you.

CS and KO are 100% translated. Good job!

@revi and @Urbanecm, have you done the tests?

revi added a comment.Nov 14 2018, 1:50 PM

Beta Labs is not happy with me - my first session failed and I needed to create another account, which prompted me to log in again immediately after I created an account and clicking 'done' prompted me to log in, again...

But whatever, I found one problem with translation (fixed now).
And I'm wondering - if account creator (or admin) creates an account for someone else, do they see this page when users log in for the first time? I am periodically creating 5 to 10 accounts every two weeks or so as part of outreach events, and I'm wondering if they will see this survey.

@revi -- that's an interesting question. I didn't know admins could make accounts for others. @SBisson, do you know the answer?

@revi -- that's an interesting question. I didn't know admins could make accounts for others. @SBisson, do you know the answer?

Everybody, it is not limited to admins. Admins can only bypass six account limit. Just enter Special:CreateAccount to the search box on any wiki while you're logged in.

When you create an account that way, IIRC the user has to log-in. If we can detect if that's the first connexion for the account, we can display the survey. I've created a sub-ticket: T209583: Accounts created using Special:CreateAccount should trigger the survey at the first connexion

And I'm wondering - if account creator (or admin) creates an account for someone else, do they see this page when users log in for the first time? I am periodically creating 5 to 10 accounts every two weeks or so as part of outreach events, and I'm wondering if they will see this survey.

Accounts created on behalf of someone else are excluded from the survey. I don't know if they fit the population we are currently looking at. I think maybe "retention among users who start by attending a workshop" is an interesting but different research question.

From @nettrom_WMF

  1. "they are likely to not be "new" users;
  2. previous research (e.g. ACTRIAL) indicates they behave quite differently from non-autocreated accounts;
  3. we don't have hypotheses about differences between these types of accounts; and
  4. we shouldn't store more data than we need.”
Trizek-WMF closed this task as Resolved.Nov 15 2018, 5:07 PM

checking confirmed by @revi in comments and by @Urbanecm in meeting.